summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2016-09-29 18:31:40 (GMT)
committerElan Ruusamäe2016-09-29 18:31:50 (GMT)
commitd367262775625a9ce6fb490cd58628866bbeefcf (patch)
tree2508b2cfbe2f4f34c461382881b25e9f9b68d7b1
downloaddocker-credential-helpers-d367262775625a9ce6fb490cd58628866bbeefcf.zip
docker-credential-helpers-d367262775625a9ce6fb490cd58628866bbeefcf.tar.gz
new, version 0.3.0
http://www.projectatomic.io/blog/2016/03/docker-credentials-store/
-rw-r--r--docker-credential-helpers.spec44
1 files changed, 44 insertions, 0 deletions
diff --git a/docker-credential-helpers.spec b/docker-credential-helpers.spec
new file mode 100644
index 0000000..0aa5bde
--- /dev/null
+++ b/docker-credential-helpers.spec
@@ -0,0 +1,44 @@
+Summary: Native credentials store for Docker
+Name: docker-credential-helpers
+Version: 0.3.0
+Release: 1
+License: MIT
+Group: Applications
+Source0: https://github.com/docker/docker-credential-helpers/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: dcd544bb5898713e27130a15070ed044
+URL: https://github.com/docker/docker-credential-helpers
+BuildRequires: golang >= 1.3.1
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define _enable_debug_packages 0
+%define gobuild(o:) go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
+%define gopath %{_libdir}/golang
+%define import_path github.com/docker/%{name}
+
+%description
+docker-credential-helpers is a suite of programs to use native stores
+to keep Docker credentials safe.
+
+%prep
+%setup -q
+
+install -d src/$(dirname %{import_path})
+ln -s ../../.. src/%{import_path}
+
+%build
+export GOPATH=$(pwd)
+
+%gobuild -o bin/docker-credential-secretservice secretservice/cmd/main_linux.go
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
+install -p bin/* $RPM_BUILD_ROOT%{_bindir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README.md CHANGELOG.md LICENSE
+%attr(755,root,root) %{_bindir}/docker-credential-secretservice