summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2018-12-01 14:23:52 (GMT)
committerJan Palus2018-12-01 14:23:52 (GMT)
commitf6620652e43854bf5057225e8c6fc83e132714ca (patch)
treec79650135438a167f070f641c575f01d69c09db1
parentd412c73fcc72076ccdcdead03f95f42847c064e4 (diff)
downloaddocker-compose-f6620652e43854bf5057225e8c6fc83e132714ca.zip
docker-compose-f6620652e43854bf5057225e8c6fc83e132714ca.tar.gz
-rw-r--r--docker-compose.spec7
-rw-r--r--remove-requires-upper-bound.patch41
2 files changed, 25 insertions, 23 deletions
diff --git a/docker-compose.spec b/docker-compose.spec
index c628ede..d49ded4 100644
--- a/docker-compose.spec
+++ b/docker-compose.spec
@@ -7,13 +7,13 @@
%define pypi_name docker-compose
Summary: Multi-container orchestration for Docker
Name: docker-compose
-Version: 1.22.0
-Release: 2
+Version: 1.23.2
+Release: 1
License: Apache v2.0
Group: Applications/System
# https://github.com/docker/compose/releases
Source0: https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
-# Source0-md5: 2c6030d4f7267a583a16debfd493e4a7
+# Source0-md5: 717831bff861e88d848477e2cd438030
Patch0: remove-requires-upper-bound.patch
URL: https://docs.docker.com/compose/
%if %{with tests}
@@ -28,6 +28,7 @@ BuildRequires: python-websocket-client
BuildRequires: rpm-pythonprov
BuildRequires: rpmbuild(macros) >= 1.714
Requires: docker(engine) >= 1.10.0
+Requires: python-docker >= 3.6.0
BuildArch: noarch
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
diff --git a/remove-requires-upper-bound.patch b/remove-requires-upper-bound.patch
index 2d84dc8..ccdc05a 100644
--- a/remove-requires-upper-bound.patch
+++ b/remove-requires-upper-bound.patch
@@ -6,35 +6,36 @@ diff -ur docker-compose-1.19.0.orig/requirements.txt docker-compose-1.19.0/requi
-cached-property==1.3.0
-certifi==2017.4.17
-chardet==3.0.4
--docker==3.4.1
+-colorama==0.4.0; sys_platform == 'win32'
+-docker==3.6.0
-docker-pycreds==0.3.0
-dockerpty==0.4.1
-docopt==0.6.2
-enum34==1.1.6; python_version < '3.4'
-functools32==3.2.3.post2; python_version < '3.2'
+-idna==2.5
+-ipaddress==1.0.18
+-jsonschema==2.6.0
+-pypiwin32==219; sys_platform == 'win32' and python_version < '3.6'
+-pypiwin32==223; sys_platform == 'win32' and python_version >= '3.6'
+-PySocks==1.6.7
+-PyYAML==3.12
+-requests==2.20.0
+-six==1.10.0
+-texttable==0.9.1
+-urllib3==1.21.1; python_version == '3.3'
+-websocket-client==0.32.0
+backports.ssl-match-hostname; python_version < '3'
+cached-property
+certifi
+chardet
++colorama; sys_platform == 'win32'
+docker
+docker-pycreds
+dockerpty
+docopt
+enum34; python_version < '3.4'
+functools32; python_version < '3.2'
- git+git://github.com/tartley/colorama.git@bd378c725b45eba0b8e5cc091c3ca76a954c92ff; sys_platform == 'win32'
--idna==2.5
--ipaddress==1.0.18
--jsonschema==2.6.0
--pypiwin32==219; sys_platform == 'win32' and python_version < '3.6'
--pypiwin32==220; sys_platform == 'win32' and python_version >= '3.6'
--PySocks==1.6.7
--PyYAML==3.12
--requests==2.18.4
--six==1.10.0
--texttable==0.9.1
--urllib3==1.21.1
--websocket-client==0.32.0
+idna
+ipaddress
+jsonschema
@@ -44,7 +45,7 @@ diff -ur docker-compose-1.19.0.orig/requirements.txt docker-compose-1.19.0/requi
+requests
+six
+texttable
-+urllib3
++urllib3; python_version == '3.3'
+websocket-client
diff -ur docker-compose-1.19.0.orig/setup.py docker-compose-1.19.0/setup.py
--- docker-compose-1.19.0.orig/setup.py 2018-03-05 21:55:17.014552784 +0100
@@ -56,10 +57,10 @@ diff -ur docker-compose-1.19.0.orig/setup.py docker-compose-1.19.0/setup.py
- 'cached-property >= 1.2.0, < 2',
- 'docopt >= 0.6.1, < 0.7',
- 'PyYAML >= 3.10, < 4',
-- 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.19',
+- 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.21',
- 'texttable >= 0.9.0, < 0.10',
- 'websocket-client >= 0.32.0, < 1.0',
-- 'docker >= 3.4.1, < 4.0',
+- 'docker >= 3.6.0, < 4.0',
- 'dockerpty >= 0.4.1, < 0.5',
- 'six >= 1.3.0, < 2',
- 'jsonschema >= 2.5.1, < 3',
@@ -69,7 +70,7 @@ diff -ur docker-compose-1.19.0.orig/setup.py docker-compose-1.19.0/setup.py
+ 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0',
+ 'texttable >= 0.9.0',
+ 'websocket-client >= 0.32.0',
-+ 'docker >= 3.4.1',
++ 'docker >= 3.6.0',
+ 'dockerpty >= 0.4.1',
+ 'six >= 1.3.0',
+ 'jsonschema >= 2.5.1',
@@ -84,9 +85,9 @@ diff -ur docker-compose-1.19.0.orig/setup.py docker-compose-1.19.0/setup.py
+ ':python_version < "3.4"': ['enum34 >= 1.0.4'],
':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
':python_version < "3.3"': ['ipaddress >= 1.0.16'],
-- ':sys_platform == "win32"': ['colorama >= 0.3.9, < 0.4'],
+- ':sys_platform == "win32"': ['colorama >= 0.4, < 0.5'],
- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
-+ ':sys_platform == "win32"': ['colorama >= 0.3.9'],
++ ':sys_platform == "win32"': ['colorama >= 0.4'],
+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
}