summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2016-11-27 12:45:25 (GMT)
committerElan Ruusamäe2016-11-27 12:45:25 (GMT)
commitd4e83a27302321f1a63f27920855696b0d737e9b (patch)
treeec100a26c8962f8ea49c226e8ccb9f91d785ef12
parent390264ed9f416ed2814eee7c601622f482dfdbb5 (diff)
downloaddocker-compose-d4e83a27302321f1a63f27920855696b0d737e9b.zip
docker-compose-d4e83a27302321f1a63f27920855696b0d737e9b.tar.gz
up to 1.9.0 (2016-11-16)auto/th/docker-compose-1.9.0-1
New Features - Interactive mode for `docker-compose run` and `docker-compose exec` is now supported on Windows platforms. Please note that the `docker` binary is required to be present on the system for this feature to work. - Introduced version 2.1 of the `docker-compose.yml` specification. This version requires to be used with Docker Engine 1.12 or above. - Added support for setting volume labels and network labels in `docker-compose.yml`. - Added support for the `isolation` parameter in service definitions. - Added support for link-local IPs in the service networks definitions. - Added support for shell-style inline defaults in variable interpolation. The supported forms are `${FOO-default}` (fall back if FOO is unset) and `${FOO:-default}` (fall back if FOO is unset or empty). - Added support for the `group_add` and `oom_score_adj` parameters in service definitions. - Added support for the `internal` and `enable_ipv6` parameters in network definitions. - Compose now defaults to using the `npipe` protocol on Windows. - Overriding a `logging` configuration will now properly merge the `options` mappings if the `driver` values do not conflict. Bug Fixes - Fixed a bug where an empty `restart` value would sometimes result in an exception being raised. - Fixed an issue where service logs containing unicode characters would sometimes cause an error to occur. - Fixed a bug where unicode values in environment variables would sometimes raise a unicode exception when retrieved. - Fixed an issue where Compose would incorrectly detect a configuration mismatch for overlay networks.
-rw-r--r--docker-compose.spec4
-rw-r--r--remove-requires-upper-bound.patch9
2 files changed, 2 insertions, 11 deletions
diff --git a/docker-compose.spec b/docker-compose.spec
index 5b3b93b..6a1f1a8 100644
--- a/docker-compose.spec
+++ b/docker-compose.spec
@@ -7,13 +7,13 @@
%define pypi_name docker-compose
Summary: Multi-container orchestration for Docker
Name: docker-compose
-Version: 1.8.1
+Version: 1.9.0
Release: 1
License: Apache v2.0
Group: Applications/System
# https://github.com/docker/compose/releases
Source0: https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
-# Source0-md5: 561104fef1c11d5b39b4627fc7fccf8b
+# Source0-md5: a5be1ba6b6868c14e40f651f368f5622
Patch0: remove-requires-upper-bound.patch
URL: https://docs.docker.com/compose/
%if %{with tests}
diff --git a/remove-requires-upper-bound.patch b/remove-requires-upper-bound.patch
index 50c0da5..14fda09 100644
--- a/remove-requires-upper-bound.patch
+++ b/remove-requires-upper-bound.patch
@@ -1,14 +1,5 @@
--- docker-compose-1.7.1/setup.py~ 2016-05-04 21:52:57.000000000 +0300
+++ docker-compose-1.7.1/setup.py 2016-05-19 14:24:16.408589040 +0300
-@@ -31,7 +31,7 @@
- 'cached-property >= 1.2.0, < 2',
- 'docopt >= 0.6.1, < 0.7',
- 'PyYAML >= 3.10, < 4',
-- 'requests >= 2.6.1, < 2.8',
-+ 'requests >= 2.6.1',
- 'texttable >= 0.8.1, < 0.9',
- 'websocket-client >= 0.32.0, < 1.0',
- 'docker-py >= 1.8.1, < 2',
@@ -47,8 +47,8 @@