summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2020-06-03 15:35:18 (GMT)
committerJan Palus2020-06-03 15:35:18 (GMT)
commit1bdf357e6267d2afb2688bd091ce5715303a83fe (patch)
treeb25d1aca3147bcc310512cf83ca44a58dd5b25b0
parent48b788cd6fc5e27af35755db4224f85892867dac (diff)
downloaddocker-compose-1bdf357e6267d2afb2688bd091ce5715303a83fe.zip
docker-compose-1bdf357e6267d2afb2688bd091ce5715303a83fe.tar.gz
-rw-r--r--docker-compose.spec8
-rw-r--r--remove-requires-upper-bound.patch32
2 files changed, 24 insertions, 16 deletions
diff --git a/docker-compose.spec b/docker-compose.spec
index 5fcfbdc..405f36e 100644
--- a/docker-compose.spec
+++ b/docker-compose.spec
@@ -7,13 +7,13 @@
%define pypi_name docker-compose
Summary: Multi-container orchestration for Docker
Name: docker-compose
-Version: 1.25.5
-Release: 2
+Version: 1.26.0
+Release: 1
License: Apache v2.0
Group: Applications/System
# https://github.com/docker/compose/releases
Source0: https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
-# Source0-md5: a6f296957148e4c61b28fb324c27c966
+# Source0-md5: f7d54de5db1f17322c09db8157bd160f
Patch0: remove-requires-upper-bound.patch
URL: https://docs.docker.com/compose/
%if %{with tests}
@@ -29,7 +29,7 @@ BuildRequires: python-websocket-client
BuildRequires: rpm-pythonprov
BuildRequires: rpmbuild(macros) >= 1.714
Requires: docker(engine) >= 1.10.0
-Requires: python-docker >= 3.6.0
+Requires: python-docker >= 4.2.1
Requires: python-paramiko >= 2.4.2
Requires: python-setuptools
BuildArch: noarch
diff --git a/remove-requires-upper-bound.patch b/remove-requires-upper-bound.patch
index 6f2bfb5..874d5ae 100644
--- a/remove-requires-upper-bound.patch
+++ b/remove-requires-upper-bound.patch
@@ -1,14 +1,14 @@
-diff -ur docker-compose-1.25.2.orig/requirements.txt docker-compose-1.25.2/requirements.txt
---- docker-compose-1.25.2.orig/requirements.txt 2020-01-21 18:13:39.348446291 +0100
-+++ docker-compose-1.25.2/requirements.txt 2020-01-21 18:15:48.717904899 +0100
-@@ -1,26 +1,25 @@
+--- docker-compose-1.26.0/requirements.txt.orig 2020-06-03 17:13:24.695266751 +0200
++++ docker-compose-1.26.0/requirements.txt 2020-06-03 17:15:46.190749529 +0200
+@@ -1,29 +1,28 @@
-backports.shutil_get_terminal_size==1.0.0
-backports.ssl-match-hostname==3.5.0.1; python_version < '3'
-cached-property==1.5.1
--certifi==2019.11.28
+-certifi==2020.4.5.1
-chardet==3.0.4
-colorama==0.4.3; sys_platform == 'win32'
--docker==4.1.0
+-distro==1.5.0
+-docker==4.2.1
-docker-pycreds==0.4.0
-dockerpty==0.4.1
-docopt==0.6.2
@@ -21,12 +21,14 @@ diff -ur docker-compose-1.25.2.orig/requirements.txt docker-compose-1.25.2/requi
-pypiwin32==219; sys_platform == 'win32' and python_version < '3.6'
-pypiwin32==223; sys_platform == 'win32' and python_version >= '3.6'
-PySocks==1.7.1
+-python-dotenv==0.13.0
-PyYAML==5.3
-requests==2.22.0
-six==1.12.0
-subprocess32==3.5.4; python_version < '3.2'
-texttable==1.6.2
-urllib3==1.25.7; python_version == '3.3'
+-wcwidth==0.1.9
-websocket-client==0.57.0
+backports.shutil_get_terminal_size
+backports.ssl-match-hostname; python_version < '3'
@@ -34,6 +36,7 @@ diff -ur docker-compose-1.25.2.orig/requirements.txt docker-compose-1.25.2/requi
+certifi
+chardet
+colorama; sys_platform == 'win32'
++distro
+docker
+docker-pycreds
+dockerpty
@@ -46,17 +49,18 @@ diff -ur docker-compose-1.25.2.orig/requirements.txt docker-compose-1.25.2/requi
+paramiko
+pypiwin32; sys_platform == 'win32'
+PySocks
++python-dotenv
+PyYAML
+requests
+six
+subprocess32; python_version < '3.2'
+texttable
+urllib3; python_version == '3.3'
++wcwidth
+websocket-client
-diff -ur docker-compose-1.25.2.orig/setup.py docker-compose-1.25.2/setup.py
---- docker-compose-1.25.2.orig/setup.py 2020-01-20 18:06:19.000000000 +0100
-+++ docker-compose-1.25.2/setup.py 2020-01-21 18:17:44.417383294 +0100
-@@ -30,16 +30,16 @@
+--- docker-compose-1.26.0/setup.py.orig 2020-06-03 17:13:24.695266751 +0200
++++ docker-compose-1.26.0/setup.py 2020-06-03 17:17:48.769056566 +0200
+@@ -30,18 +30,18 @@
install_requires = [
@@ -66,24 +70,28 @@ diff -ur docker-compose-1.25.2.orig/setup.py docker-compose-1.25.2/setup.py
- 'requests >= 2.20.0, < 3',
- 'texttable >= 0.9.0, < 2',
- 'websocket-client >= 0.32.0, < 1',
+- 'distro >= 1.5.0, < 2',
- 'docker[ssh] >= 3.7.0, < 5',
- 'dockerpty >= 0.4.1, < 1',
- 'six >= 1.3.0, < 2',
- 'jsonschema >= 2.5.1, < 4',
+- 'python-dotenv >= 0.13.0, < 1',
+ 'cached-property >= 1.2.0',
+ 'docopt >= 0.6.1',
+ 'PyYAML >= 3.10',
+ 'requests >= 2.20.0',
+ 'texttable >= 0.9.0',
+ 'websocket-client >= 0.32.0',
++ 'distro >= 1.5.0',
+ 'docker[ssh] >= 3.7.0',
+ 'dockerpty >= 0.4.1',
+ 'six >= 1.3.0',
+ 'jsonschema >= 2.5.1',
++ 'python-dotenv >= 0.13.0',
]
-@@ -52,13 +52,13 @@
+@@ -55,13 +55,13 @@
tests_require.append('mock >= 1.0.1, < 4')
extras_require = {
@@ -101,6 +109,6 @@ diff -ur docker-compose-1.25.2.orig/setup.py docker-compose-1.25.2/setup.py
+ 'ipaddress >= 1.0.16'],
+ ':sys_platform == "win32"': ['colorama >= 0.4'],
+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
+ 'tests': tests_require,
}
-