summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2014-04-06 09:06:33 (GMT)
committerJakub Bogusz2014-04-06 10:01:13 (GMT)
commita547a50f7fd42160f1870979d4a762a5fabd1649 (patch)
tree3e2696dc68a61f75ffd28e28ffc691d7a5288807
parent464e5352c23317c0011323d0e7f373ce50bbeaaa (diff)
downloadctl-a547a50f7fd42160f1870979d4a762a5fabd1649.zip
ctl-a547a50f7fd42160f1870979d4a762a5fabd1649.tar.gz
- new URLs, updated to 1.5
- openexr_ctl and ctlrender are now included - removed obsolete include patch - added libdir patch (honour LIB_SUFFIX) - added ctlrender patch (build not installed libctldpx as static)
-rw-r--r--ctl-ctlrender.patch10
-rw-r--r--ctl-include.patch31
-rw-r--r--ctl-libdir.patch45
-rw-r--r--ctl.spec145
4 files changed, 172 insertions, 59 deletions
diff --git a/ctl-ctlrender.patch b/ctl-ctlrender.patch
new file mode 100644
index 0000000..84095fb
--- /dev/null
+++ b/ctl-ctlrender.patch
@@ -0,0 +1,10 @@
+--- CTL-ctl-1.5/lib/dpx/CMakeLists.txt.orig 2013-10-22 19:39:04.000000000 +0200
++++ CTL-ctl-1.5/lib/dpx/CMakeLists.txt 2014-04-06 09:42:18.259636939 +0200
+@@ -1,6 +1,6 @@
+ include_directories( "${CMAKE_CURRENT_SOURCE_DIR}" )
+
+-add_library( ctldpx
++add_library( ctldpx STATIC
+ dpx.cc
+ dpx_raw.cc
+ dpx_read.cc
diff --git a/ctl-include.patch b/ctl-include.patch
deleted file mode 100644
index d9c7c2e..0000000
--- a/ctl-include.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- ctl-1.4.1/IlmCtl/CtlLex.cpp.orig 2007-03-20 18:48:40.000000000 +0100
-+++ ctl-1.4.1/IlmCtl/CtlLex.cpp 2013-03-28 18:59:30.520355166 +0100
-@@ -57,6 +57,7 @@
- #include <CtlLContext.h>
- #include <iomanip>
- #include <cassert>
-+#include <cstdlib>
-
-
- #if 0
---- ctl-1.4.1/IlmCtlSimd/CtlSimdReg.h.orig 2006-11-30 02:46:44.000000000 +0100
-+++ ctl-1.4.1/IlmCtlSimd/CtlSimdReg.h 2013-03-28 19:05:40.243672986 +0100
-@@ -49,6 +49,7 @@
- #ifndef INCLUDED_CTL_SIMD_REG_H
- #define INCLUDED_CTL_SIMD_REG_H
-
-+#include <cstring>
- #include <typeinfo>
- #include <CtlExc.h>
- #include <Iex.h>
---- ctl-1.4.1/IlmCtl/CtlInterpreter.cpp.orig 2006-12-14 23:43:55.000000000 +0100
-+++ ctl-1.4.1/IlmCtl/CtlInterpreter.cpp 2013-03-28 22:09:59.194860880 +0100
-@@ -69,6 +69,8 @@
- #include <io.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#else
-+ #include <unistd.h>
- #endif
-
- using namespace std;
diff --git a/ctl-libdir.patch b/ctl-libdir.patch
new file mode 100644
index 0000000..9d2a6a2
--- /dev/null
+++ b/ctl-libdir.patch
@@ -0,0 +1,45 @@
+--- CTL-ctl-1.5/lib/IlmImfCtl/CMakeLists.txt.orig 2013-10-22 19:39:04.000000000 +0200
++++ CTL-ctl-1.5/lib/IlmImfCtl/CMakeLists.txt 2014-04-06 08:31:55.806391615 +0200
+@@ -13,4 +13,4 @@
+
+ export( TARGETS IlmImfCtl IlmCtl FILE "${PROJECT_BINARY_DIR}/CTLLibraryDepends.cmake" )
+
+-install( TARGETS IlmImfCtl DESTINATION lib )
++install( TARGETS IlmImfCtl DESTINATION lib${LIB_SUFFIX} )
+--- CTL-ctl-1.5/lib/IlmCtl/CMakeLists.txt.orig 2013-10-22 19:39:04.000000000 +0200
++++ CTL-ctl-1.5/lib/IlmCtl/CMakeLists.txt 2014-04-06 08:32:32.226390855 +0200
+@@ -50,4 +50,4 @@
+ CtlVersion.h
+ DESTINATION include/CTL )
+
+-install( TARGETS IlmCtl DESTINATION lib )
++install( TARGETS IlmCtl DESTINATION lib${LIB_SUFFIX} )
+--- CTL-ctl-1.5/lib/IlmCtlMath/CMakeLists.txt.orig 2013-10-22 19:39:04.000000000 +0200
++++ CTL-ctl-1.5/lib/IlmCtlMath/CMakeLists.txt 2014-04-06 08:32:50.143057151 +0200
+@@ -20,6 +20,6 @@
+ CtlSparseMatrix.h
+ DESTINATION include/CTL )
+
+-install( TARGETS IlmCtlMath DESTINATION lib )
++install( TARGETS IlmCtlMath DESTINATION lib${LIB_SUFFIX} )
+
+ # TODO Add Imath and Iex libadd dependency and version info
+--- CTL-ctl-1.5/lib/IlmCtlSimd/CMakeLists.txt.orig 2013-10-22 19:39:04.000000000 +0200
++++ CTL-ctl-1.5/lib/IlmCtlSimd/CMakeLists.txt 2014-04-06 08:33:07.246390126 +0200
+@@ -42,4 +42,4 @@
+
+ install( FILES CtlSimdInterpreter.h DESTINATION include/CTL )
+
+-install( TARGETS IlmCtlSimd DESTINATION lib )
++install( TARGETS IlmCtlSimd DESTINATION lib${LIB_SUFFIX} )
+--- CTL-ctl-1.5/CMakeLists.txt.orig 2013-10-22 19:39:04.000000000 +0200
++++ CTL-ctl-1.5/CMakeLists.txt 2014-04-06 08:35:26.706387222 +0200
+@@ -77,7 +77,7 @@
+
+ if ( PKG_CONFIG_FOUND )
+ configure_file(config/CTL.pc.in "${PROJECT_BINARY_DIR}/CTL.pc" @ONLY)
+-install( FILES "${PROJECT_BINARY_DIR}/CTL.pc" DESTINATION lib/pkgconfig COMPONENT dev )
++install( FILES "${PROJECT_BINARY_DIR}/CTL.pc" DESTINATION lib${LIB_SUFFIX}/pkgconfig COMPONENT dev )
+ endif()
+
+ install( FILES
diff --git a/ctl.spec b/ctl.spec
index edfc86a..3c445c9 100644
--- a/ctl.spec
+++ b/ctl.spec
@@ -1,17 +1,23 @@
Summary: Color Transform Language libraries
Summary(pl.UTF-8): Biblioteki CTL (języka przekształceń kolorów)
Name: ctl
-Version: 1.4.1
-Release: 2
+Version: 1.5
+Release: 1
License: BSD + IP clause
Group: Libraries
-Source0: http://downloads.sourceforge.net/ampasctl/%{name}-%{version}.tar.gz
-# Source0-md5: 11e215aea6c6380833ade3b576660638
-Patch0: %{name}-include.patch
+Source0: https://github.com/ampas/CTL/archive/%{name}-%{version}.tar.gz
+# Source0-md5: 020aa09422c13b2f62c1c40f18d9d093
+Patch0: %{name}-libdir.patch
+Patch1: %{name}-ctlrender.patch
URL: http://www.oscars.org/science-technology/council/projects/ctl.html
-BuildRequires: ilmbase-devel >= 1.0.1
+BuildRequires: OpenEXR-devel
+BuildRequires: aces_container-devel
+BuildRequires: cmake >= 2.8
+BuildRequires: ilmbase-devel >= 2.0.0
BuildRequires: libstdc++-devel
+BuildRequires: libtiff-devel
BuildRequires: pkgconfig
+Requires: ilmbase >= 2.0.0
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%description
@@ -45,8 +51,9 @@ Summary: Header files for CTL library
Summary(pl.UTF-8): Pliki nagłówkowe biblioteki CTL
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
-Requires: ilmbase-devel >= 1.0.1
+Requires: ilmbase-devel >= 2.0.0
Requires: libstdc++-devel
+Obsoletes: ctl-static
%description devel
Header files for CTL library.
@@ -54,24 +61,93 @@ Header files for CTL library.
%description devel -l pl.UTF-8
Pliki nagłówkowe biblioteki CTL.
-%package static
-Summary: Static CTL library
-Summary(pl.UTF-8): Statyczna biblioteka CTL
+%package -n openexr_ctl
+Summary: OpenEXR interface to CTL (Color Transform Language)
+Summary(pl.UTF-8): Interfejs OpenEXR do CTL (języka przekształceń kolorów)
+Group: Libraries
+Requires: ctl = %{version}-%{release}
+
+%description -n openexr_ctl
+IlmImfCtl provides a simplified OpenEXR interface to CTL (Color
+Transform Language).
+
+%description -n openexr_ctl -l pl.UTF-8
+IlmImfCtl udostępnia uproszczony interfejs OpenEXR do CTL (języka
+przekształceń kolorów).
+
+%package -n openexr_ctl-devel
+Summary: Header files for IlmInfCtl library
+Summary(pl.UTF-8): Pliki nagłówkowe biblioteki IlmInfCtl
Group: Development/Libraries
-Requires: %{name}-devel = %{version}-%{release}
+Requires: OpenEXR-devel
+Requires: ctl-devel = %{version}-%{release}
+Requires: openexr_ctl = %{version}-%{release}
+Obsoletes: openexr_ctl-static
+
+%description -n openexr_ctl-devel
+Header files for IlmInfCtl library.
+
+%description -n openexr_ctl-devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki IlmInfCtl.
+
+%package -n openexr_ctl-progs
+Summary: Programs utilizing OpenEXR/CTL interface
+Summary(pl.UTF-8): Programy wykorzystujące interfejs OpenEXR/CTL
+Group: Applications/Graphics
+Requires: openexr_ctl = %{version}-%{release}
+
+%description -n openexr_ctl-progs
+Programs utilizing OpenEXR/CTL interface:
+
+exrdpx is an initial version of a CTL-driven file converter that
+translates DPX files into OpenEXR files and vice versa. The conversion
+between the DPX and OpenEXR color spaces is handled by CTL transforms.
+
+exr_ctl_exr is an initial version of a program that can bake the
+effect of a series of CTL transforms into the pixels of an OpenEXR
+file.
+
+%description -n openexr_ctl-progs -l pl.UTF-8
+Programy wykorzystujące interfejs OpenEXR/CTL:
+
+exrdpx to wstępna wersja konwertera plików sterowanego CTL-em,
+tłumaczącego pliki DPX na OpenEXR i na odwrót. Przekształcenia między
+przestrzeniami kolorów DPX i OpenEXR są obsługiwane przez
+przekształcenia CTL.
-%description static
-Static CTL library.
+exr_ctl_exr to wstępna wersja programu potrafiącego zamienić efekt
+serii przekształceń CTL na piksele w pliku OpenEXR.
-%description static -l pl.UTF-8
-Statyczna biblioteka CTL.
+%package -n ctlrender
+Summary: CLI application to apply CTL transforms to an image
+Summary(pl.UTF-8): Uruchamiany z linii poleceń program do nakładania przekształceń CTL na obraz
+Group: Applications/Graphics
+Requires: ctl = %{version}-%{release}
+
+%description -n ctlrender
+ctlrender is a command line application for applying CTL transforms to
+an image using one or more CTL scripts, potentially converting the
+file format in the process.
+
+ctlrender supports OpenEXR, TIFF, DPX, and ACES container file
+formats.
+
+%description -n ctlrender
+ctlrender to uruchamiany z linii poleceń program do nakładania
+przekształceń CTL na obraz przy użyciu jednego lub więcej skryptów
+CTL, potencjalnie także zmieniając w trakcie format pliku.
+
+ctlrender obsługuje formaty plików OpenEXR, TIFF, DPX oraz ACES.
%prep
-%setup -q
+%setup -q -n CTL-%{name}-%{version}
%patch0 -p1
+%patch1 -p1
%build
-%configure
+%cmake . \
+ -DINSTALL_CMAKE_DIR=%{_libdir}/cmake/CTL \
+ -DINSTALL_LIB_DIR=%{_libdir}
%{__make}
%install
@@ -80,6 +156,9 @@ rm -rf $RPM_BUILD_ROOT
%{__make} install \
DESTDIR=$RPM_BUILD_ROOT
+# packaged as %doc
+%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/CTL
+
%clean
rm -rf $RPM_BUILD_ROOT
@@ -88,13 +167,10 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(644,root,root,755)
-%doc AUTHORS COPYING ChangeLog NEWS README
+%doc AUTHORS CHANGELOG LICENSE README.md
%attr(755,root,root) %{_libdir}/libIlmCtl.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libIlmCtl.so.2
%attr(755,root,root) %{_libdir}/libIlmCtlMath.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libIlmCtlMath.so.2
%attr(755,root,root) %{_libdir}/libIlmCtlSimd.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libIlmCtlSimd.so.2
%files devel
%defattr(644,root,root,755)
@@ -102,14 +178,27 @@ rm -rf $RPM_BUILD_ROOT
%attr(755,root,root) %{_libdir}/libIlmCtl.so
%attr(755,root,root) %{_libdir}/libIlmCtlMath.so
%attr(755,root,root) %{_libdir}/libIlmCtlSimd.so
-%{_libdir}/libIlmCtl.la
-%{_libdir}/libIlmCtlMath.la
-%{_libdir}/libIlmCtlSimd.la
%{_includedir}/CTL
%{_pkgconfigdir}/CTL.pc
+%{_libdir}/cmake/CTL
+
+%files -n openexr_ctl
+%defattr(644,root,root,755)
+%doc OpenEXR_CTL/README
+%attr(755,root,root) %{_libdir}/libIlmImfCtl.so
+
+%files -n openexr_ctl-devel
+%defattr(644,root,root,755)
+#%attr(755,root,root) %{_libdir}/libIlmImfCtl.so
+%{_includedir}/OpenEXR/ImfCtlApplyTransforms.h
+%{_pkgconfigdir}/OpenEXR_CTL.pc
+
+%files -n openexr_ctl-progs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/exr_ctl_exr
+%attr(755,root,root) %{_bindir}/exrdpx
+%{_prefix}/lib/CTL
-%files static
+%files -n ctlrender
%defattr(644,root,root,755)
-%{_libdir}/libIlmCtl.a
-%{_libdir}/libIlmCtlMath.a
-%{_libdir}/libIlmCtlSimd.a
+%attr(755,root,root) %{_bindir}/ctlrender