summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2022-02-05 09:05:01 (GMT)
committerJakub Bogusz2022-02-05 09:05:01 (GMT)
commit7957b5500b8895b950eb085e2c79a66c1e79352f (patch)
tree8072ccc7a258971953a442efe306d5356f48ad38
parent79b5e07876a329131635720f623a37e998f5a273 (diff)
downloadctl-7957b5500b8895b950eb085e2c79a66c1e79352f.zip
ctl-7957b5500b8895b950eb085e2c79a66c1e79352f.tar.gz
- added openexr-update patch (fixes build with OpenEXR 2.3.x)auto/th/ctl-1.5.2-4
- added c++17 patch (fixes build in C++ 17 mode) - versioned Obsoletes - use out-of-tree build - release 4
-rw-r--r--ctl-c++17.patch11
-rw-r--r--ctl-openexr-update.patch11
-rw-r--r--ctl.spec18
3 files changed, 34 insertions, 6 deletions
diff --git a/ctl-c++17.patch b/ctl-c++17.patch
new file mode 100644
index 0000000..7c0aba8
--- /dev/null
+++ b/ctl-c++17.patch
@@ -0,0 +1,11 @@
+--- CTL-ctl-1.5.2/lib/dpx/dpx.hh.orig 2014-06-03 03:11:24.000000000 +0200
++++ CTL-ctl-1.5.2/lib/dpx/dpx.hh 2022-02-05 09:54:00.923386506 +0100
+@@ -297,7 +297,7 @@ struct dpx {
+ compliance_e current_compliance;
+ endian_mode_e current_endian_mode;
+
+- std::istream::streampos header_start;
++ std::streampos header_start;
+
+ public:
+ virtual ~dpx();
diff --git a/ctl-openexr-update.patch b/ctl-openexr-update.patch
new file mode 100644
index 0000000..007c05d
--- /dev/null
+++ b/ctl-openexr-update.patch
@@ -0,0 +1,11 @@
+--- CTL-ctl-1.5.2/lib/IlmCtlSimd/CtlSimdInst.cpp.orig 2014-06-03 03:11:24.000000000 +0200
++++ CTL-ctl-1.5.2/lib/IlmCtlSimd/CtlSimdInst.cpp 2022-02-05 08:36:14.965330834 +0100
+@@ -189,7 +189,7 @@ SimdInst::executePath (SimdBoolMask &mas
+ REPLACE_EXC
+ (e, "\n" <<
+ xcontext.fileName() << ":" <<
+- inst->lineNumber() << ": " << e);
++ inst->lineNumber() << ": " << e.message());
+
+ throw e;
+ }
diff --git a/ctl.spec b/ctl.spec
index 6732721..f9d71f1 100644
--- a/ctl.spec
+++ b/ctl.spec
@@ -2,15 +2,17 @@ Summary: Color Transform Language libraries
Summary(pl.UTF-8): Biblioteki CTL (języka przekształceń kolorów)
Name: ctl
Version: 1.5.2
-Release: 3
+Release: 4
License: BSD + IP clause
Group: Libraries
-#Source0Download: https://github.com/ampas/CTL/releases
+#Source0Download: https://github.com/ampas/CTL/tags
Source0: https://github.com/ampas/CTL/archive/%{name}-%{version}.tar.gz
# Source0-md5: 4796bf258d0c66d421c864996482f952
Patch0: %{name}-libdir.patch
Patch1: %{name}-ctlrender.patch
Patch2: %{name}-pc.patch
+Patch3: %{name}-openexr-update.patch
+Patch4: %{name}-c++17.patch
URL: https://www.oscars.org/science-technology/sci-tech-projects/color-transformation-language
BuildRequires: OpenEXR-devel
BuildRequires: aces_container-devel
@@ -55,7 +57,7 @@ Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: ilmbase-devel >= 2.0.0
Requires: libstdc++-devel
-Obsoletes: ctl-static
+Obsoletes: ctl-static < 1.5
%description devel
Header files for CTL library.
@@ -84,7 +86,7 @@ Group: Development/Libraries
Requires: OpenEXR-devel
Requires: ctl-devel = %{version}-%{release}
Requires: openexr_ctl = %{version}-%{release}
-Obsoletes: openexr_ctl-static
+Obsoletes: openexr_ctl-static < 1.1
%description -n openexr_ctl-devel
Header files for IlmInfCtl library.
@@ -146,9 +148,13 @@ ctlrender obsługuje formaty plików OpenEXR, TIFF, DPX oraz ACES.
%patch0 -p1
%patch1 -p1
%patch2 -p1
+%patch3 -p1
+%patch4 -p1
%build
-%cmake . \
+install -d build
+cd build
+%cmake .. \
-DINSTALL_CMAKE_DIR=%{_libdir}/cmake/CTL \
-DINSTALL_LIB_DIR=%{_libdir}
%{__make}
@@ -156,7 +162,7 @@ ctlrender obsługuje formaty plików OpenEXR, TIFF, DPX oraz ACES.
%install
rm -rf $RPM_BUILD_ROOT
-%{__make} install \
+%{__make} -C build install \
DESTDIR=$RPM_BUILD_ROOT
# packaged as %doc