summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2012-09-13 19:08:36 (GMT)
committerElan Ruusamäe2012-09-13 19:08:36 (GMT)
commit462cb7b426489246ebca3b8f766a382c10091436 (patch)
treeceebbf2282398fe4ff1ceee85b1c4bb6e04c84e1
parentdfcb00b254d1ce8044d1d81baa2cafaeb367ff88 (diff)
downloadcrossnacl-newlib-462cb7b426489246ebca3b8f766a382c10091436.zip
crossnacl-newlib-462cb7b426489246ebca3b8f766a382c10091436.tar.gz
use xz source
-rw-r--r--crossnacl-newlib.spec3
-rwxr-xr-xget-source.sh17
2 files changed, 11 insertions, 9 deletions
diff --git a/crossnacl-newlib.spec b/crossnacl-newlib.spec
index 65c36c3..0404197 100644
--- a/crossnacl-newlib.spec
+++ b/crossnacl-newlib.spec
@@ -9,7 +9,6 @@ Source0: nacl-newlib-%{version}-git%{gitver}.tar.bz2
# Source0-md5: 62471478377d5f99a2ce88213731e500
Source1: nacl-headers-21.0.1180.57.tar.bz2
# Source1-md5: 8e76cde640c1f268e14dbd67568a4bee
-# Taken from chromium-15.0.874.106/native_client/tools/newlib-libc-script
Source2: newlib-libc-script
Source3: pthread.h
Source4: get-source.sh
@@ -17,6 +16,8 @@ URL: http://sourceware.org/newlib/
BuildRequires: crossnacl-binutils
BuildRequires: crossnacl-gcc
BuildRequires: fslint
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
ExclusiveArch: %{ix86} %{x8664}
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
diff --git a/get-source.sh b/get-source.sh
index e2c3bf8..afca054 100755
--- a/get-source.sh
+++ b/get-source.sh
@@ -61,13 +61,13 @@ version=$(awk -F"'" '/PACKAGE_VERSION=/{print $2}' configure)
shorthash=$(git rev-parse --short $githash)
prefix=$package-$version-git$shorthash
-if [ -f $prefix.tar.bz2 ]; then
- echo "Tarball $prefix.tar.bz2 already exists at $shorthash"
+if [ -f $prefix.tar.xz ]; then
+ echo "Tarball $prefix.tar.xz already exists at $shorthash"
else
git archive $githash --prefix $prefix/ > $prefix.tar
- bzip2 -9 $prefix.tar
+ xz -9 $prefix.tar
- ../dropin $prefix.tar.bz2
+ ../dropin $prefix.tar.xz
fi
# We need to copy some missing header files from chromium
@@ -79,15 +79,16 @@ fi
package=nacl-headers
prefix=$package-$chrome_version
-if [ -f $prefix.tar.bz2 ]; then
- echo "Tarball $prefix.tar.bz2 already exists"
+if [ -f $prefix.tar.xz ]; then
+ echo "Tarball $prefix.tar.xz already exists"
else
svn co $nacl_trunk/src/native_client/src/trusted/service_runtime@$nacl_revision $package
cd $package
./export_header.py include ../$prefix
cd ..
- tar -cjf $prefix.tar.bz2 --exclude-vcs $prefix
- ../dropin $prefix.tar.bz2
+ tar -cf $prefix.tar --exclude-vcs $prefix
+ xz -9 $prefix.tar
+ ../dropin $prefix.tar.xz
fi
# Taken from chromium-15.0.874.106/native_client/tools/newlib-libc-script