summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2012-07-06 11:59:07 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commite0a445508d55c3f7c97e233ac57dce1c03c38a1c (patch)
tree9914c11c573a19107cce53b250393474c1317ec1
parent3aa025913a01da21ceaf2988376cc12be7323b5d (diff)
downloadcrossnacl-gcc-e0a445508d55c3f7c97e233ac57dce1c03c38a1c.zip
crossnacl-gcc-e0a445508d55c3f7c97e233ac57dce1c03c38a1c.tar.gz
- c++ to subpackage
Changed files: crossnacl-gcc.spec -> 1.3
-rw-r--r--crossnacl-gcc.spec24
1 files changed, 20 insertions, 4 deletions
diff --git a/crossnacl-gcc.spec b/crossnacl-gcc.spec
index 4da241f..354c7a4 100644
--- a/crossnacl-gcc.spec
+++ b/crossnacl-gcc.spec
@@ -1,6 +1,6 @@
#
# Conditional build:
-%bcond_with bootstrap # build without nacl newlib package
+%bcond_with bootstrap # build without nacl newlib package dependency (without c++ package)
%define gitver cff9ac88
Summary: Various compilers (C, C++) for nacl
@@ -16,7 +16,7 @@ Release: 1.git%{gitver}
# For gcc version, echo gcc/BASE-VER
# mv nacl-gcc nacl-gcc-4.4.3-gitcff9ac88
# tar cfj nacl-gcc-4.4.3-gitcff9ac88.tar.bz2 nacl-gcc-4.4.3-gitcff9ac88
-License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions
+License: GPL v3+ and GPL v3+ with exceptions and GPL v2+ with exceptions
Group: Development/Languages
Source0: nacl-gcc-%{version}-git%{gitver}.tar.bz2
# Source0-md5: 5f96c99136882b2b22a5d173890f8026
@@ -37,8 +37,22 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%description
The gcc package contains the GNU Compiler Collection version 4.4.3.
-You'll need this package in order to compile C code. This provides
-support for nacl targets.
+You'll need this package in order to compile C code.
+
+This provides support for NaCl targets.
+
+%package c++
+Summary: C++ support for crossnacl-gcc
+Summary(pl.UTF-8): Obsługa C++ dla crossnacl-gcc
+Group: Development/Languages
+Requires: %{name} = %{version}-%{release}
+
+%description c++
+This package adds C++ support to the GNU Compiler Collection for NaCl
+targets.
+
+%description c++ -l pl.UTF-8
+Ten pakiet dodaje obsługę C++ do kompilatora gcc dla NaCL.
%prep
%setup -q -n nacl-gcc-%{version}-git%{?gitver}
@@ -147,6 +161,8 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man1/%{gcc_target_platform}-gcov.*
%if %{without bootstrap}
+%files c++
+%defattr(644,root,root,755)
%attr(755,root,root) %{_bindir}/%{gcc_target_platform}-c++
%attr(755,root,root) %{_bindir}/%{gcc_target_platform}-g++
%{_prefix}/%{gcc_target_platform}/include/c++