summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2012-12-07 10:18:47 (GMT)
committerElan Ruusamäe2012-12-07 10:18:47 (GMT)
commit53a502ad4ae26d94d3f6f01c6e4f0ccac5887b2c (patch)
tree87d7c4fbeb98738b7d0d8027cf6d3dcd8882c1e7
parentcaf4e83b87722e1a77894163ab8088ed452f6b8b (diff)
downloadcrossnacl-binutils-53a502ad4ae26d94d3f6f01c6e4f0ccac5887b2c.zip
crossnacl-binutils-53a502ad4ae26d94d3f6f01c6e4f0ccac5887b2c.tar.gz
- update for omahaproxy changes
-rwxr-xr-xget-source.sh8
1 files changed, 4 insertions, 4 deletions
diff --git a/get-source.sh b/get-source.sh
index c1a93c6..d7cb112 100755
--- a/get-source.sh
+++ b/get-source.sh
@@ -20,12 +20,12 @@ omahaproxy_url=http://omahaproxy.appspot.com
specfile=crossnacl-binutils.spec
chrome_channel=${1:-stable}
-chrome_version=$(curl -s "$omahaproxy_url/?os=linux&channel=$chrome_channel" | awk -F, 'NR > 1{print $3}')
+chrome_version=$(curl -s "$omahaproxy_url/all?os=linux&channel=$chrome_channel" | awk -F, 'NR > 1{print $3}')
test -n "$chrome_version"
-chrome_revision=$(curl -s $omahaproxy_url/revision?version=$chrome_version)
+chrome_revision=$((echo 'data='; curl -s $omahaproxy_url/revision.json?version=$chrome_version; echo ',print(data.chromium_revision)') | js)
test -n "$chrome_revision"
chrome_branch=$(IFS=.; set -- $chrome_version; echo $3)
-test -e DEPS.py || svn cat http://src.chromium.org/chrome/branches/$chrome_branch/src/DEPS@$chrome_revision > DEPS.py
+test -s DEPS.py || svn cat http://src.chromium.org/chrome/branches/$chrome_branch/src/DEPS@$chrome_revision > DEPS.py
nacl_revision=$(awk -F'"' '/nacl_revision.:/{print $4}' DEPS.py)
test -n "$nacl_revision"
@@ -42,7 +42,7 @@ fi
# get src/native_client/tools/REVISIONS directly from svn
test -n "$nacl_revision"
-test -e NACL_REVISIONS.sh || svn cat $nacl_trunk/src/native_client/tools/REVISIONS@$nacl_revision > NACL_REVISIONS.sh
+test -s NACL_REVISIONS.sh || svn cat $nacl_trunk/src/native_client/tools/REVISIONS@$nacl_revision > NACL_REVISIONS.sh
if grep -Ev '^(#|(LINUX_HEADERS_FOR_NACL|NACL_(BINUTILS|GCC|GDB|GLIBC|NEWLIB))_COMMIT=[0-9a-f]+$|)' NACL_REVISIONS.sh >&2; then
echo >&2 "I refuse to execute grabbed file for security concerns"