summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2019-09-10 18:15:16 (GMT)
committerJakub Bogusz2019-09-10 18:15:16 (GMT)
commitf4c217513920ed2ea1318d5cf608ff7a0842ec3c (patch)
treea5aa164d4953af82261821c1619fac1ec79fbff8
parentf4e27df48eb3dc6b77537c6df0a3d4cb8da389d2 (diff)
downloadcrossmingw32-glib2-f4c217513920ed2ea1318d5cf608ff7a0842ec3c.zip
crossmingw32-glib2-f4c217513920ed2ea1318d5cf608ff7a0842ec3c.tar.gz
- adjust win32 patch to avoid "secure crt" calls not supported by mingw32
-rw-r--r--crossmingw32-glib2.spec12
-rw-r--r--glib2-win32.patch64
2 files changed, 70 insertions, 6 deletions
diff --git a/crossmingw32-glib2.spec b/crossmingw32-glib2.spec
index 8875b9d..6e68beb 100644
--- a/crossmingw32-glib2.spec
+++ b/crossmingw32-glib2.spec
@@ -12,12 +12,12 @@ Summary(tr.UTF-8): Yararlı ufak yordamlar kitaplığı
Summary(zh_CN.UTF-8): 实用工具函数库
%define realname glib
Name: crossmingw32-glib2
-Version: 2.60.7
+Version: 2.62.0
Release: 1
License: LGPL v2+
Group: Development/Libraries
-Source0: http://ftp.gnome.org/pub/GNOME/sources/glib/2.60/glib-%{version}.tar.xz
-# Source0-md5: f036f78a7fca330d9f7d939fcf794bde
+Source0: http://ftp.gnome.org/pub/GNOME/sources/glib/2.62/glib-%{version}.tar.xz
+# Source0-md5: a5d34752dd3a6c8d929ade7debc4db03
Patch0: glib2-win32.patch
URL: http://www.gtk.org/
BuildRequires: crossmingw32-gcc
@@ -28,13 +28,13 @@ BuildRequires: crossmingw32-pcre >= 8.31
# rand_s()
BuildRequires: crossmingw32-runtime >= 1:4.0.3-2
# SetThreadErrorMode and more
-BuildRequires: crossmingw32-w32api >= 1:5.0.2-4
+BuildRequires: crossmingw32-w32api >= 1:5.0.2-7
BuildRequires: crossmingw32-zlib
# host glib-genmarshall and glib-compile-schemas are needed for cross-compiling
-BuildRequires: glib2 >= 1:2.32.0
+BuildRequires: glib2 >= 1:2.62.0
BuildRequires: gtk-doc >= 1.20
BuildRequires: meson >= 0.50.0-2
-BuildRequires: ninja
+BuildRequires: ninja >= 1.5
BuildRequires: pkgconfig >= 1:0.16
BuildRequires: python3 >= 1:3.4
BuildRequires: rpmbuild(macros) >= 1.736
diff --git a/glib2-win32.patch b/glib2-win32.patch
index fa6dae5..5031143 100644
--- a/glib2-win32.patch
+++ b/glib2-win32.patch
@@ -184,3 +184,67 @@
static void
test_basic (void)
+--- glib-2.62.0/glib/gtimezone.c.orig 2019-09-05 18:56:49.000000000 +0200
++++ glib-2.62.0/glib/gtimezone.c 2019-09-10 19:30:55.332089477 +0200
+@@ -817,7 +817,7 @@
+ for (year = first, i = 0; *rules != NULL && year <= last; year++)
+ {
+ gboolean failed = FALSE;
+- swprintf_s (s, 11, L"%d", year);
++ swprintf (s, 12, L"%d", year);
+
+ if (!failed)
+ {
+--- glib-2.62.0/glib/gwin32.c.orig 2019-09-05 18:56:49.000000000 +0200
++++ glib-2.62.0/glib/gwin32.c 2019-09-10 19:40:22.822348452 +0200
+@@ -1120,7 +1120,7 @@
+ return EXCEPTION_CONTINUE_EXECUTION;
+ }
+
+- fprintf_s (stderr,
++ fprintf (stderr,
+ "Exception code=0x%lx flags=0x%lx at 0x%p",
+ er->ExceptionCode,
+ er->ExceptionFlags,
+@@ -1129,7 +1129,7 @@
+ switch (er->ExceptionCode)
+ {
+ case EXCEPTION_ACCESS_VIOLATION:
+- fprintf_s (stderr,
++ fprintf (stderr,
+ ". Access violation - attempting to %s at address 0x%p\n",
+ er->ExceptionInformation[0] == 0 ? "read data" :
+ er->ExceptionInformation[0] == 1 ? "write data" :
+@@ -1138,7 +1138,7 @@
+ (void *) er->ExceptionInformation[1]);
+ break;
+ case EXCEPTION_IN_PAGE_ERROR:
+- fprintf_s (stderr,
++ fprintf (stderr,
+ ". Page access violation - attempting to %s at address 0x%p with status %Ix\n",
+ er->ExceptionInformation[0] == 0 ? "read from an inaccessible page" :
+ er->ExceptionInformation[0] == 1 ? "write to an inaccessible page" :
+@@ -1148,7 +1148,7 @@
+ er->ExceptionInformation[2]);
+ break;
+ default:
+- fprintf_s (stderr, "\n");
++ fprintf (stderr, "\n");
+ break;
+ }
+
+--- glib-2.62.0/glib/gwin32-private.c.orig 2019-09-05 18:56:49.000000000 +0200
++++ glib-2.62.0/glib/gwin32-private.c 2019-09-10 19:45:50.857238001 +0200
+@@ -40,10 +40,10 @@
+ char event_str[STR_BUFFER_SIZE] = {0};
+ gsize event_str_len;
+
+- _snprintf_s (pid_str, STR_BUFFER_SIZE, G_N_ELEMENTS (pid_str), "%lu", pid);
++ snprintf (pid_str, STR_BUFFER_SIZE, "%lu", pid);
+ pid_str[G_N_ELEMENTS (pid_str) - 1] = 0;
+ pid_str_len = strlen (pid_str);
+- _snprintf_s (event_str, STR_BUFFER_SIZE, G_N_ELEMENTS (pid_str), "%Iu", event);
++ snprintf (event_str, STR_BUFFER_SIZE, "%Iu", event);
+ event_str[G_N_ELEMENTS (pid_str) - 1] = 0;
+ event_str_len = strlen (event_str);
+ #undef STR_BUFFER_SIZE