summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2023-07-06 21:00:56 (GMT)
committerJan Palus2023-07-06 21:00:56 (GMT)
commit443b5f36fcb97942c1d006a3997f11dcb9fe89bc (patch)
treedfe08b6620b078245fc6ac58ca12be7600ce50eb
parent2f6a8b12f4ea8486ee4438d29e08ed3e12881f01 (diff)
downloadclaws-mail-443b5f36fcb97942c1d006a3997f11dcb9fe89bc.zip
claws-mail-443b5f36fcb97942c1d006a3997f11dcb9fe89bc.tar.gz
upstream fix for gcc >= 13
-rw-r--r--claws-mail.spec2
-rw-r--r--gcc13.patch37
2 files changed, 39 insertions, 0 deletions
diff --git a/claws-mail.spec b/claws-mail.spec
index e3a4a86..bd1c1e2 100644
--- a/claws-mail.spec
+++ b/claws-mail.spec
@@ -21,6 +21,7 @@ Source0: https://www.claws-mail.org/releases/%{name}-%{version}.tar.xz
# Source0-md5: bde1fdfcc082aa629d8704cba56a8cf6
Source1: %{name}.desktop
Patch0: %{name}-link.patch
+Patch1: gcc13.patch
URL: https://www.claws-mail.org/
BuildRequires: NetworkManager-devel
BuildRequires: autoconf >= 2.69
@@ -443,6 +444,7 @@ webCal.
%prep
%setup -q
%patch0 -p1
+%patch1 -p1
%{__rm} po/stamp-po
diff --git a/gcc13.patch b/gcc13.patch
new file mode 100644
index 0000000..10da046
--- /dev/null
+++ b/gcc13.patch
@@ -0,0 +1,37 @@
+From a9a16a253ed3865a51db5e306539d3494087dafd Mon Sep 17 00:00:00 2001
+From: Paul <paul@claws-mail.org>
+Date: Wed, 19 Apr 2023 16:42:07 +0100
+Subject: [PATCH] fix bug 4648, 'fails to build with gcc 13'
+
+---
+ src/plugins/litehtml_viewer/litehtml/html.h | 1 +
+ src/plugins/litehtml_viewer/litehtml/num_cvt.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/plugins/litehtml_viewer/litehtml/html.h b/src/plugins/litehtml_viewer/litehtml/html.h
+index 4151b1225..20457f155 100644
+--- a/src/plugins/litehtml_viewer/litehtml/html.h
++++ b/src/plugins/litehtml_viewer/litehtml/html.h
+@@ -9,6 +9,7 @@
+ #include <cstring>
+ #include <algorithm>
+ #include <sstream>
++#include <cstdint>
+ #include "os_types.h"
+ #include "types.h"
+ #include "background.h"
+diff --git a/src/plugins/litehtml_viewer/litehtml/num_cvt.h b/src/plugins/litehtml_viewer/litehtml/num_cvt.h
+index 515e46d62..367dcc36a 100644
+--- a/src/plugins/litehtml_viewer/litehtml/num_cvt.h
++++ b/src/plugins/litehtml_viewer/litehtml/num_cvt.h
+@@ -2,6 +2,7 @@
+ #define NUM_CVT_H
+
+ #include <string>
++#include <cstdint>
+ #include "os_types.h"
+
+ namespace litehtml
+--
+2.25.1
+