summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcvs2git2006-11-30 16:36:46 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commita8ab839cff691fdbb8a8d7afad33abbbe64162f4 (patch)
tree4758740400ead624b909964483056047a71b53f3
parent92b902ce740e13e30b678f4ae9fe21ad36656652 (diff)
downloadbluez-utils-AC-branch.zip
bluez-utils-AC-branch.tar.gz
This commit was manufactured by cvs2git to create branch 'AC-branch'.AC-branch
Sprout from master 2006-06-05 20:04:18 UTC freetz <freetz@pld-linux.org> '- dbus fixes from fedora' Cherrypick from master 2006-11-30 16:36:46 UTC Elan Ruusamäe <glen@pld-linux.org> '- use functions': bluez-utils.init -> 1.10 bluez-utils.spec -> 1.47
-rw-r--r--bluez-utils.init30
-rw-r--r--bluez-utils.spec58
2 files changed, 52 insertions, 36 deletions
diff --git a/bluez-utils.init b/bluez-utils.init
index ec15b0f..b624e71 100644
--- a/bluez-utils.init
+++ b/bluez-utils.init
@@ -19,10 +19,7 @@ if [ "$UART_CONF" != "no" -a ! -f "$UART_CONF" ]; then
UART_CONF="no"
fi
-RETVAL=0
-# See how we were called.
-case "$1" in
- start)
+start() {
# Check if the service is already running?
if [ ! -f /var/lock/subsys/bluetooth ]; then
msg_starting bluetooth; started
@@ -78,8 +75,9 @@ case "$1" in
else
msg_already_running bluetooth
fi
- ;;
- stop)
+}
+
+stop() {
if [ -f /var/lock/subsys/bluetooth ]; then
if is_yes "${PAND_ENABLE}" && [ -x /usr/bin/pand ]; then
msg_stopping pand
@@ -118,11 +116,20 @@ case "$1" in
else
msg_not_running bluetooth
fi
+}
+
+RETVAL=0
+# See how we were called.
+case "$1" in
+ start)
+ start
+ ;;
+ stop)
+ stop
;;
restart)
- $0 stop
- $0 start
- exit $?
+ stop
+ start
;;
reload|force-reload)
if [ -f /var/lock/subsys/bluetooth ]; then
@@ -130,7 +137,7 @@ case "$1" in
killproc hcid -HUP
RETVAL=$?
else
- msg_not_running bluetooth >&2
+ msg_not_running bluetooth
exit 7
fi
;;
@@ -148,6 +155,3 @@ case "$1" in
esac
exit $RETVAL
-
-# This must be last line !
-# vi:syntax=sh:tw=78:ts=8:sw=4
diff --git a/bluez-utils.spec b/bluez-utils.spec
index a1c2b0d..a904d53 100644
--- a/bluez-utils.spec
+++ b/bluez-utils.spec
@@ -1,32 +1,39 @@
Summary: Bluetooth utilities
Summary(pl): Narzędzia Bluetooth
Name: bluez-utils
-Version: 2.25
-Release: 3
+Version: 3.7
+Release: 1
Epoch: 0
License: GPL v2
Group: Applications/System
+#Source0Download: http://www.bluez.org/download.html
Source0: http://bluez.sourceforge.net/download/%{name}-%{version}.tar.gz
-# Source0-md5: ae3729ab5592be06ed01b973d4b3e9fe
+# Source0-md5: 89f7290907d098163a2fa59a55dfafe7
Source1: %{name}.init
Source2: %{name}.sysconfig
Source3: %{name}-udev.rules
Source4: %{name}-udev.script
Patch0: %{name}-etc_dir.patch
-URL: http://bluez.sourceforge.net/
+URL: http://www.bluez.org/
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: bison
-BuildRequires: bluez-libs-devel >= 2.25
-BuildRequires: dbus-devel >= 0.33
+BuildRequires: bluez-libs-devel >= 3.7
+BuildRequires: dbus-glib-devel >= 0.35
BuildRequires: libtool
BuildRequires: libusb-devel
+BuildRequires: pkgconfig
BuildRequires: rpmbuild(macros) >= 1.268
-# alsa-lib-devel, openobex-devel - currently only checked for, not used
-Requires: bluez-libs >= 2.21
+# for future use (ALSA plugins not finished)
+#BuildRequires: alsa-lib-devel >= 0.9
+# for future use (fuse module is just testing stub now)
+#BuildRequires: libfuse-devel
+#BuildRequires: openobex-devel >= 1.1
+Requires: bluez-libs >= 3.7
Requires: rc-scripts
Obsoletes: bluez-pan
Obsoletes: bluez-sdp
+Obsoletes: bluez-utils-init
Conflicts: bluez-bluefw
ExcludeArch: s390 s390x
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -60,7 +67,7 @@ Narzędzia Bluetooth:
Summary: Bluetooth backend for CUPS
Summary(pl): Backend Bluetooth dla CUPS-a
Group: Applications/Printing
-Requires: bluez-libs >= 2.21
+Requires: bluez-libs >= 3.7
Requires: cups
%description -n cups-backend-bluetooth
@@ -92,9 +99,11 @@ Skrypt init dla podsystemu Bluetooth.
%{__autoconf}
%{__automake}
%configure \
- --enable-bcm203x \
+ --enable-avctrl \
+ --enable-bccmd \
--enable-cups \
- --enable-pcmcia \
+ --enable-dfutool \
+ --enable-pcmciarules \
--with-cups=/usr
%{__make} \
cupsdir=%{cupsdir}
@@ -106,12 +115,16 @@ install -d $RPM_BUILD_ROOT{/etc/udev/rules.d,/lib/udev}
%{__make} install \
DESTDIR=$RPM_BUILD_ROOT \
- cupsdir=%{cupsdir}
+ cupsdir=%{cupsdir} \
+ udevdir=/lib/udev
install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bluetooth
install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
install %{SOURCE3} $RPM_BUILD_ROOT/etc/udev/rules.d/70-bluetooth.rules
install %{SOURCE4} $RPM_BUILD_ROOT/lib/udev/bluetooth.sh
+install hcid/passkey-agent $RPM_BUILD_ROOT/%{_bindir}
+mv $RPM_BUILD_ROOT/etc/udev/bluetooth.rules \
+ $RPM_BUILD_ROOT/etc/udev/rules.d/71-bluetooth.rules
%clean
rm -rf $RPM_BUILD_ROOT
@@ -132,20 +145,19 @@ fi
%attr(755,root,root) %{_bindir}/*
%attr(755,root,root) %{_sbindir}/*
%{_mandir}/man*/*
+
+%attr(754,root,root) /etc/rc.d/init.d/bluetooth
+%attr(755,root,root) /lib/udev/bluetooth.sh
+%attr(755,root,root) /lib/udev/bluetooth_serial
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/70-bluetooth.rules
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/71-bluetooth.rules
+
+%dir /etc/bluetooth
+%dir /etc/sysconfig/bluetooth
%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bluetooth
-%dir %{_sysconfdir}/bluetooth
%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/*
-%attr(755,root,root) %{_sysconfdir}/hotplug/usb/bcm203x
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hotplug/usb/bcm203x.usermap
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pcmcia/bluetooth.conf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pcmcia/bluetooth
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/*
%files -n cups-backend-bluetooth
%defattr(644,root,root,755)
%attr(755,root,root) %{_prefix}/lib/cups/backend/bluetooth
-
-%files init
-%defattr(644,root,root,755)
-%attr(754,root,root) /etc/rc.d/init.d/bluetooth
-%attr(755,root,root) /lib/udev/bluetooth.sh
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/70-bluetooth.rules