summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2012-10-26 22:02:09 (GMT)
committerJakub Bogusz2012-10-26 22:02:09 (GMT)
commit53a8b53f19be41a1b6584efeeb55b67e43fe0cab (patch)
tree0589d0c7b5a1bd0c6d176da54eb82583d31300cf
parent3a6625874b63f50107478cc843edf01fc48a2828 (diff)
downloadbcc-53a8b53f19be41a1b6584efeeb55b67e43fe0cab.zip
bcc-53a8b53f19be41a1b6584efeeb55b67e43fe0cab.tar.gz
- added format patch to fix build with -Werror=format-securityauto/ti/bcc-0.16.19-1auto/th/bcc-0.16.19-1
-rw-r--r--bcc.spec2
-rw-r--r--dev86-format.patch22
2 files changed, 24 insertions, 0 deletions
diff --git a/bcc.spec b/bcc.spec
index 09e1b0a..9308a15 100644
--- a/bcc.spec
+++ b/bcc.spec
@@ -17,6 +17,7 @@ Patch6: dev86-nostrip.patch
Patch7: dev86-print-overflow.patch
Patch8: dev86-make.patch
Patch9: dev86-copt.patch
+Patch10: dev86-format.patch
URL: http://www.debath.co.uk/
Requires: bin86 >= %{version}
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -53,6 +54,7 @@ są odwzorowywane do jednego z innych typów całkowitych.
%patch7 -p1
%patch8 -p1
%patch9 -p1
+%patch10 -p1
mv -f bootblocks/README README.bootblocks
mv -f copt/README README.copt
diff --git a/dev86-format.patch b/dev86-format.patch
new file mode 100644
index 0000000..60f0b67
--- /dev/null
+++ b/dev86-format.patch
@@ -0,0 +1,22 @@
+--- dev86-0.16.19/copt/copt.c.orig 2012-10-26 23:51:09.735174869 +0200
++++ dev86-0.16.19/copt/copt.c 2012-10-26 23:55:09.276050428 +0200
+@@ -803,7 +803,7 @@
+ exit(1);
+ }
+ if (headstr != NULL) {
+- fprintf(fp, headstr);
++ fprintf(fp, "%s", headstr);
+ fprintf(fp, "\n");
+ }
+ for (lp = infile; lp != NULL; lp = lp->next)
+--- dev86-0.16.19/ar/ar.c.orig 2012-08-13 21:15:47.000000000 +0200
++++ dev86-0.16.19/ar/ar.c 2012-10-26 23:59:23.414647129 +0200
+@@ -2036,7 +2036,7 @@
+ struct mapelt *mapelt;
+ {
+ fprintf (stderr, "%s: ", program_name);
+- fprintf (stderr, string);
++ fprintf (stderr, "%s", string);
+ if (mapelt->info.offset != 0)
+ fprintf (stderr, "%s(%s)", archive, mapelt->info.name);
+ else