summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2008-06-16 21:10:13 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit92fc1d4a5ca53b774727b423ef68c07a5d65feb0 (patch)
tree09638ab30f6f56150a2626e96264f3cae41417c8
parenta460b68577e935268524feda50615a6c586aefca (diff)
downloadapr-compat-92fc1d4a5ca53b774727b423ef68c07a5d65feb0.zip
apr-compat-92fc1d4a5ca53b774727b423ef68c07a5d65feb0.tar.gz
- updated for 1.3.0
Changed files: apr-libtool.patch -> 1.2 apr-link.patch -> 1.5
-rw-r--r--apr-libtool.patch10
-rw-r--r--apr-link.patch24
2 files changed, 17 insertions, 17 deletions
diff --git a/apr-libtool.patch b/apr-libtool.patch
index cfcdcfd..a715463 100644
--- a/apr-libtool.patch
+++ b/apr-libtool.patch
@@ -1,17 +1,17 @@
must give hint to libtool which tag to use, in case we use ccache and then
libtool is unable to autodetect from $CC
---- apr-1.2.2/configure.in~ 2005-12-19 22:17:54.000000000 +0200
-+++ apr-1.2.2/configure.in 2005-12-19 22:30:13.000000000 +0200
-@@ -196,9 +196,9 @@
+--- apr-1.3.0/configure.in.orig 2008-06-16 22:57:25.596627316 +0200
++++ apr-1.3.0/configure.in 2008-06-16 22:58:16.295519834 +0200
+@@ -197,9 +197,9 @@
[ use_libtool=$withval ], [ use_libtool="yes" ] )
if test "x$use_libtool" = "xyes"; then
- lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE) -o $@ -c $< && touch $@'
+ lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile --tag=CC $(COMPILE) -o $@ -c $< && touch $@'
LT_VERSION="-version-info `$get_version libtool $version_hdr APR`"
-- link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LT_LDFLAGS) \$(COMPILE) ${LT_VERSION} \$(ALL_LDFLAGS) -o \$@"
-+ link="\$(LIBTOOL) \$(LTFLAGS) --mode=link --tag=CC \$(LT_LDFLAGS) \$(COMPILE) ${LT_VERSION} \$(ALL_LDFLAGS) -o \$@"
+- link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LT_LDFLAGS) \$(COMPILE) \$(LT_VERSION) \$(ALL_LDFLAGS) -o \$@"
++ link="\$(LIBTOOL) \$(LTFLAGS) --mode=link --tag=CC \$(LT_LDFLAGS) \$(COMPILE) \$(LT_VERSION) \$(ALL_LDFLAGS) -o \$@"
so_ext='lo'
lib_target='-rpath $(libdir) $(OBJECTS)'
export_lib_target='-rpath \$(libdir) \$(OBJECTS)'
diff --git a/apr-link.patch b/apr-link.patch
index 569f682..3db9baf 100644
--- a/apr-link.patch
+++ b/apr-link.patch
@@ -1,15 +1,15 @@
---- apr-1.0.0/configure.in.orig 2004-08-01 02:52:20.000000000 +0200
-+++ apr-1.0.0/configure.in 2004-09-16 21:33:34.263720072 +0200
-@@ -519,7 +519,7 @@
- AC_SEARCH_LIBS(gethostbyname, nsl)
- AC_SEARCH_LIBS(gethostname, nsl)
- AC_SEARCH_LIBS(socket, socket)
--AC_SEARCH_LIBS(crypt, crypt ufc)
-+dnl AC_SEARCH_LIBS(crypt, crypt ufc)
- AC_CHECK_LIB(truerand, main)
- AC_SEARCH_LIBS(modf, m)
-
-@@ -659,7 +659,7 @@
+--- apr-1.3.0/configure.in.orig 2008-05-02 20:55:47.000000000 +0200
++++ apr-1.3.0/configure.in 2008-06-16 22:56:55.094888283 +0200
+@@ -600,7 +600,7 @@
+ AC_SEARCH_LIBS(gethostbyname, nsl)
+ AC_SEARCH_LIBS(gethostname, nsl)
+ AC_SEARCH_LIBS(socket, socket)
+- AC_SEARCH_LIBS(crypt, crypt ufc)
++ dnl AC_SEARCH_LIBS(crypt, crypt ufc)
+ AC_CHECK_LIB(truerand, main)
+ AC_SEARCH_LIBS(modf, m)
+ ;;
+@@ -767,7 +767,7 @@
# The real-time POSIX extensions (e.g. shm_*, sem_*) may only
# be available if linking against librt.