summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorradek2004-08-29 19:51:09 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit3ee189aa923c91ac3037fcb0803ce0ef38626a68 (patch)
treef59108dbc134f6ed4ed9577b2f14a3acb099efea
parent28abe21dd3cf01b766330771f1d5fa9f7130ad46 (diff)
downloadapache1-mod_become-3ee189aa923c91ac3037fcb0803ce0ef38626a68.zip
apache1-mod_become-3ee189aa923c91ac3037fcb0803ce0ef38626a68.tar.gz
- mv apache{,1}-*, do not turn on by defaultauto/ac/apache1-mod_become-1_3-1
Changed files: apache1-mod_become.spec -> 1.3
-rw-r--r--apache1-mod_become.spec21
1 files changed, 13 insertions, 8 deletions
diff --git a/apache1-mod_become.spec b/apache1-mod_become.spec
index 1721dc9..bae5cb4 100644
--- a/apache1-mod_become.spec
+++ b/apache1-mod_become.spec
@@ -1,8 +1,8 @@
%define mod_name become
-%define apxs %{_sbindir}/apxs
+%define apxs /usr/sbin/apxs1
Summary: Apache module: Become Somebody
Summary(pl): Moduł Apache'a: stawanie się kim¶
-Name: apache-mod_%{mod_name}
+Name: apache1-mod_%{mod_name}
Version: 1.3
Release: 1
License: ?
@@ -10,11 +10,13 @@ Group: Networking/Daemons
Source0: http://www.snert.com/Software/mod_become/mod_become103.tgz
# Source0-md5: 7bb1607587687dabc711b3b1903947e5
URL: http://www.snert.com/Software/mod_become/
-BuildRequires: apache(EAPI)-devel
+BuildRequires: apache1-devel
+BuildRequires: %{apxs}
Requires(post,preun): %{apxs}
Requires(post,preun): grep
Requires(preun): fileutils
-Requires: apache(EAPI)
+Requires: apache1
+Obsoletes: apache-mod_%{mod_name} <= %{version}
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%define _pkglibdir %(%{apxs} -q LIBEXECDIR)
@@ -41,7 +43,8 @@ także z serwerami wirtualnymi, katalogami i miejscami.
%build
PATH=$PATH:%{_sbindir}
-%{__make} build-dynamic
+%{__make} build-dynamic \
+ APXS=%{apxs}
%install
rm -rf $RPM_BUILD_ROOT
@@ -53,13 +56,15 @@ install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
rm -rf $RPM_BUILD_ROOT
%post
-%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+%{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so
+echo "mod_%{mod_name}: this module is not turned on by default; if you're sure,"
+echo "mod_%{mod_name}: uncomment the appropriate line in Apache's config file"
%preun
if [ "$1" = "0" ]; then
%{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
- if [ -f /var/lock/subsys/httpd ]; then
- /etc/rc.d/init.d/httpd restart 1>&2
+ if [ -f /var/lock/subsys/apache ]; then
+ /etc/rc.d/init.d/apache restart 1>&2
fi
fi