summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2024-04-17 17:27:49 (GMT)
committerJakub Bogusz2024-04-17 17:27:49 (GMT)
commitd7426e6a0036a247a5e5251d98686fec5fb1de99 (patch)
tree3cd67bbfea3b7f810ff9193c51542dea4981dc57
parentddb1d6c494b441ded20295d40bf5d0cf2e2ecd7b (diff)
downloadadvancecomp-d7426e6a0036a247a5e5251d98686fec5fb1de99.zip
advancecomp-d7426e6a0036a247a5e5251d98686fec5fb1de99.tar.gz
- new URLs, updated to 2.6HEADauto/th/advancecomp-2.6-1master
(fixes CVE-2022-35014 CVE-2022-35015 CVE-2022-35016 CVE-2022-35017 CVE-2022-35018 CVE-2022-35019 CVE-2022-35020)
-rw-r--r--advancecomp-7z-lib.patch61
-rw-r--r--advancecomp-system-libs.patch55
-rw-r--r--advancecomp.spec11
3 files changed, 65 insertions, 62 deletions
diff --git a/advancecomp-7z-lib.patch b/advancecomp-7z-lib.patch
index 5ab7aab..8285131 100644
--- a/advancecomp-7z-lib.patch
+++ b/advancecomp-7z-lib.patch
@@ -1,5 +1,5 @@
---- advancecomp-1.23/Makefile.am.orig 2016-12-19 05:33:51.310793262 +0100
-+++ advancecomp-1.23/Makefile.am 2017-05-09 18:58:20.486037160 +0200
++++ advancecomp-2.6/Makefile.am.orig 2024-04-17 18:59:18.464658604 +0200
++++ advancecomp-2.6/Makefile.am 2024-04-17 19:02:19.014563123 +0200
@@ -1,6 +1,10 @@
bin_PROGRAMS = advzip advpng advmng advdef
@@ -12,56 +12,55 @@
7z/7zdeflate.cc \
7z/7zlzma.cc \
7z/AriBitCoder.cc \
-@@ -23,7 +27,7 @@
-
- libdeflate_LIBS = -ldeflate
- zopfli_LIBS = -lzopfli
--LDADD = $(libdeflate_LIBS) $(zopfli_LIBS)
-+LDADD = $(libdeflate_LIBS) $(zopfli_LIBS) libadv7z.la
-
- advzip_SOURCES = \
- rezip.cc \
-@@ -35,7 +39,7 @@
- zipsh.cc \
+@@ -37,9 +41,8 @@ advzip_SOURCES = \
getopt.c \
snprintf.c \
-- $(7z_SOURCES)
-+ $(nil)
+ portable.c \
+- $(7z_SOURCES) \
+ $(nil)
+-advzip_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS)
++advzip_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS) libadv7z.la
advpng_SOURCES = \
repng.cc \
-@@ -50,7 +54,7 @@
+@@ -55,9 +58,8 @@ advpng_SOURCES = \
lib/png.c \
lib/error.c \
lib/snstring.c \
-- $(7z_SOURCES)
-+ $(nil)
+- $(7z_SOURCES) \
+ $(nil)
+-advpng_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS)
++advpng_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS) libadv7z.la
advmng_SOURCES = \
remng.cc \
-@@ -68,7 +72,7 @@
+@@ -76,9 +78,8 @@ advmng_SOURCES = \
lib/mng.c \
lib/error.c \
lib/snstring.c \
-- $(7z_SOURCES)
-+ $(nil)
+- $(7z_SOURCES) \
+ $(nil)
+-advmng_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS)
++advmng_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS) libadv7z.la
advdef_SOURCES = \
redef.cc \
-@@ -84,7 +88,7 @@
+@@ -95,9 +96,8 @@ advdef_SOURCES = \
lib/snstring.c \
lib/png.c \
lib/mng.c \
-- $(7z_SOURCES)
-+ $(nil)
+- $(7z_SOURCES) \
+ $(nil)
+-advdef_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS)
++advdef_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS) libadv7z.la
- EXTRA_DIST = \
- README AUTHORS HISTORY INSTALL COPYING \
---- advancecomp-1.23/configure.ac.orig 2016-11-21 18:26:40.000000000 +0100
-+++ advancecomp-1.23/configure.ac 2017-05-09 19:02:08.302701223 +0200
-@@ -2,6 +2,7 @@
- AC_PREREQ([2.65])
- AC_INIT([AdvanceCOMP], [1.23], [], [], [http://www.advancemame.it])
+ # Add the .version file in the distribution
+ dist-hook:
+--- advancecomp-2.6/configure.ac.orig 2023-10-10 17:17:08.000000000 +0200
++++ advancecomp-2.6/configure.ac 2024-04-17 19:07:04.858546549 +0200
+@@ -4,6 +4,7 @@ dnl Get version number from git
+ m4_define([git_revision], m4_esyscmd_s([./autover.sh]))
+ AC_INIT([AdvanceCOMP], [git_revision], [], [], [http://www.advancemame.it])
AM_INIT_AUTOMAKE([foreign no-dependencies subdir-objects])
+LT_INIT
AC_CONFIG_SRCDIR([rezip.cc])
diff --git a/advancecomp-system-libs.patch b/advancecomp-system-libs.patch
index 3273922..c9c1bc4 100644
--- a/advancecomp-system-libs.patch
+++ b/advancecomp-system-libs.patch
@@ -1,21 +1,23 @@
---- advancecomp-1.23/Makefile.am.orig 2016-11-21 18:28:02.000000000 +0100
-+++ advancecomp-1.23/Makefile.am 2016-12-18 22:10:03.761097301 +0100
-@@ -21,32 +21,9 @@
+--- advancecomp-2.6/Makefile.am.orig 2023-10-10 17:01:16.000000000 +0200
++++ advancecomp-2.6/Makefile.am 2024-04-17 18:59:18.464658604 +0200
+@@ -21,34 +21,10 @@ bin_PROGRAMS = advzip advpng advmng advd
7z/WindowIn.cc \
7z/WindowOut.cc
-libdeflate_SOURCES = \
+- libdeflate/arm/cpu_features.c \
+- libdeflate/x86/cpu_features.c \
- libdeflate/adler32.c \
-- libdeflate/aligned_malloc.c \
- libdeflate/crc32.c \
-- libdeflate/deflate_compress.c \
+- libdeflate/deflate_compress.c\
- libdeflate/deflate_decompress.c \
- libdeflate/gzip_compress.c \
- libdeflate/gzip_decompress.c \
-- libdeflate/x86_cpu_features.c \
+- libdeflate/utils.c \
- libdeflate/zlib_compress.c \
- libdeflate/zlib_decompress.c
-
+-
-zopfli_SOURCES = \
- zopfli/blocksplitter.c \
- zopfli/cache.c \
@@ -31,55 +33,56 @@
- zopfli/zopfli.h \
- zopfli/zopfli_lib.c
+libdeflate_LIBS = -ldeflate
++
++
+zopfli_LIBS = -lzopfli
-+LDADD = $(libdeflate_LIBS) $(zopfli_LIBS)
advzip_SOURCES = \
rezip.cc \
-@@ -58,9 +35,7 @@
- zipsh.cc \
- getopt.c \
+@@ -62,8 +38,8 @@ advzip_SOURCES = \
snprintf.c \
-- $(7z_SOURCES) \
+ portable.c \
+ $(7z_SOURCES) \
- $(libdeflate_SOURCES) \
- $(zopfli_SOURCES)
-+ $(7z_SOURCES)
++ $(nil)
++advzip_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS)
advpng_SOURCES = \
repng.cc \
-@@ -75,9 +50,7 @@
- lib/png.c \
+@@ -79,8 +55,8 @@ advpng_SOURCES = \
lib/error.c \
lib/snstring.c \
-- $(7z_SOURCES) \
+ $(7z_SOURCES) \
- $(libdeflate_SOURCES) \
- $(zopfli_SOURCES)
-+ $(7z_SOURCES)
++ $(nil)
++advpng_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS)
advmng_SOURCES = \
remng.cc \
-@@ -95,9 +68,7 @@
- lib/mng.c \
+@@ -101,8 +75,8 @@ advmng_SOURCES = \
lib/error.c \
lib/snstring.c \
-- $(7z_SOURCES) \
+ $(7z_SOURCES) \
- $(libdeflate_SOURCES) \
- $(zopfli_SOURCES)
-+ $(7z_SOURCES)
++ $(nil)
++advmng_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS)
advdef_SOURCES = \
redef.cc \
-@@ -113,9 +84,7 @@
- lib/snstring.c \
+@@ -120,8 +93,8 @@ advdef_SOURCES = \
lib/png.c \
lib/mng.c \
-- $(7z_SOURCES) \
+ $(7z_SOURCES) \
- $(libdeflate_SOURCES) \
- $(zopfli_SOURCES)
-+ $(7z_SOURCES)
++ $(nil)
++advdef_LDADD = $(libdeflate_LIBS) $(zopfli_LIBS)
- EXTRA_DIST = \
- README AUTHORS HISTORY INSTALL COPYING \
+ # Add the .version file in the distribution
+ dist-hook:
--- advancecomp-1.23/compress.h.orig 2016-09-26 22:04:03.000000000 +0200
+++ advancecomp-1.23/compress.h 2016-12-18 22:11:26.444429691 +0100
@@ -24,11 +24,11 @@
diff --git a/advancecomp.spec b/advancecomp.spec
index 648aebb..f87a778 100644
--- a/advancecomp.spec
+++ b/advancecomp.spec
@@ -5,15 +5,16 @@
Summary: Recompression utilities for .ZIP archives, .PNG snapshots, .MNG video clips and .gz files
Summary(pl.UTF-8): Narzędzia rekompresujące pliki ZIP, PNG, MNG, gz
Name: advancecomp
-Version: 1.23
-Release: 2
+Version: 2.6
+Release: 1
License: GPL v3+
Group: Applications/File
-Source0: http://downloads.sourceforge.net/advancemame/%{name}-%{version}.tar.gz
-# Source0-md5: 39a205f0ba1baa26550fccc6405a6b45
+#Source0Download: https://github.com/amadvance/advancecomp/releases
+Source0: https://github.com/amadvance/advancecomp/releases/download/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: fc7f6c2bdbabae26f90bf18ec63e9242
Patch0: %{name}-system-libs.patch
Patch1: %{name}-7z-lib.patch
-URL: http://advancemame.sourceforge.net/comp-readme.html
+URL: http://www.advancemame.it/comp-readme.html
BuildRequires: autoconf >= 2.65
BuildRequires: automake
%{?with_bzip2:BuildRequires: bzip2-devel}