summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2013-11-04 19:39:37 (GMT)
committerJakub Bogusz2013-11-04 19:39:37 (GMT)
commit72fafc20a07fd597a83a836f0c4c02154dee0554 (patch)
tree1b2aa1517a3b74f1640c390226286b1fd5dc2a7d
parent294a06901fcf7bad24b66717f1dbf2768211f2c7 (diff)
downloadZThread-72fafc20a07fd597a83a836f0c4c02154dee0554.zip
ZThread-72fafc20a07fd597a83a836f0c4c02154dee0554.tar.gz
- more fixes in c++ patch
-rw-r--r--ZThread-c++.patch18
-rw-r--r--ZThread.spec2
2 files changed, 19 insertions, 1 deletions
diff --git a/ZThread-c++.patch b/ZThread-c++.patch
index 3dcf4a8..d67167b 100644
--- a/ZThread-c++.patch
+++ b/ZThread-c++.patch
@@ -83,6 +83,24 @@
for(;;) {
--- ZThread-2.3.2/include/zthread/Guard.h.orig 2005-03-13 03:10:09.000000000 +0100
+++ ZThread-2.3.2/include/zthread/Guard.h 2008-09-10 18:14:58.176983956 +0200
+@@ -428,7 +428,7 @@
+ template <class U, class V>
+ Guard(Guard<U, V>& g) : LockHolder<LockType>(g) {
+
+- LockingPolicy::shareScope(*this, extract(g));
++ LockingPolicy::shareScope(*this, this->extract(g));
+
+ }
+
+@@ -458,7 +458,7 @@
+ template <class U, class V>
+ Guard(Guard<U, V>& g, LockType& lock) : LockHolder<LockType>(lock) {
+
+- LockingPolicy::transferScope(*this, extract(g));
++ LockingPolicy::transferScope(*this, this->extract(g));
+
+ }
+
@@ -491,7 +491,7 @@ Guard<LockType, LockingPolicy>::~Guard()
try {
diff --git a/ZThread.spec b/ZThread.spec
index 9696325..91fad1d 100644
--- a/ZThread.spec
+++ b/ZThread.spec
@@ -5,7 +5,7 @@ Version: 2.3.2
Release: 1
License: MIT
Group: Libraries
-Source0: http://dl.sourceforge.net/zthread/%{name}-%{version}.tar.gz
+Source0: http://downloads.sourceforge.net/zthread/%{name}-%{version}.tar.gz
# Source0-md5: f2782d19b8ed6f1ff2ab8824dd4ba48e
Patch0: %{name}-c++.patch
Patch1: %{name}-destdir.patch