summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2015-02-22 19:31:46 (GMT)
committerElan Ruusamäe2015-02-22 19:32:08 (GMT)
commit93c2628deecca91e6e345ca491b8847a7e304af6 (patch)
treedb3ebdeb2f074e83273b7cbb2664ebfc07979ec3
parentcaba5b6590d2b0db483c7248f2326f08e2b8ac91 (diff)
downloadQtLockedFile-93c2628deecca91e6e345ca491b8847a7e304af6.zip
QtLockedFile-93c2628deecca91e6e345ca491b8847a7e304af6.tar.gz
up to latest commit 17b56547d6e0d9a06603231fe2384474f9144829
-rw-r--r--QtLockedFile.spec34
1 files changed, 20 insertions, 14 deletions
diff --git a/QtLockedFile.spec b/QtLockedFile.spec
index 2dcfdea..c0d8a39 100644
--- a/QtLockedFile.spec
+++ b/QtLockedFile.spec
@@ -1,16 +1,22 @@
+
+# last commit to qtlockedfile subdir in
+# https://qt.gitorious.org/qt-solutions/qt-solutions/
+%define commit 17b56547d6e0d9a06603231fe2384474f9144829
Summary: QFile extension with advisory locking functions
Name: QtLockedFile
Version: 2.4
-Release: 1
+Release: 2
License: GPL v3 or LGPL v2 with exceptions
Group: Libraries
-URL: http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtlockedfile
-Source0: http://get.qt.nokia.com/qt/solutions/lgpl/qtlockedfile-%{version}_1-opensource.tar.gz
-# Source0-md5: ac8f848f59038a414f3ab4f4cc08e99c
+# git clone git@gitorious.org:qt-solutions/qt-solutions.git
+# git checkout %{commit}
+# tar -cjf QtLockedFile-%{version}.tar.bz2 -C qt-solutions/qtlockedfile .
+Source0: %{name}-%{version}.tar.bz2
+# Source0-md5: 8d0525b7f3dc92ee1464c6a538832535
Source1: qtlockedfile.prf
Patch0: qtlockedfile-dont-build-example.patch
-# Remove unnecessary linkage to libQtGui
-Patch1: qtlockedfile-dont-link-qtgui.patch
+Patch1: qtlockedfile-use-current-version.patch
+URL: http://doc.qt.digia.com/solutions/4/qtlockedfile/qtlockedfile.html
BuildRequires: QtCore-devel
BuildRequires: libstdc++-devel
BuildRequires: qt4-qmake
@@ -25,22 +31,21 @@ access the same file, QtLockedFile can be used to easily ensure that
only one process at a time is writing to the file, and that no process
is writing to it while others are reading it.
-%package devel
+%package devel
Summary: Development files for QtLockedFile library
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: qt4-build
Requires: qt4-qmake
-%description devel
+%description devel
This package contains libraries and header files for developing
applications that use QtLockedFile.
%prep
-%setup -q -n qtlockedfile-%{version}_1-opensource
+%setup -qc
%patch0 -p1
-%patch1 -p1
-
+%patch1 -p0
%build
touch .licenseAccepted
@@ -60,13 +65,13 @@ rm $RPM_BUILD_ROOT%{_libdir}/lib*-%{version}.so.1.0
# headers
install -d $RPM_BUILD_ROOT%{_includedir}/QtSolutions
-cp -a \
+cp -p \
src/qtlockedfile.h \
src/QtLockedFile \
$RPM_BUILD_ROOT%{_includedir}/QtSolutions
install -d $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
%clean
rm -rf $RPM_BUILD_ROOT
@@ -76,7 +81,8 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(644,root,root,755)
-%doc LGPL_EXCEPTION.txt LICENSE.* README.TXT
+%doc README.TXT
+#%doc LGPL_EXCEPTION.txt LICENSE.*
%attr(755,root,root) %{_libdir}/libQtSolutions_LockedFile-%{version}.so.*.*.*
%attr(755,root,root) %ghost %{_libdir}/libQtSolutions_LockedFile-%{version}.so.1