summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorshadzik2010-05-25 19:59:28 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commita220de66f782317a363bd765e9b9edfeb493f239 (patch)
treed8282d4f245b1745999830a4ee64600c8b00cad4
downloadPLDSetupAssistant-a220de66f782317a363bd765e9b9edfeb493f239.zip
PLDSetupAssistant-a220de66f782317a363bd765e9b9edfeb493f239.tar.gz
- init
Changed files: PLDSetupAssistant.spec -> 1.1
-rw-r--r--PLDSetupAssistant.spec55
1 files changed, 55 insertions, 0 deletions
diff --git a/PLDSetupAssistant.spec b/PLDSetupAssistant.spec
new file mode 100644
index 0000000..b7548d3
--- /dev/null
+++ b/PLDSetupAssistant.spec
@@ -0,0 +1,55 @@
+#
+%define kdever 4.4.3
+
+Summary: PLD Setup Assistant
+Summary(pl.UTF-8): Asysten konfiguracji PLD
+Name: PLDSetupAssistant
+Version: 0.1
+Release: 1
+License: GPL
+Group: X11/Applications
+Source0: %{name}-%{version}.tar.bz2
+# Source0-md5: eda58a079150838a503c232e06a0aa8c
+#URL: http://
+# leave only required ones
+BuildRequires: cmake >= 2.8.0
+BuildRequires: kde4-kdebase-devel >= %{kdever}
+BuildRequires: kde4-kdelibs-devel >= %{kdever}
+BuildRequires: rpmbuild(macros) >= 1.293
+BuildRequires: strigi-devel >= 0.5.10
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+PLD Setup Assistant.
+
+%description -l pl.UTF-8
+Asysten konfiguracji PLD.
+
+%prep
+%setup -q
+
+%build
+install -d build
+cd build
+%cmake .. \
+ -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
+ -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+%if "%{_lib}" == "lib64"
+ -DLIB_SUFFIX=64
+%endif
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} -C build install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/pldsetupassistant
+%{_datadir}/apps/pldsetupassistant