summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2010-11-15 09:23:02 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit4391dd547cf5233080b7f913114d9ab3e96bef82 (patch)
tree5ca427e75bf90c7950412b7f5a2d01bdcadcdc46
downloadMathJax-4391dd547cf5233080b7f913114d9ab3e96bef82.zip
MathJax-4391dd547cf5233080b7f913114d9ab3e96bef82.tar.gz
- initial revisionauto/th/MathJax-1_0_1a-1
Changed files: MathJax.spec -> 1.1
-rw-r--r--MathJax.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/MathJax.spec b/MathJax.spec
new file mode 100644
index 0000000..9212aa6
--- /dev/null
+++ b/MathJax.spec
@@ -0,0 +1,83 @@
+Summary: JavaScript display engine for mathematics
+#Summary(pl.UTF-8):
+Name: MathJax
+Version: 1.0.1a
+Release: 1
+License: Apache v2.0
+Group: Applications/WWW
+Source0: http://dl.sourceforge.net/mathjax/%{name}-v%{version}.zip
+# Source0-md5: b93c1f1e26a898faee072ab7aec57251
+URL: http://www.mathjax.org/
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires: webapps
+Requires: webserver(access)
+Requires: webserver(alias)
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define _webapps /etc/webapps
+%define _webapp %{name}
+%define _sysconfdir %{_webapps}/%{_webapp}
+%define _appdir %{_datadir}/%{_webapp}
+
+%description
+MathJax is an open source JavaScript display engine for mathematics
+that works in all modern browsers.
+
+#%description -l pl.UTF-8
+
+%prep
+%setup -q -n %{name}
+
+cat > apache.conf <<'EOF'
+Alias /%{name} %{_appdir}
+<Directory %{_appdir}>
+ Allow from all
+</Directory>
+EOF
+
+cat > lighttpd.conf <<'EOF'
+alias.url += (
+ "/%{name}" => "%{_appdir}",
+)
+EOF
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
+
+cp -a MathJax.js config extensions fonts jax $RPM_BUILD_ROOT%{_appdir}
+
+cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+cp -a lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+
+%triggerin -- apache1 < 1.3.37-3, apache1-base
+%webapp_register apache %{_webapp}
+
+%triggerun -- apache1 < 1.3.37-3, apache1-base
+%webapp_unregister apache %{_webapp}
+
+%triggerin -- apache < 2.2.0, apache-base
+%webapp_register httpd %{_webapp}
+
+%triggerun -- apache < 2.2.0, apache-base
+%webapp_unregister httpd %{_webapp}
+
+%triggerin -- lighttpd
+%webapp_register lighttpd %{_webapp}
+
+%triggerun -- lighttpd
+%webapp_unregister lighttpd %{_webapp}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README.txt docs test unpacked
+%dir %attr(750,root,http) %{_sysconfdir}
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
+%{_appdir}