summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GLStats-cmake.patch42
-rw-r--r--GLStats-update.patch57
-rw-r--r--GLStats.spec12
3 files changed, 95 insertions, 16 deletions
diff --git a/GLStats-cmake.patch b/GLStats-cmake.patch
index ae27bf9..b7ab482 100644
--- a/GLStats-cmake.patch
+++ b/GLStats-cmake.patch
@@ -1,14 +1,34 @@
---- GLStats-0.3.1/CMakeLists.txt.orig 2014-10-07 11:54:53.000000000 +0200
-+++ GLStats-0.3.1/CMakeLists.txt 2014-12-20 21:44:32.998326854 +0100
-@@ -19,11 +19,6 @@
+--- GLStats-0.3.2/CMake/FindPackages.cmake.orig 2024-04-21 13:23:23.180915783 +0200
++++ GLStats-0.3.2/CMake/FindPackages.cmake 2024-04-21 13:23:27.200894005 +0200
+@@ -1,6 +1,5 @@
+ # generated by Buildyard, do not edit.
+
+-include(System)
+ list(APPEND FIND_PACKAGES_DEFINES ${SYSTEM})
+ # Copyright (c) 2014 Stefan.Eilemann@epfl.ch
+
+@@ -136,7 +135,6 @@ endif()
+ file(APPEND ${DEFINES_FILE_IN}
+ "\n#endif\n")
+
+-include(UpdateFile)
+ configure_file(${DEFINES_FILE_IN} ${DEFINES_FILE} COPYONLY)
+ if(Boost_FOUND) # another WAR for broken boost stuff...
+ set(Boost_VERSION ${Boost_MAJOR_VERSION}.${Boost_MINOR_VERSION}.${Boost_SUBMINOR_VERSION})
+--- GLStats-0.3.2/CMakeLists.txt.orig 2015-07-07 12:40:32.000000000 +0200
++++ GLStats-0.3.2/CMakeLists.txt 2024-04-21 13:27:45.259495982 +0200
+@@ -15,6 +15,14 @@ set(VERSION_PATCH "2")
+ set(VERSION_ABI 1)
+
+ set(PROJECT_INCLUDE_NAME "GLStats")
++set(PROJECT_VERSION_MAJOR "${VERSION_MAJOR}")
++set(PROJECT_VERSION_MINOR "${VERSION_MINOR}")
++set(PROJECT_VERSION_PATCH "${VERSION_PATCH}")
++set(PROJECT_VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}")
++set(GLStats_VERSION "${PROJECT_VERSION}")
++set(GLStats_VERSION_ABI "${VERSION_ABI}")
++set(GLSTATS_INCLUDE_NAME "GLStats")
++set(GLSTATS_LICENSE "LGPL")
include(Common)
--include(Buildyard)
--if(BUILDYARD_STOP)
-- return()
--endif()
--
- set(FIND_PACKAGES_DEFINES GLSTATS_STATIC)
- include(FindPackages)
- set(GLSTATS_DEPENDENT_LIBRARIES Lunchbox)
diff --git a/GLStats-update.patch b/GLStats-update.patch
new file mode 100644
index 0000000..bf95fb0
--- /dev/null
+++ b/GLStats-update.patch
@@ -0,0 +1,57 @@
+--- GLStats-0.3.2/GLStats/data.cpp.orig 2015-07-07 12:40:32.000000000 +0200
++++ GLStats-0.3.2/GLStats/data.cpp 2024-04-21 18:16:45.032225044 +0200
+@@ -23,14 +23,15 @@
+ #include "type.h"
+
+ #include <lunchbox/debug.h>
+-#include <lunchbox/stdExt.h>
++#include <servus/uint128_t.h>
+ #include <limits>
++#include <unordered_map>
+
+ namespace GLStats
+ {
+-typedef stde::hash_map< uint32_t, Entity > EntityMap;
++typedef std::unordered_map< uint32_t, Entity > EntityMap;
+ typedef EntityMap::const_iterator EntityMapCIter;
+-typedef stde::hash_map< uint32_t, Thread > ThreadMap;
++typedef std::unordered_map< uint32_t, Thread > ThreadMap;
+ typedef ThreadMap::const_iterator ThreadMapCIter;
+ typedef Items::const_iterator ItemsCIter;
+ typedef Items::iterator ItemsIter;
+--- GLStats-0.3.2/GLStats/renderer.cpp.orig 2015-07-07 12:40:32.000000000 +0200
++++ GLStats-0.3.2/GLStats/renderer.cpp 2024-04-21 18:16:31.875629652 +0200
+@@ -25,10 +25,12 @@
+
+ #include <lunchbox/debug.h>
+ #include <lunchbox/os.h>
+-#include <lunchbox/stdExt.h>
++#include <servus/uint128_t.h>
+
++#include <algorithm>
+ #include <map>
+ #include <set>
++#include <unordered_map>
+ #ifdef __APPLE__
+ # include <OpenGL/gl.h>
+ #else
+@@ -48,7 +50,7 @@ typedef std::set< uint32_t > ThreadSet;
+ typedef ThreadSet::const_iterator ThreadSetCIter;
+ typedef std::map< uint32_t, ThreadSet > EntityMap;
+ typedef EntityMap::const_iterator EntityMapCIter;
+-typedef stde::hash_map< uint32_t, float > EntityPos;
++typedef std::unordered_map< uint32_t, float > EntityPos;
+
+ typedef Items::const_iterator ItemsCIter;
+
+@@ -122,8 +124,8 @@ public:
+ const Item* last = &items.front();
+ typedef std::pair< uint32_t, uint64_t > FrameTime;
+ typedef std::vector< FrameTime > FrameTimes;
+- typedef stde::hash_map< uint64_t, FrameTimes > FrameTimesMap;
+- typedef stde::hash_map< uint32_t, uint64_t > FrameEndMap;
++ typedef std::unordered_map< uint64_t, FrameTimes > FrameTimesMap;
++ typedef std::unordered_map< uint32_t, uint64_t > FrameEndMap;
+ typedef FrameTimes::const_iterator FrameTimesCIter;
+ typedef FrameTimesMap::const_iterator FrameTimesMapCIter;
+ typedef FrameEndMap::const_iterator FrameEndMapCIter;
diff --git a/GLStats.spec b/GLStats.spec
index 975ba42..51cccac 100644
--- a/GLStats.spec
+++ b/GLStats.spec
@@ -5,19 +5,21 @@
Summary: Generic OpenGL overlay statistics renderer
Summary(pl.UTF-8): Ogólna biblioteka do renderowania statystyk na nakładce OpenGL
Name: GLStats
-Version: 0.3.1
+Version: 0.3.2
Release: 1
License: LGPL v2.1
Group: Libraries
+#Source0Download: https://github.com/Eyescale/GLStats/tags
Source0: https://github.com/Eyescale/GLStats/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: ed80f815bdfdb714aa6269d35c6bfcc1
+# Source0-md5: 4af2acee59974144ae2cad2930af14aa
Patch0: %{name}-cmake.patch
Patch1: %{name}-shared.patch
+Patch2: %{name}-update.patch
URL: https://github.com/Eyescale/GLStats/
-BuildRequires: Eyescale-CMake
+BuildRequires: Eyescale-CMake >= 2018.2
BuildRequires: Lunchbox-devel >= 1.10
+BuildRequires: Servus-devel
BuildRequires: OpenGL-devel
-BuildRequires: boost-devel >= 1.41.0
BuildRequires: cmake >= 2.8
%{?with_apidocs:BuildRequires: doxygen}
BuildRequires: libstdc++-devel
@@ -60,6 +62,7 @@ Dokumentacja API biblioteki GLStats.
%setup -q
%patch0 -p1
%patch1 -p1
+%patch2 -p1
ln -s %{_datadir}/Eyescale-CMake CMake/common
%{__rm} .gitexternals
@@ -97,7 +100,6 @@ rm -rf $RPM_BUILD_ROOT
%defattr(644,root,root,755)
%attr(755,root,root) %{_libdir}/libGLStats.so
%{_includedir}/GLStats
-%{_pkgconfigdir}/GLStats.pc
%dir %{_datadir}/GLStats
%{_datadir}/GLStats/CMake