summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2014-10-02 18:57:13 (GMT)
committerJakub Bogusz2014-10-02 18:57:13 (GMT)
commit979439cc727339e05735d1eef8f3b3aa950adb08 (patch)
treef41634db670de1a047c7e371d0a3d0c8d1ab65dc
parent928ad810fafad442d395c444cbc4c505bd813b3c (diff)
downloadCCOLAMD-979439cc727339e05735d1eef8f3b3aa950adb08.zip
CCOLAMD-979439cc727339e05735d1eef8f3b3aa950adb08.tar.gz
- updated to 2.9.0auto/th/CCOLAMD-2.9.0-1
- updated ufconfig,shared patches
-rw-r--r--CCOLAMD.spec8
-rw-r--r--ccolamd-shared.patch35
-rw-r--r--ccolamd-ufconfig.patch14
3 files changed, 30 insertions, 27 deletions
diff --git a/CCOLAMD.spec b/CCOLAMD.spec
index 083a5ba..35267c0 100644
--- a/CCOLAMD.spec
+++ b/CCOLAMD.spec
@@ -1,16 +1,16 @@
Summary: CCOLAMD: constrained column approximate minimum degree
Summary(pl.UTF-8): CCOLAMD - przybliżony ograniczony algorytm minimalnego stopnia dla kolumn
Name: CCOLAMD
-Version: 2.8.0
+Version: 2.9.0
Release: 1
License: LGPL v2.1+
Group: Libraries
Source0: http://www.cise.ufl.edu/research/sparse/ccolamd/%{name}-%{version}.tar.gz
-# Source0-md5: a0af8b91c3d24eba5d4818e88c6c288c
+# Source0-md5: ae0739c8bc2881587a0ce3c3dd0e1812
Patch0: ccolamd-ufconfig.patch
Patch1: ccolamd-shared.patch
URL: http://www.cise.ufl.edu/research/sparse/ccolamd/
-BuildRequires: SuiteSparse_config >= 4.0.0
+BuildRequires: SuiteSparse_config >= 4.3.0
BuildRequires: libtool >= 2:1.5
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -39,7 +39,7 @@ Summary: Header files for CCOLAMD library
Summary(pl.UTF-8): Pliki nagłówkowe biblioteki CCOLAMD
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
-Requires: SuiteSparse_config >= 4.0.0
+Requires: SuiteSparse_config >= 4.3.0
%description devel
Header files for CCOLAMD library.
diff --git a/ccolamd-shared.patch b/ccolamd-shared.patch
index 60fc6b4..93a0e2e 100644
--- a/ccolamd-shared.patch
+++ b/ccolamd-shared.patch
@@ -1,23 +1,22 @@
-diff -ur CCOLAMD/Demo/Makefile CCOLAMD-shared/Demo/Makefile
---- CCOLAMD/Demo/Makefile 2007-12-02 15:48:48.000000000 +0100
-+++ CCOLAMD-shared/Demo/Makefile 2007-12-02 15:48:31.000000000 +0100
-@@ -20,12 +20,12 @@
+--- CCOLAMD/Demo/Makefile.orig 2014-10-02 18:27:24.372931816 +0200
++++ CCOLAMD/Demo/Makefile 2014-10-02 19:24:24.356121609 +0200
+@@ -23,12 +23,12 @@
dist:
ccolamd_example: ccolamd_example.c library
-- $(C) -o ccolamd_example ccolamd_example.c ../Lib/libccolamd.a -lm
-+ libtool --tag=CC --mode=link $(C) $(LDFLAGS) -o ccolamd_example ccolamd_example.c ../Lib/libccolamd.la -lm
+- $(C) -o ccolamd_example ccolamd_example.c ../Lib/libccolamd.a $(LIB2)
++ libtool --tag=CC --mode=link $(C) $(LDFLAGS) -o ccolamd_example ccolamd_example.c ../Lib/libccolamd.la $(LIB2)
- ./ccolamd_example > my_ccolamd_example.out
- diff ccolamd_example.out my_ccolamd_example.out
ccolamd_l_example: ccolamd_l_example.c library
-- $(C) -o ccolamd_l_example ccolamd_l_example.c ../Lib/libccolamd.a -lm
-+ libtool --tag=CC --mode=link $(C) $(LDFLAGS) -o ccolamd_l_example ccolamd_l_example.c ../Lib/libccolamd.la -lm
+- $(C) -o ccolamd_l_example ccolamd_l_example.c ../Lib/libccolamd.a $(LIB2)
++ libtool --tag=CC --mode=link $(C) $(LDFLAGS) -o ccolamd_l_example ccolamd_l_example.c ../Lib/libccolamd.la $(LIB2)
- ./ccolamd_l_example > my_ccolamd_l_example.out
- - diff ccolamd_example.out my_ccolamd_example.out
+ - diff ccolamd_l_example.out my_ccolamd_l_example.out
---- CCOLAMD/Lib/Makefile.orig 2012-01-01 15:02:59.719704930 +0100
-+++ CCOLAMD/Lib/Makefile 2012-01-01 15:57:38.526481381 +0100
+--- CCOLAMD/Lib/Makefile.orig 2014-10-02 20:27:21.509296447 +0200
++++ CCOLAMD/Lib/Makefile 2014-10-02 20:35:12.779276670 +0200
@@ -2,7 +2,8 @@
# CCOLAMD Makefile
#-------------------------------------------------------------------------------
@@ -28,25 +27,23 @@ diff -ur CCOLAMD/Demo/Makefile CCOLAMD-shared/Demo/Makefile
include /usr/share/misc/SuiteSparse_config.mk
-@@ -13,16 +14,19 @@
- SRC = ../Source/ccolamd.c ../Source/ccolamd_global.c
+@@ -13,15 +14,18 @@
+ SRC = ../Source/ccolamd.c
# creates libccolamd.a, a C-callable COLAMD library
-libccolamd.a: $(SRC) $(INC)
-- $(CC) $(CF) $(I) -c ../Source/ccolamd_global.c
- $(CC) $(CF) $(I) -c ../Source/ccolamd.c
- $(CC) $(CF) $(I) -c ../Source/ccolamd.c -DDLONG -o ccolamd_l.o
-- $(ARCHIVE) libccolamd.a ccolamd.o ccolamd_l.o ccolamd_global.o
+- $(ARCHIVE) libccolamd.a ccolamd.o ccolamd_l.o
- - $(RANLIB) libccolamd.a
+libccolamd.la: $(SRC) $(INC)
-+ libtool --tag=CC --mode=compile $(CC) $(CF) $(I) -c ../Source/ccolamd_global.c
+ libtool --tag=CC --mode=compile $(CC) $(CF) $(I) -c ../Source/ccolamd.c
+ libtool --tag=CC --mode=compile $(CC) $(CF) $(I) -c ../Source/ccolamd.c -DDLONG -o ccolamd_l.o
-+ libtool --tag=CC --mode=link $(CC) $(LDFLAGS) -o libccolamd.la -rpath $(libdir) ccolamd.lo ccolamd_l.lo ccolamd_global.lo -lm
++ libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -o libccolamd.la -rpath $(libdir) ccolamd.lo ccolamd_l.lo -lsuitesparseconfig -lm
+
+install: libccolamd.la
+ install -d $(DESTDIR)$(libdir)
-+ libtool --mode=install cp libccolamd.la $(DESTDIR)$(libdir)/libccolamd.la
++ libtool --mode=install install libccolamd.la $(DESTDIR)$(libdir)
-ccode: libccolamd.a
+ccode: libccolamd.la
@@ -56,7 +53,7 @@ diff -ur CCOLAMD/Demo/Makefile CCOLAMD-shared/Demo/Makefile
clean:
- $(RM) $(CLEAN)
-@@ -30,4 +34,4 @@
+@@ -29,4 +33,4 @@
purge: distclean
distclean: clean
diff --git a/ccolamd-ufconfig.patch b/ccolamd-ufconfig.patch
index 3d97753..55ab274 100644
--- a/ccolamd-ufconfig.patch
+++ b/ccolamd-ufconfig.patch
@@ -20,10 +20,9 @@
# Compile all C code, including the C-callable routine and the mexFunctions.
# Do not the MATLAB interface.
-diff -ur CCOLAMD/Demo/Makefile CCOLAMD.UF/Demo/Makefile
--- CCOLAMD/Demo/Makefile 2007-05-05 15:42:44.000000000 +0200
+++ CCOLAMD.UF/Demo/Makefile 2007-12-02 15:41:19.000000000 +0100
-@@ -4,9 +4,9 @@
+@@ -4,16 +4,15 @@
default: ccolamd_example ccolamd_l_example
@@ -33,9 +32,16 @@ diff -ur CCOLAMD/Demo/Makefile CCOLAMD.UF/Demo/Makefile
-I = -I../Include -I../../SuiteSparse_config
+I = -I../Include
- C = $(CC) $(CFLAGS) $(I)
+ C = $(CC) $(CF) $(I)
-diff -ur CCOLAMD/Lib/Makefile CCOLAMD.UF/Lib/Makefile
+-LIB2 = ../../SuiteSparse_config/libsuitesparseconfig.a $(LIB)
++LIB2 = -lsuitesparseconfig $(LIB)
+
+ library:
+- ( cd ../../SuiteSparse_config ; $(MAKE) )
+ ( cd ../Lib ; $(MAKE) )
+
+ #------------------------------------------------------------------------------
--- CCOLAMD/Lib/Makefile 2007-05-05 15:41:47.000000000 +0200
+++ CCOLAMD.UF/Lib/Makefile 2007-12-02 15:42:02.000000000 +0100
@@ -4,11 +4,11 @@