summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Gołaszewski2004-10-18 08:25:00 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitd0744ddf167bfa56fbf62288d6a4eb2c6cf9875d (patch)
tree05b3018148ef54a1f157a552e169d2be6571ae6e
parent556f9966301b0521a9097e8d0980f4b821a31920 (diff)
downloadApache-Gallery-d0744ddf167bfa56fbf62288d6a4eb2c6cf9875d.zip
Apache-Gallery-d0744ddf167bfa56fbf62288d6a4eb2c6cf9875d.tar.gz
- release 2 - added config for apache, modified icons location (kill
services) Changed files: Apache-Gallery.spec -> 1.11
-rw-r--r--Apache-Gallery.spec59
1 files changed, 30 insertions, 29 deletions
diff --git a/Apache-Gallery.spec b/Apache-Gallery.spec
index 4e8be8a..06860e2 100644
--- a/Apache-Gallery.spec
+++ b/Apache-Gallery.spec
@@ -1,6 +1,3 @@
-# TODO:
-# - prepare subpackage with virtual
-# - configuration for apache
#
%bcond_with tests # Build with tests
@@ -10,12 +7,12 @@ Summary: An Apache module for creating an online gallery
Summary(pl): Modu³ Apache'a do tworzenia galerii online
Name: Apache-Gallery
Version: 0.9.1
-Release: 1
+Release: 2
License: Artistic
Group: Applications/Graphics
Source0: http://apachegallery.dk/download/%{name}-%{version}.tar.gz
# Source0-md5: 882e650e6fc3f059e84eca1564b5f32f
-#Source1: %{name}.conf
+Source1: %{name}.conf
Patch0: %{name}-apache2.patch
URL: http://apachegallery.dk/
BuildRequires: apache-mod_perl >= 1.99
@@ -34,7 +31,8 @@ Conflicts: apache-mod_autoindex
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%define _noautoreq 'perl(APR::Table)' 'perl(Apache2)' 'perl(Apache::Const)' 'perl(Apache::RequestIO)' 'perl(Apache::RequestRec)' 'perl(Apache::SubRequest)'
-%define _apacheicons /home/services/httpd/icons/gallery
+%define _appdir %{_datadir}/%{name}
+%define _apacheicons %{_appdir}/icons
%description
Apache::Gallery is a mod_perl handler that sits on top of your
@@ -65,44 +63,47 @@ przeskalowywane w locie i buforowane.
%install
rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_datadir}/%{name}/templates/{new,default},%{_apacheicons}}
+install -d $RPM_BUILD_ROOT{%{_appdir}/templates/{new,default},%{_apacheicons},/etc/httpd}
%{__make} install \
DESTDIR=$RPM_BUILD_ROOT
-install templates/new/*.{css,tpl} $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/new/
-install templates/default/*.{css,tpl} $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/default/
+install templates/new/*.{css,tpl} $RPM_BUILD_ROOT%{_appdir}/templates/new/
+install templates/default/*.{css,tpl} $RPM_BUILD_ROOT%{_appdir}/templates/default/
install htdocs/*.png $RPM_BUILD_ROOT%{_apacheicons}
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/httpd.conf/99_%{name}.conf
+
%clean
rm -rf $RPM_BUILD_ROOT
-#%post
-#if [ -f /var/lock/subsys/httpd ]; then
-# /etc/rc.d/init.d/httpd restart 1>&2
-#else
-# echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
-#fi
+%post
+if [ -f /var/lock/subsys/httpd ]; then
+ /etc/rc.d/init.d/httpd reload 1>&2
+else
+ echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+fi
-#%preun
-#if [ "$1" = "0" ]; then
-# if [ -f /var/lock/subsys/httpd ]; then
-# /etc/rc.d/init.d/httpd restart 1>&2
-# fi
-#fi
+%preun
+if [ "$1" = "0" ]; then
+ if [ -f /var/lock/subsys/httpd ]; then
+ /etc/rc.d/init.d/httpd reload 1>&2
+ fi
+fi
%files
%defattr(644,root,root,755)
%doc Changes INSTALL README TODO UPGRADE
+%attr(640,root,http) %config(noreplace) %verify(not size mtime md5) /etc/httpd/httpd.conf/*%{name}.conf
%{perl_vendorlib}/Apache/Gallery.pm
-%dir %{_datadir}/%{name}
-%dir %{_datadir}/%{name}/templates
-%dir %{_datadir}/%{name}/templates/new
-%{_datadir}/%{name}/templates/new/*.tpl
-%{_datadir}/%{name}/templates/new/*.css
-%dir %{_datadir}/%{name}/templates/default
-%{_datadir}/%{name}/templates/default/*.tpl
-%{_datadir}/%{name}/templates/default/*.css
+%dir %{_appdir}
+%dir %{_appdir}/templates
+%dir %{_appdir}/templates/new
+%{_appdir}/templates/new/*.tpl
+%{_appdir}/templates/new/*.css
+%dir %{_appdir}/templates/default
+%{_appdir}/templates/default/*.tpl
+%{_appdir}/templates/default/*.css
%dir %{_apacheicons}
%{_apacheicons}/*.png
%{_mandir}/man3/*.3*