summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Gołaszewski2004-05-06 15:18:36 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit53a2c683464ab2967ebdd3d260de188ea34b7597 (patch)
treedd5d12831e1f75033c54e23f69abbde189f8679a
parent9ae8fbc7b641013c37d973e64bd465dba3203fed (diff)
downloadApache-Gallery-53a2c683464ab2967ebdd3d260de188ea34b7597.zip
Apache-Gallery-53a2c683464ab2967ebdd3d260de188ea34b7597.tar.gz
- now it works with RA - feel free to prepare it for AC...RA-branch
Changed files: Apache-Gallery.spec -> 1.3
-rw-r--r--Apache-Gallery.spec23
1 files changed, 21 insertions, 2 deletions
diff --git a/Apache-Gallery.spec b/Apache-Gallery.spec
index eee6887..39dc5b9 100644
--- a/Apache-Gallery.spec
+++ b/Apache-Gallery.spec
@@ -9,22 +9,27 @@ Summary: An Apache module for creating an online gallery
Summary(pl): Modu³ Apache'a do tworzenia galerii online
Name: Apache-Gallery
Version: 0.8
-Release: 0.1
+Release: 0.6
License: Artistic
Group: Applications/Graphics
Source0: http://apachegallery.dk/download/%{name}-%{version}.tar.gz
# Source0-md5: 21ec1b8b11240dc6e3dbba19c6330120
#Source1: %{name}.conf
URL: http://apachegallery.dk/
+BuildRequires: apache-mod_perl
BuildRequires: perl-Image-Imlib2 >= 1.00
BuildRequires: perl-Image-Info
BuildRequires: perl-Image-Size
BuildRequires: perl-Text-Template
BuildRequires: perl-devel
+BuildRequires: perl-libapreq
BuildRequires: rpm-perlprov >= 3.0.3-16
Requires: apache-mod_perl
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+%define _noautoreq 'perl(APR::Table)' 'perl(Apache2)' 'perl(Apache::Const)' 'perl(Apache::RequestIO)' 'perl(Apache::RequestRec)' 'perl(Apache::SubRequest)'
+%define _apacheicons /home/httpd/icons/gallery
+
%description
Apache::Gallery is a mod_perl handler that sits on top of your
DocumentRoot and creates an image gallery of the files and directories
@@ -45,14 +50,19 @@ przeskalowywane w locie i buforowane.
%build
%{__perl} Makefile.PL
%{__make}
-#%{__make} test
+%{__make} test
%install
rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_datadir}/%{name}/templates/{new,default},%{_apacheicons}}
%{__make} install \
DESTDIR=$RPM_BUILD_ROOT
+install templates/new/*.{css,tpl} $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/new/
+install templates/default/*.{css,tpl} $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/default/
+install htdocs/*.png $RPM_BUILD_ROOT%{_apacheicons}
+
%clean
rm -rf $RPM_BUILD_ROOT
@@ -74,4 +84,13 @@ rm -rf $RPM_BUILD_ROOT
%defattr(644,root,root,755)
%doc Changes INSTALL README TODO UPGRADE
%{perl_sitelib}/Apache/Gallery.pm
+%dir %{_datadir}/%{name}
+%dir %{_datadir}/%{name}/templates
+%dir %{_datadir}/%{name}/templates/new
+%{_datadir}/%{name}/templates/new/*.tpl
+%{_datadir}/%{name}/templates/new/*.css
+%dir %{_datadir}/%{name}/templates/default
+%{_datadir}/%{name}/templates/default/*.tpl
+%{_datadir}/%{name}/templates/default/*.css
+%{_apacheicons}/*.png
%{_mandir}/man3/*.3*