summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpascalek2007-03-07 09:15:32 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit03f71889f9986da9819b83c2328c6727ab840ade (patch)
tree9cf75dea88381682139bf4e3f9f7a81f60e5d324
download3DM2-9650SE-03f71889f9986da9819b83c2328c6727ab840ade.zip
3DM2-9650SE-03f71889f9986da9819b83c2328c6727ab840ade.tar.gz
- initial revision
Changed files: 3DM2-9650SE.spec -> 1.1 3dm2-9650SE.init -> 1.1
-rw-r--r--3DM2-9650SE.spec110
-rw-r--r--3dm2-9650SE.init69
2 files changed, 179 insertions, 0 deletions
diff --git a/3DM2-9650SE.spec b/3DM2-9650SE.spec
new file mode 100644
index 0000000..cda36e8
--- /dev/null
+++ b/3DM2-9650SE.spec
@@ -0,0 +1,110 @@
+Summary: 3DM2 Management Utility
+Summary(pl.UTF-8): Narzędzie do zarządzania kontrolerami 3DM2
+Name: 3DM2-9650SE
+Version: 9.4.0.1
+Release: 1
+License: commercial
+Group: Development/Libraries
+Source0: http://www.3ware.com/download/Escalade9650SE-Series/%{version}/3DM2-Linux-%{version}.tgz
+# NoSource0-md5: 9505131021bafae54aa6d935202ce8e2
+NoSource: 0
+Source1: http://www.3ware.com/download/Escalade9650SE-Series/%{version}/%{version}_Release_Notes_Web.pdf
+# NoSource1-md5: a1f1cf93813592ea3499735ee598e673
+NoSource: 1
+Source2: 3dm2-9650SE.init
+URL: http://www.3ware.com/products/raid_management.asp
+Requires(post,preun): /sbin/chkconfig
+Requires: rc-scripts
+ExclusiveArch: %{ix86} %{x8664}
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+3DM2 Management Utility for 3ware RAID controllers. It supports
+AMCC 3ware 9650SE controlers.
+
+%description -l pl.UTF-8
+Narzędzie 3DM2 do zarządzania kontrolerami RAID 3ware. Obsługuje
+kontrolery z serii AMCC 3ware 9650SE.
+
+%prep
+%setup -q -c -n 3DM2
+tar -xvzf 3dm-lnx.tgz
+tar -xvzf 3dm-help.tgz
+tar -xvzf 3dm-msg.tgz
+cp %{SOURCE1} .
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_sbindir}
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/3dm2
+install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
+install -d $RPM_BUILD_ROOT%{_datadir}/3dm2/msg
+
+cp -a en $RPM_BUILD_ROOT%{_datadir}/3dm2
+install *_msg_en $RPM_BUILD_ROOT%{_datadir}/3dm2/msg
+%ifarch %{ix86}
+install 3dm2.x86 $RPM_BUILD_ROOT%{_sbindir}/3dm2
+%endif
+%ifarch %{x8664}
+install 3dm2.x8664 $RPM_BUILD_ROOT%{_sbindir}/3dm2
+%endif
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/3dm2
+
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/3dm2/3dm2.conf << EOF
+Port 888
+EmailEnable 0
+EmailSender [none]
+EmailServer [none]
+EmailRecipient [none]
+EmailSeverity 3
+ROpwd twOmwmsK8lKk2
+ADMINpwd twOmwmsK8lKk2
+RemoteAccess 0
+Language 0
+Logger 0
+Refresh 5
+BGRate 3333333333333333
+MsgPath /usr/share/3dm2/msg
+imgPath /usr/share/3dm2
+Help /usr/share/3dm2
+OEM 0
+AutoLogout 0
+CommandLog 1
+EOF
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+/sbin/chkconfig --add 3dm2
+%service 3dm2 restart "3DM2 Utility"
+
+%preun
+if [ "$1" = "0" ]; then
+ /sbin/chkconfig --del 3dm2
+ %service 3dm2 stop
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc version.3dm license.txt %{version}_Release_Notes_Web.pdf
+%attr(755,root,root) %{_sbindir}/*
+%dir %{_sysconfdir}/3dm2
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/3dm2/3dm2.conf
+%dir %{_datadir}/3dm2
+%dir %{_datadir}/3dm2/msg
+%dir %{_datadir}/3dm2/en
+%dir %{_datadir}/3dm2/en/css
+%dir %{_datadir}/3dm2/en/images
+%dir %{_datadir}/3dm2/en/scripts
+%{_datadir}/3dm2/msg/*msg*
+%{_datadir}/3dm2/en/*.html
+%{_datadir}/3dm2/en/*.gif
+%{_datadir}/3dm2/en/*.jpg
+%{_datadir}/3dm2/en/css/*.css
+%{_datadir}/3dm2/en/images/*.gif
+%{_datadir}/3dm2/en/images/*.png
+%{_datadir}/3dm2/en/images/*.jpg
+%{_datadir}/3dm2/en/images/*.JPG
+%{_datadir}/3dm2/en/scripts/*.js
+%attr(754,root,root) /etc/rc.d/init.d/3dm2
diff --git a/3dm2-9650SE.init b/3dm2-9650SE.init
new file mode 100644
index 0000000..355b09c
--- /dev/null
+++ b/3dm2-9650SE.init
@@ -0,0 +1,69 @@
+#!/bin/sh
+#
+# 3dm2: Starts the 3ware daemon
+#
+# Author: Rafal Cygnarowski <pascalek@pld-linux.org>
+#
+# chkconfig: 345 40 60
+# description: Start the 3dm2 application which logs the current state
+# of the 3ware DiskSwitch controller card, and then polls
+# for state changes.
+#
+# processname: 3dm2
+# config: /etc/3dm2/3dm2.conf
+
+# Source function library.
+. /etc/rc.d/init.d/functions
+
+RETVAL=0
+
+# See how we were called.
+case "$1" in
+ start)
+ if [ ! -f /var/lock/subsys/3dm2 ]; then
+ msg_starting "3DM2 Utility"
+ start-stop-daemon --start --quiet --exec /usr/sbin/3dm2
+ RETVAL=$?
+ if [ $RETVAL -eq 0 ]; then
+ ok
+ touch /var/lock/subsys/3dm2
+ else
+ fail
+ RETVAL=1
+ fi
+ else
+ msg_already_running "3DM2 Utility"
+ fi
+ ;;
+ stop)
+ if [ -f /var/lock/subsys/3dm2 ]; then
+ msg_stopping "3DM2 Utility"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/3dm2 1> /dev/null
+ RETVAL=$?
+ if [ $RETVAL -eq 0 ]; then
+ ok
+ rm -f /var/lock/subsys/3dm2
+ else
+ fail
+ RETVAL=1
+ fi
+ else
+ msg_not_running "3DM2 Utility"
+ fi
+ ;;
+ status)
+ status 3dm2
+ RETVAL=$?
+ ;;
+ restart)
+ $0 stop
+ sleep 2
+ $0 start
+ RETVAL=$?
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|status|restart}"
+ exit 1
+esac
+
+exit $RETVAL