]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - python3-ext.spec
- spaces to tabs
[projects/template-specs.git] / python3-ext.spec
index 57d323f0ffa4149352ad815a73cfedb041a89c1e..8d6c7131db0bf2ea9cb52408b9c74ccdc6e5570e 100644 (file)
@@ -3,10 +3,10 @@
 # use template-specs/python3.spec for pure python packages
 #
 # Conditional build:
-%bcond_without doc     # don't build doc
-%bcond_without tests   # do not perform "make test"
+%bcond_without doc     # API documentation
+%bcond_without tests   # unit tests
 
-%define        module  template
+%define                module  template
 Summary:       -
 Summary(pl.UTF-8):     -
 # Name must match the python module/package name (as on pypi or in 'import' statement)
@@ -21,13 +21,15 @@ Source0:    https://files.pythonhosted.org/packages/source/M/MODULE/%{module}-%{ver
 # Source0-md5: -
 #URL:          https://pypi.org/project/MODULE/
 URL:           -
+BuildRequires: python3-devel >= 1:3.2
 #BuildRequires:        python3-setuptools
 %if %{with tests}
 #BuildRequires:        python3-
 %endif
+# if using noarch subpackage:
+#BuildRequires:        rpm-build >= 4.6
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
-BuildRequires: python3-devel >= 1:3.2
 # when using /usr/bin/env or other in-place substitutions
 #BuildRequires:        sed >= 4.0
 %if %{with doc}
@@ -42,18 +44,16 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description -l pl.UTF-8
 
 %package apidocs
-Summary:       %{module} API documentation
-Summary(pl.UTF-8):     Dokumentacja API %{module}
+Summary:       API documentation for Python %{module} module
+Summary(pl.UTF-8):     Dokumentacja API modułu Pythona %{module}
 Group:         Documentation
-%if "%{_rpmversion}" >= "4.6"
 BuildArch:     noarch
-%endif
 
 %description apidocs
-API documentation for %{module}.
+API documentation for Python %{module} module.
 
 %description apidocs -l pl.UTF-8
-Dokumentacja API %{module}.
+Dokumentacja API modułu Pythona %{module}.
 
 %prep
 %setup -q -n %{module}-%{version}
This page took 0.050547 seconds and 4 git commands to generate.