]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - php-pecl.spec
- further unified python templates
[projects/template-specs.git] / php-pecl.spec
index 04bf0d0de0970d905271bf7a6df48e31602a837d..986dc01f7c77cfe4b2893d4d97db8c5fd31361c2 100644 (file)
@@ -11,14 +11,18 @@ Version:    1.0
 Release:       1
 License:       PHP 3.01
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
+Source0:       https://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: -
-URL:           http://pecl.php.net/package/MODULE_NAME/
-%{?with_tests:BuildRequires:    %{php_name}-cli}
+URL:           https://pecl.php.net/package/MODULE_NAME/
+BuildRequires: %{php_name}-cli
 BuildRequires: %{php_name}-devel
 BuildRequires: rpmbuild(macros) >= 1.666
+%if %{with tests}
+BuildRequires: %{php_name}-pcre
+%endif
 %{?requires_php_extension}
-Provides:      php(MODULE_NAME) = %{version}
+Requires:      %{php_name}-spl
+Provides:      php(%{modname}) = %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -29,36 +33,49 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %setup -qc
 mv %{modname}-%{version}/* .
 
+cat <<'EOF' > run-tests.sh
+#!/bin/sh
+export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
+exec %{__make} test \
+       PHP_EXECUTABLE=%{__php} \
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl pdo session" \
+       RUN_TESTS_SETTINGS="-q $*"
+EOF
+chmod +x run-tests.sh
+
+xfail() {
+       local t=$1
+       test -f $t
+       cat >> $t <<-EOF
+
+       --XFAIL--
+       Skip
+       EOF
+}
+
+while read line; do
+       t=${line##*\[}; t=${t%\]}
+       xfail $t
+done << 'EOF'
+Test for blowfish compatibility [tests/blowfish.phpt]
+Bug #8040 (MCRYPT_MODE_* do not seem to exist) [tests/bug8040.phpt]
+EOF
+
 %build
 phpize
 %configure
 %{__make}
 
-%if %{with tests}
 # simple module load test
 %{__php} -n -q \
        -d extension_dir=modules \
+       -d extension=%{php_extensiondir}/spl.so \
        -d extension=%{modname}.so \
        -m > modules.log
 grep %{modname} modules.log
 
-export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
-%{__make} test \
-       PHP_EXECUTABLE=%{__php}
-
-# or:
-cat <<'EOF' > run-tests.sh
-#!/bin/sh
-export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
-%{__make} test \
-       PHP_EXECUTABLE=%{__php} \
-       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl pdo session" \
-       RUN_TESTS_SETTINGS="-q $*"
-EOF
-
-chmod +x run-tests.sh
-./run-tests.sh -w failed.log
-test -f failed.log -a ! -s failed.log
+%if %{with tests}
+./run-tests.sh --show-diff
 %endif
 
 %install
This page took 0.196551 seconds and 4 git commands to generate.