]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - perl.spec
- adjusted noarch subpackage rules and some descriptions, more pl
[projects/template-specs.git] / perl.spec
index 044b6300f363e2e79b9e332b5a4a3652b1571749..32b9c04b96886a5bd79de301207c5ae81d6b0082 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -8,12 +8,10 @@
 ############################################################
 #
 # Conditional build:
-%bcond_without autodeps        # don't BR packages needed only for resolving deps
 %bcond_without tests   # do not perform "make test"
 #
 %define                pdir    PDIR
 %define                pnam    PNAM
-%include       /usr/lib/rpm/macros.perl
 Summary:       -
 Summary(pl.UTF-8):     -
 Name:          perl-PDIR-PNAM
@@ -27,11 +25,12 @@ Source0:    http://www.cpan.org/modules/by-module/PDIR/%{pdir}-%{pnam}-%{version}.t
 # Source0-md5: 
 Patch0:                %{name}-foo.patch
 # most of CPAN modules have generic URL (substitute pdir and pnam here)
-URL:           http://search.cpan.org/dist/PDIR-PNAM/
+URL:           https://metacpan.org/release/PDIR-PNAM
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRequires: -
-%if %{with autodeps} || %{with tests}
+%if %{with tests}
 BuildRequires: perl-
 BuildRequires: perl-
 %endif
@@ -41,7 +40,7 @@ Obsoletes:    -
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq      'perl(anything_fake_or_conditional)'
+%define                _noautoreq_perl anything_fake_or_conditional
 
 %description
 
@@ -59,6 +58,12 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
 
+# Build.PL based packages
+%{__perl} Build.PL \
+       perl=%{__perl} \
+       installdirs=vendor
+./Build
+
 %{__make}
 # if module isn't noarch, use:
 # %{__make} \
@@ -79,6 +84,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
 
+./Build install \
+       destdir=$RPM_BUILD_ROOT
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.09087 seconds and 4 git commands to generate.