]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - apache1-module.spec
- spaces to tabs
[projects/template-specs.git] / apache1-module.spec
index 1f13890ee0f7b320b0d5705e5fbcfd99df8d1958..07dfd36d6b23b4316840e8602f2cb9830ff02d36 100644 (file)
@@ -7,9 +7,9 @@
 # for new packages.
 #
 %define                mod_name        MODNAME
-%define        apxs            %{_sbindir}/apxs1
-Summary:       Apache module: ...
-Summary(pl):   Modu³ Apache'a: ...
+%define                apxs            %{_sbindir}/apxs1
+Summary:       Apache HTTPD module: ..
+Summary(pl.UTF-8):     Moduł Apache'a: ...
 Name:          apache1-mod_%{mod_name}
 Version:       -
 Release:       0.1
@@ -19,23 +19,23 @@ Source0:    -
 # Source0-md5: -
 Source1:       %{name}.conf
 URL:           -
+%{?with_ipv6:BuildRequires:    apache1(ipv6)-devel}
 BuildRequires: apache1-devel >= 1.3.33-2
 BuildRequires: rpmbuild(macros) >= 1.228
-%{?with_ipv6:BuildRequires:    apache1(ipv6)-devel}
 %{!?with_ipv6:BuildConflicts:  apache1(ipv6)-devel}
 Requires(triggerpostun):       %{apxs}
 Requires(triggerpostun):       grep
 Requires(triggerpostun):       sed >= 4.0
-Requires:      apache1 >= 1.3.33-2
+Requires:      apache1(EAPI)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 %define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
-MODNAME is Apache module...
+MODNAME is Apache HTTPD module...
 
-%description -l pl
+%description -l pl.UTF-8
 
 %prep
 %setup -q -n mod_%{mod_name}-%{version}
@@ -72,7 +72,7 @@ fi
 %if 0 # triggers for upgrading from pre confdir module
 # if there was "Include modulename.conf"
 %triggerpostun -- %{name} < VERSION
-if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
+if grep -q '^Include conf\.d/\*\.conf' /etc/apache/apache.conf; then
        %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
        sed -i -e '
                /^Include.*mod_%{mod_name}\.conf/d
@@ -83,12 +83,12 @@ else
                s,^Include.*mod_%{mod_name}\.conf,Include %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf,
 ' /etc/apache/apache.conf
 fi
-%service apache restart
+%service -q apache restart
 
 # or, if there was just apxs usage
 %triggerpostun -- apache1-mod_%{mod_name} < VERSION
 # check that they're not using old apache.conf
-if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
+if grep -q '^Include conf\.d/\*\.conf' /etc/apache/apache.conf; then
        %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
 fi
 
This page took 0.043791 seconds and 4 git commands to generate.