]> git.pld-linux.org Git - projects/template-specs.git/blame - python3-ext.spec
- spaces to tabs
[projects/template-specs.git] / python3-ext.spec
CommitLineData
367df2cb
JB
1#
2# This is template for python 3 extension modules (including compiled C code)
3# use template-specs/python3.spec for pure python packages
4#
5# Conditional build:
09ee490b
JB
6%bcond_without doc # API documentation
7%bcond_without tests # unit tests
367df2cb 8
688a1eb4 9%define module template
367df2cb
JB
10Summary: -
11Summary(pl.UTF-8): -
12# Name must match the python module/package name (as on pypi or in 'import' statement)
13Name: python3-%{module}
14Version: _
15Release: 0.1
16License: - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
17Group: Libraries/Python
18# if pypi:
19#Source0Download: https://pypi.org/simple/MODULE/
20Source0: https://files.pythonhosted.org/packages/source/M/MODULE/%{module}-%{version}.tar.gz
21# Source0-md5: -
22#URL: https://pypi.org/project/MODULE/
23URL: -
1a50796a 24BuildRequires: python3-devel >= 1:3.2
367df2cb
JB
25#BuildRequires: python3-setuptools
26%if %{with tests}
27#BuildRequires: python3-
28%endif
28eb9a67
JB
29# if using noarch subpackage:
30#BuildRequires: rpm-build >= 4.6
367df2cb
JB
31BuildRequires: rpm-pythonprov
32BuildRequires: rpmbuild(macros) >= 1.714
367df2cb
JB
33# when using /usr/bin/env or other in-place substitutions
34#BuildRequires: sed >= 4.0
35%if %{with doc}
36BuildRequires: sphinx-pdg-3
37%endif
38# replace with other requires if defined in setup.py
b95097ca 39Requires: python3-modules >= 1:3.2
367df2cb
JB
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43
44%description -l pl.UTF-8
45
367df2cb 46%package apidocs
1a50796a
JB
47Summary: API documentation for Python %{module} module
48Summary(pl.UTF-8): Dokumentacja API modułu Pythona %{module}
367df2cb 49Group: Documentation
28eb9a67 50BuildArch: noarch
367df2cb
JB
51
52%description apidocs
1a50796a 53API documentation for Python %{module} module.
367df2cb
JB
54
55%description apidocs -l pl.UTF-8
1a50796a 56Dokumentacja API modułu Pythona %{module}.
367df2cb
JB
57
58%prep
59%setup -q -n %{module}-%{version}
60
61# fix #!/usr/bin/env python -> #!/usr/bin/python:
62#%{__sed} -i -e '1s,^#!.*python3,#!%{__python3},' %{name}.py
63
64%build
65%py3_build
66# deprecated target, but sometimes still used: %{?with_tests:test}
67
68%if %{with tests}
69%{__python3} -m pytest ...
70%endif
71
72%if %{with doc}
73%{__make} -C docs html \
74 SPHINXBUILD=sphinx-build-3
75rm -rf docs/_build/html/_sources
76%endif
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81%py3_install
82
83%if %{with enable_if_there_are_examples_provided_in_package}
84install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
85cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
86find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
87 | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
88%endif
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(644,root,root,755)
95%doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
96%dir %{py3_sitedir}/%{module}
97%{py3_sitedir}/%{module}/*.py
98%attr(755,root,root) %{py3_sitedir}/%{module}/*.so
99%{py3_sitedir}/%{module}/__pycache__
100%{py3_sitedir}/%{module}-%{version}-py*.egg-info
101%{_examplesdir}/%{name}-%{version}
102
103%if %{with doc}
104%files apidocs
105%defattr(644,root,root,755)
106%doc docs/_build/html/*
107%endif
This page took 0.854656 seconds and 4 git commands to generate.