]> git.pld-linux.org Git - projects/template-specs.git/blame - php-pecl.spec
nagios-plug: nrpe example
[projects/template-specs.git] / php-pecl.spec
CommitLineData
fc1df23f
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
9ec83f18 5%define php_name php%{?php_suffix}
abe712a7 6%define modname MODULE_NAME
fc1df23f
ER
7Summary: %{modname} -
8Summary(pl.UTF-8): %{modname} -
9ec83f18 9Name: %{php_name}-pecl-%{modname}
a7223ec4
AG
10Version: 1.0
11Release: 1
4099af7d 12License: PHP 3.01
a7223ec4 13Group: Development/Languages/PHP
fc1df23f 14Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
dc5e1efb 15# Source0-md5: -
abe712a7 16URL: http://pecl.php.net/package/MODULE_NAME/
512c7faf 17%{?with_tests:BuildRequires: %{php_name}-cli}
9ec83f18 18BuildRequires: %{php_name}-devel
3ad11c3e 19BuildRequires: rpmbuild(macros) >= 1.666
930a1dff
ER
20%if %{with tests}
21BuildRequires: %{php_name}-cli
22BuildRequires: %{php_name}-pcre
23%endif
672c5afc 24%{?requires_php_extension}
7abd4293 25Provides: php(%{modname}) = %{version}
a7223ec4
AG
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
a7223ec4
AG
28%description
29
9be49f18 30%description -l pl.UTF-8
a7223ec4 31
a7223ec4 32%prep
05e722ff 33%setup -qc
fc1df23f 34mv %{modname}-%{version}/* .
a7223ec4
AG
35
36%build
a7223ec4
AG
37phpize
38%configure
39%{__make}
40
512c7faf
ER
41%if %{with tests}
42# simple module load test
43%{__php} -n -q \
44 -d extension_dir=modules \
82804f07 45 -d extension=%{php_extensiondir}/spl.so \
512c7faf
ER
46 -d extension=%{modname}.so \
47 -m > modules.log
48grep %{modname} modules.log
49
50export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
51%{__make} test \
bb69cd23
ER
52 PHP_EXECUTABLE=%{__php} \
53 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl" \
023d6644
ER
54
55# or:
56cat <<'EOF' > run-tests.sh
57#!/bin/sh
58export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
59%{__make} test \
60 PHP_EXECUTABLE=%{__php} \
61 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl pdo session" \
62 RUN_TESTS_SETTINGS="-q $*"
63EOF
64
65chmod +x run-tests.sh
66./run-tests.sh -w failed.log
67test -f failed.log -a ! -s failed.log
512c7faf
ER
68%endif
69
a7223ec4
AG
70%install
71rm -rf $RPM_BUILD_ROOT
f6dd55ea 72install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
9c71ffdc
ER
73install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
74install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
a7223ec4 75
852624ea 76%{__make} install \
0ec203b9
ER
77 EXTENSION_DIR=%{php_extensiondir} \
78 INSTALL_ROOT=$RPM_BUILD_ROOT
01c11931
ER
79
80install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
fc1df23f
ER
81cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
82; Enable %{modname} extension module
83extension=%{modname}.so
ceb2ba66 84EOF
a7223ec4 85
68c7fa4c 86install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
9c71ffdc
ER
87cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
88
a7223ec4
AG
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post
6e284c47 93%php_webserver_restart
a7223ec4 94
ceb2ba66
AG
95%postun
96if [ "$1" = 0 ]; then
6e284c47 97 %php_webserver_restart
a7223ec4
AG
98fi
99
100%files
101%defattr(644,root,root,755)
f8cfa67b 102%doc CREDITS EXPERIMENTAL
fc1df23f
ER
103%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
104%attr(755,root,root) %{php_extensiondir}/%{modname}.so
9c71ffdc 105%{_examplesdir}/%{name}-%{version}
This page took 0.378259 seconds and 4 git commands to generate.