]> git.pld-linux.org Git - projects/template-specs.git/blame - lib.spec
- adjusted noarch subpackage rules and some descriptions, more pl
[projects/template-specs.git] / lib.spec
CommitLineData
3cb1cd3d 1#
66df3cad
ER
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
aed9d573 4%bcond_without static_libs # don't build static libraries
66df3cad 5#
f9986cd5 6Summary: -
ce39d734 7Summary(pl.UTF-8): -
3f8f5e5b
ER
8Name: ---
9Version: 0.1
10Release: 0.1
f9986cd5
JB
11License: - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12Group: Libraries
13Source0: %{name}-%{version}.tar.gz
14# Source0-md5: -
3f8f5e5b
ER
15#Patch0: %{name}-what.patch
16#URL: -
17#BuildRequires: -
c53387e8
ER
18#BuildRequires: autoconf
19#BuildRequires: automake
20#BuildRequires: intltool
21#BuildRequires: libtool
09ee490b
JB
22# if using noarchpackage:
23#BuildRequires: rpmbuild(macros) >= 1.752
3f8f5e5b
ER
24#Requires(postun): -
25#Requires(pre,post): -
26#Requires(preun): -
27#Requires: -
28#Provides: -
29#Obsoletes: -
30#Conflicts: -
f9986cd5
JB
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
a1a32384
ER
33# do not keep them in newly created specs
34# these are only here to help fixing quickly broken specs
35%define filterout_ld -Wl,--no-copy-dt-needed-entries
36%define filterout_ld -Wl,--as-needed
31c122e0
ER
37# do not commit spec containing this (use for local testing only):
38%define filterout_c -Werror=format-security
c392e5f5 39%define filterout_cpp -D_FORTIFY_SOURCE=.
877721ed 40%define filterout_cxx -Werror=format-security
a1a32384 41
20667fb2 42# Ignore file in __spec_install_post_check_so
5346ce74 43BuildRequires: rpmbuild(macros) >= 1.583
e24df1c5 44%define skip_post_check_so libunresolved.so.*
20667fb2 45
e025831d
ER
46# do not commit spec containing this (use for local testing only):
47%define no_install_post_check_tmpfiles 1
48
f9986cd5
JB
49%description
50
3f8f5e5b 51#%description -l pl.UTF-8
f9986cd5 52
41119926 53%package common
ca8abdb7
TP
54Summary: Common files for %{name} library
55Summary(pl.UTF-8): Wspólne pliki biblioteki %{name}
41119926
TP
56Group: Libraries
57Requires: %{name} = %{version}-%{release}
58
59%description common
ca8abdb7 60Common files for %{name} library.
41119926
TP
61
62%description common -l pl.UTF-8
ca8abdb7 63Wspólne pliki biblioteki %{name}.
41119926 64
f9986cd5 65%package devel
ca8abdb7
TP
66Summary: Header files for %{name} library
67Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
f9986cd5 68Group: Development/Libraries
d7dd7729 69Requires: %{name} = %{version}-%{release}
f9986cd5
JB
70
71%description devel
ca8abdb7 72Header files for %{name} library.
f9986cd5 73
9be49f18 74%description devel -l pl.UTF-8
ca8abdb7 75Pliki nagłówkowe biblioteki %{name}.
f9986cd5
JB
76
77%package static
ca8abdb7
TP
78Summary: Static %{name} library
79Summary(pl.UTF-8): Statyczna biblioteka %{name}
f9986cd5 80Group: Development/Libraries
d7dd7729 81Requires: %{name}-devel = %{version}-%{release}
f9986cd5
JB
82
83%description static
ca8abdb7 84Static %{name} library.
f9986cd5 85
9be49f18 86%description static -l pl.UTF-8
ca8abdb7 87Statyczna biblioteka %{name}.
f9986cd5 88
66df3cad 89%package apidocs
2bd7838d 90Summary: API documentation for %{name} library
ca8abdb7 91Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
66df3cad 92Group: Documentation
2bd7838d 93# if not arch-dependent
09ee490b 94%{?noarchpackage}
66df3cad
ER
95
96%description apidocs
e077345b 97API documentation for %{name} library.
66df3cad 98
3cb1cd3d 99%description apidocs -l pl.UTF-8
ca8abdb7 100Dokumentacja API biblioteki %{name}.
3cb1cd3d 101
f9986cd5
JB
102%prep
103%setup -q
1c854c4b 104#%patch0 -p1
f9986cd5
JB
105
106%build
c42a30cf
JB
107# if ac/am/lt/* rebuilding is necessary, do it in this order and add
108# appropriate BuildRequires
109#%{__libtoolize}
110#%{__aclocal}
111#%{__autoconf}
112#%{__autoheader}
113#%{__automake}
f6de6810
ER
114%configure \
115 %{!?with_static_libs:--disable-static}
f9986cd5
JB
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120# create directories if necessary
121#install -d $RPM_BUILD_ROOT
122
123%{__make} install \
124 DESTDIR=$RPM_BUILD_ROOT
125
14750145
JB
126# if library provides pkgconfig file containing proper {Requires,Libs}.private
127# then remove .la pollution
4b532792
JR
128#%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
129
f9986cd5
JB
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post -p /sbin/ldconfig
134%postun -p /sbin/ldconfig
135
136%files
137%defattr(644,root,root,755)
41119926
TP
138%doc AUTHORS CREDITS README THANKS
139%attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
140%attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
141
142%files common
143%defattr(644,root,root,755)
144%attr(755,root,root) %{_bindir}/%{name}*
f9986cd5
JB
145%{_datadir}/%{name}
146
147%files devel
148%defattr(644,root,root,755)
41119926
TP
149%doc devel-doc/* ChangeLog NEWS TODO
150%attr(755,root,root) %{_libdir}/%{name}.so
14750145
JB
151# if no pkgconfig support, or it misses .private deps, then include .la file
152#%{_libdir}/libFOO.la
41119926
TP
153%{_includedir}/%{name}
154%{_aclocaldir}/%{name}.m4
155%{_pkgconfigdir}/%{name}.pc
f9986cd5 156
f6de6810 157%if %{with static_libs}
f9986cd5
JB
158%files static
159%defattr(644,root,root,755)
41119926 160%{_libdir}/%{name}.a
f6de6810 161%endif
66df3cad 162
a5f7d790 163%if %{with apidocs}
66df3cad
ER
164%files apidocs
165%defattr(644,root,root,755)
166%doc apidocs/*
a5f7d790 167%endif
This page took 1.555528 seconds and 4 git commands to generate.