]> git.pld-linux.org Git - packages/zeromq.git/blobdiff - zeromq.spec
- updated to 4.3.5 (relicensed to MPL v2.0 now)
[packages/zeromq.git] / zeromq.spec
index e38da34be0bf7406a3029dc3c7b6216a130dd181..d66bca39f89085c9a1380fb183efc47690cae5dd 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Conditional build:
+%bcond_without gnutls          # TLS transport (GnuTLS based)
 %bcond_with    kerberos5       # GSSAPI client support [expects MIT Kerberos]
 %bcond_with    norm            # NORM extension
 %bcond_without pgm             # PGM extension (using OpenPGM library)
@@ -9,25 +10,28 @@ Summary:     0MQ - Zero Message Queue
 Summary(en.UTF-8):     ØMQ - Zero Message Queue
 Summary(pl.UTF-8):     ØMQ (Zero Message Queue) - kolejka komunikatów
 Name:          zeromq
-Version:       4.2.0
+Version:       4.3.5
 Release:       1
-License:       LGPL v3+ with linking exception
+License:       MPL v2.0
 Group:         Libraries
+#Source0Download: https://github.com/zeromq/libzmq/releases/
 Source0:       https://github.com/zeromq/libzmq/releases/download/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 1fb2595d2a905a9e820c976a1d8348bc
-Source1:       https://raw.githubusercontent.com/zeromq/cppzmq/master/zmq.hpp
-# Source1-md5: 03ea6bb87901660ad09df8f6c7a62e59
-Patch0:                zeromq-4.2.0-dl-backport.patch
+# Source0-md5: ae933b1e98411fd7cb8309f9502d2737
 URL:           http://www.zeromq.org/
 BuildRequires: asciidoc
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake
+%{?with_gnutls:BuildRequires:  gnutls-devel >= 3.1.4}
 %{?with_krb5:BuildRequires:    krb5-devel}
+BuildRequires: libbsd-devel
+# 5.1, 5.2, 5.3 are supported
+%{?with_pgm:BuildRequires:     libpgm-devel >= 5.1}
+%{?with_pgm:BuildRequires:     libpgm-devel < 5.4}
 BuildRequires: libsodium-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
+BuildRequires: libunwind-devel
 BuildRequires: libuuid-devel
-%{?with_pgm:BuildRequires:     libpgm-devel >= 5.1}
 %{?with_norm:BuildRequires:    norm-devel}
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
@@ -65,8 +69,13 @@ Summary(en.UTF-8):   ØMQ library header files for development
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki ØMQ
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+%{?with_gnutls:Requires:       gnutls >= 3.1.4}
+Requires:      libbsd-devel
+%{?with_pgm:Requires:  libpgm-devel >= 5.1}
+Requires:      libsodium-devel
 Requires:      libstdc++-devel
-Obsoletes:     zeromq-pthreads-devel
+Requires:      libunwind-devel
+Obsoletes:     zeromq-pthreads-devel < 2
 
 %description devel
 0MQ library header files for development.
@@ -83,7 +92,7 @@ Summary(en.UTF-8):    Static ØMQ library
 Summary(pl.UTF-8):     Statyczna biblioteka ØMQ
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
-Obsoletes:     zeromq-pthreads-static
+Obsoletes:     zeromq-pthreads-static < 2
 
 %description static
 Static 0MQ library.
@@ -111,9 +120,9 @@ wykorzystujących interfejs C++ do ØMQ.
 
 %prep
 %setup -q
-%patch0 -p1
 
-%{__sed} -ne '/SPECIAL EXCEPTION GRANTED/,$p' COPYING.LESSER > COPYING.exception
+# uses some multicast networking, timeouts on some hosts
+%{__sed} -i -e '/^\s*tests\/test_radio_dish /d' Makefile.am
 
 %build
 %{__libtoolize}
@@ -122,10 +131,14 @@ wykorzystujących interfejs C++ do ØMQ.
 %{__automake}
 %{__autoheader}
 %configure \
+       --enable-drafts \
        --disable-silent-rules \
        %{?with_kerberos5:--with-libgssapi_krb5} \
+       --with-libsodium \
        %{?with_norm:--with-norm} \
-       %{?with_pgm:--with-pgm}
+       %{?with_pgm:--with-pgm} \
+       %{?with_gnutls:--with-tls} \
+       --disable-Werror
 %{__make}
 
 %if %{with tests}
@@ -138,8 +151,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}
-
 # obsoleted by pkg-config
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
 
@@ -151,7 +162,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING.exception ChangeLog NEWS
+%doc AUTHORS ChangeLog NEWS
+%attr(755,root,root) %{_bindir}/curve_keygen
 %attr(755,root,root) %{_libdir}/libzmq.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libzmq.so.5
 
@@ -167,7 +179,3 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libzmq.a
-
-%files -n cppzmq-devel
-%defattr(644,root,root,755)
-%{_includedir}/zmq.hpp
This page took 0.121024 seconds and 4 git commands to generate.