]> git.pld-linux.org Git - packages/yum-utils.git/blame_incremental - yum-utils.spec
add rpm5 patch
[packages/yum-utils.git] / yum-utils.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with puppet # puppet plugin
4
5Summary: A collection of utilities related to yum
6Summary(pl.UTF-8): Zestaw narzędzi związanych z yumem
7Name: yum-utils
8Version: 1.1.31
9Release: 9
10License: GPL
11Group: Applications/System
12Source0: http://yum.baseurl.org/download/yum-utils/%{name}-%{version}.tar.gz
13# Source0-md5: b2859b89321b98f2581243536e1b4993
14Source1: yum-plugin-pld-kernel.py
15Source2: yum-plugin-pld-kernel.conf
16Patch0: rpm5.patch
17URL: http://yum.baseurl.org/download/yum-utils/
18BuildRequires: gettext-devel
19BuildRequires: rpm-pythonprov
20BuildRequires: rpmbuild(macros) >= 1.228
21Requires: python >= 1:2.5
22Requires: yum >= 3.2.29
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define _libexecdir %{_prefix}/lib/%{name}
27
28%description
29Yum-utils is a collection of utilities, plugins and examples related
30to the yum package manager.
31
32%description -l pl.UTF-8
33yum-utils to zestaw narzędzi, wtyczek i przykładów związanych z
34zarządcą pakietów yum.
35
36%package -n yum-updateonboot
37Summary: Run yum update on system boot
38Summary(pl.UTF-8): Uruchamianie yum update przy starcie systemu
39Group: Base
40Requires(post): /sbin/chkconfig
41Requires(pre): /sbin/chkconfig
42Requires: python
43Requires: yum >= 2.4
44
45%description -n yum-updateonboot
46Runs yum update on system boot. This allows machines that have been
47turned off for an extended amount of time to become secure
48immediately, instead of waiting until the next early morning cron job.
49
50%description -n yum-updateonboot -l pl.UTF-8
51Uruchamianie yum update przy starcie systemu. Pozwala to maszynom
52wyłączonym na dłuższy czas stać się bezpiecznymi natychmiast, bez
53czekania na kolejne poranne zadanie crona.
54
55%package -n yum-plugin-changelog
56Summary: Yum plugin for viewing package changelogs before/after updating
57Summary(pl.UTF-8): Wtyczka yuma do oglądania list zmian pakietów przed/po uaktualnieniu
58Group: Base
59# changelog requires new update_md.UpdateMetadata() API in 3.2.23
60Requires: python-dateutil
61Requires: yum >= 3.2.23
62Obsoletes: yum-changelog
63
64%description -n yum-plugin-changelog
65This plugin adds a command line option to allow viewing package
66changelog deltas before or after updating packages.
67
68%description -n yum-plugin-changelog -l pl.UTF-8
69Ta wtyczka dodaje opcję linii poleceń pozwalającą oglądać przyrostowo
70listę zmian pakietu (changelog) przed lub po uaktualnieniu.
71
72%package -n yum-plugin-fastestmirror
73Summary: Yum plugin which chooses fastest repository from a mirrorlist
74Summary(pl.UTF-8): Wtyczka yuma wybierająca najszybsze repozytorium z listy serwerów lustrzanych
75Group: Base
76Requires: yum >= 3.0
77Obsoletes: yum-fastestmirror
78
79%description -n yum-plugin-fastestmirror
80This plugin sorts each repository's mirrorlist by connection speed
81prior to downloading packages.
82
83%description -n yum-plugin-fastestmirror -l pl.UTF-8
84Ta wtyczka sortuje listy serwerów lustrzanych każdego repozytorium po
85szybkości połączenia przed rozpoczęciem ściągania pakietów.
86
87%package -n yum-plugin-protectbase
88Summary: Yum plugin to protect packages from certain repositories
89Summary(pl.UTF-8): Wtyczka yuma zabezpieczająca pakiety z pewnych repozytoriów
90Group: Base
91Requires: yum >= 3.0
92Obsoletes: yum-protectbase
93
94%description -n yum-plugin-protectbase
95This plugin allows certain repositories to be protected. Packages in
96the protected repositories can't be overridden by packages in
97non-protected repositories even if the non-protected repo has a later
98version.
99
100%description -n yum-plugin-protectbase -l pl.UTF-8
101Ta wtyczka pozwala na zabezpieczenie pewnych repozytoriów. Pakiety z
102zabezpieczonych repozytoriów nie mogą być przykryte przez pakiety z
103repozytoriów niezabezpieczonych, nawet jeśli w niezabezpieczonym jest
104nowsza wersja.
105
106%package -n yum-plugin-versionlock
107Summary: Yum plugin to lock specified packages from being updated
108Summary(pl.UTF-8): Wtyczka yuma blokująca uaktualnianie określonych pakietów
109Group: Base
110Requires: yum >= 3.2.24
111Obsoletes: yum-versionlock
112
113%description -n yum-plugin-versionlock
114This plugin allows certain packages specified in a file to be
115protected from being updated by newer versions.
116
117%description -n yum-plugin-versionlock -l pl.UTF-8
118Ta wtyczka pozwala chronić pewne pakiety określone w pliku przed
119uaktualnieniem do nowszych wersji.
120
121%package -n yum-plugin-tsflags
122Summary: Yum plugin to add tsflags by a commandline option
123Summary(pl.UTF-8): Wtyczka yuma dodająca flagi transakcji opcją linii poleceń
124Group: Base
125Requires: yum >= 3.0
126Obsoletes: yum-tsflags
127
128%description -n yum-plugin-tsflags
129This plugin allows you to specify optional transaction flags on the
130yum command line.
131
132%description -n yum-plugin-tsflags -l pl.UTF-8
133Ta wtyczka pozwala określić dodatkowe flagi transakcji z linii
134poleceń.
135
136# TODO: figure if to remove in pld
137%package -n yum-kernel-module
138Summary: Yum plugin to handle kernel-module-foo type of kernel module
139Summary(pl.UTF-8): Wtyczka yuma obsługująca moduły jądra typu kernel-module-foo
140Group: Base
141Requires: yum >= 3.0
142
143%description -n yum-kernel-module
144This plugin handle installation of kernel-module-foo type of kernel
145modules when new version of kernels are installed.
146
147%description -n yum-kernel-module -l pl.UTF-8
148Ta wtyczka obsługuje instalację modułów jądra typu kernel-module-foo
149kiedy zainstalowane są nowe wersje jądra.
150
151%package -n yum-plugin-downloadonly
152Summary: Yum plugin to add downloadonly command option
153Summary(pl.UTF-8): Wtyczka yuma dodająca opcję linii poleceń downloadonly
154Group: Base
155Requires: yum >= 3.0
156Obsoletes: yum-downloadonly
157
158%description -n yum-plugin-downloadonly
159This plugin adds a --downloadonly flag to yum so that yum will only
160download the packages and not install/update them.
161
162%description -n yum-plugin-downloadonly -l pl.UTF-8
163Ta wtyczka dodaje flagę --downloadonly do yuma, powodującą, że yum
164tylko ściąga pakiety bez ich instalacji/uaktualniania.
165
166%package -n yum-allowdowngrade
167Summary: Yum plugin to enable manual downgrading of packages
168Summary(pl.UTF-8): Wtyczka yuma umożliwiająca ręczne instalowanie starszych pakietów
169Group: Base
170Requires: yum >= 3.0
171
172%description -n yum-allowdowngrade
173This plugin adds a --allow-downgrade flag to yum to make it possible
174to manually downgrade packages to specific versions.
175
176%description -n yum-allowdowngrade -l pl.UTF-8
177Ta wtyczka dodaje do yuma flagę --allow-downgrade, umożliwiającą
178ręczne zastępowanie pakietów określonymi starszymi wersjami
179(downgrade).
180
181%package -n yum-plugin-pld-kernel
182Summary: Yum plugin to handle PLD kernel installs
183Summary(pl.UTF-8): Wtyczka yuma obsługująca instalację jąder PLD
184Group: Base
185Requires: yum >= 3.0
186Obsoletes: yum-pld-kernel
187
188%description -n yum-plugin-pld-kernel
189This plugin handle installation of PLD kernels.
190
191%description -n yum-plugin-pld-kernel -l pl.UTF-8
192Ta wtyczka obsługuje instalację jąder PLD.
193
194%package -n yum-plugin-priorities
195Summary: Plugin to give priorities to packages from different repos
196Summary(pl.UTF-8): Wtyczka nadająca priorytety pakietom z różnych repozytoriów
197Group: Base
198Requires: yum >= 3.0
199Obsoletes: yum-priorities
200
201%description -n yum-plugin-priorities
202This plugin allows repositories to have different priorities. Packages
203in a repository with a lower priority can't be overridden by packages
204from a repository with a higher priority even if repo has a later
205version.
206
207%description -n yum-plugin-priorities -l pl.UTF-8
208Ta wtyczka umożliwia przypisanie repozytoriom różnych priorytetów.
209Pakiety z repozytorium o niższym priorytecie nie mogą być przykryte
210przez pakiety z repozytorium o wyższym priorytecie nawet jeśli te
211drugie mają nowszą wersję.
212
213%package -n yum-plugin-refresh-updatesd
214Summary: Tell yum-updatesd to check for updates when yum exits
215Summary(pl.UTF-8): Sprawdzanie uaktualnień przez yum-updatesd przy zakończeniu yuma
216Group: Base
217Requires: yum >= 3.0
218Requires: yum-updatesd
219Obsoletes: yum-refresh-updatesd
220
221%description -n yum-plugin-refresh-updatesd
222yum-plugin-refresh-updatesd tells yum-updatesd to check for updates
223when yum exits. This way, if you run 'yum update' and install all
224available updates, puplet will almost instantly update itself to
225reflect this.
226
227%description -n yum-plugin-refresh-updatesd -l pl.UTF-8
228yum-plugin-refresh-updatesd przekazuje yum-updatesd, aby sprawdzał
229uaktualnienia kiedy yum kończy pracę. W ten sposób po uruchomieniu
230"yum update" i zainstalowaniu wszystkich dostępnych uaktualnień puplet
231prawie natychmiast uaktualni swoje informacje.
232
233%package -n yum-plugin-merge-conf
234Summary: Yum plugin to merge configuration changes when installing packages
235Summary(pl.UTF-8): Wtyczka yuma do włączania zmian konfiguracji przy instalacji pakietów
236Group: Base
237Requires: yum >= 3.0
238Obsoletes: yum-merge-conf
239
240%description -n yum-plugin-merge-conf
241This yum plugin adds the "--merge-conf" command line option. With this
242option, Yum will ask you what to do with config files which have
243changed on updating a package.
244
245%description -n yum-plugin-merge-conf -l pl.UTF-8
246Ta wtyczka yuma dodaje opcję linii poleceń --merge-conf. Przy jej
247użyciu yum pyta co zrobić z plikami konfiguracyjnymi, które zmieniły
248się przy uaktualnianiu pakietu.
249
250%package -n yum-plugin-security
251Summary: Yum plugin to enable security filters
252Summary(pl.UTF-8): Wtyczka yuma włączająca filtry bezpieczeństwa
253Group: Base
254Requires: yum >= 3.2.18
255Obsoletes: yum-security
256
257%description -n yum-plugin-security
258This plugin adds the options --security, --cve, --bz and --advisory
259flags to yum and the list-security and info-security commands. The
260options make it possible to limit list/upgrade of packages to specific
261security relevant ones. The commands give you the security
262information.
263
264%description -n yum-plugin-security -l pl.UTF-8
265Ta wtyczka dodaje do yuma flagi --security, --cve, --bz i --advisory
266oraz polecenia list-security i info-security. Opcje te umożliwiają
267ograniczenie listy/uaktualnień pakietów do związanych z
268bezpieczeństwem w określony sposób. Polecenia podają informacje
269związane z bezpieczeństwem.
270
271%package -n yum-protect-packages
272Summary: Yum plugin to prevents Yum from removing itself and other protected packages
273Summary(pl.UTF-8): Wtyczka yuma zapobiegająca usunięciu siebie lub innych chronionych pakietów
274Group: Base
275Requires: yum >= 3.0
276
277%description -n yum-protect-packages
278This plugin prevents Yum from removing itself and other protected
279packages. By default, yum is the only package protected, but by
280extension this automatically protects everything on which yum depends
281(rpm, python, glibc, and so on).Therefore, the plugin functions well
282even without compiling careful lists of all important packages.
283
284%description -n yum-protect-packages -l pl.UTF-8
285Ta wtyczka zapobiega usunięciu przez yuma siebie samego lub innych
286chronionych pakietów. Domyślnie jedynym chronionym pakietem jest yum,
287ale poprzez rozszerzenie automatycznie zabezpiecza to wszystkie
288pakiety będące zależnościami yuma (rpm, python, glibc itd.). W ten
289sposób wtyczka funkcjonuje dobrze nawet bez troskliwego tworzenia list
290wszystkich ważnych pakietów.
291
292%package -n yum-basearchonly
293Summary: Yum plugin to let Yum install only basearch packages
294Summary(pl.UTF-8): Wtyczka yuma pozwalająca instalować tylko pakiety basearch
295Group: Base
296Requires: yum >= 3.0
297
298%description -n yum-basearchonly
299This plugin makes Yum only install basearch packages on multiarch
300systems. If you type 'yum install foo' on a x68_64 system, only
301'foo-x.y.x86_64.rpm' is installed. If you want to install the
302foo-x.y.i386.rpm, you have to type 'yum install foo.i386'. The plugin
303only works with 'yum install'.
304
305%description -n yum-basearchonly -l pl.UTF-8
306Ta wtyczka powoduje, że yum instaluje tylko pakiety basearch na
307systemach multiarch. Po wpisaniu "yum install foo" na systemie x86_64
308zostanie zainstalowany tylko "foo-x.y.x86_64.rpm. Aby zainstalować
309foo-x.y.i386.rpm, trzeba wpisać "yum install foo.i386". Wtyczka działa
310tylko z "yum install".
311
312%package -n yum-plugin-upgrade-helper
313Summary: Yum plugin to help upgrades to the next distribution version
314Summary(pl.UTF-8): Wtyczka yuma pomagająca przy uaktualnianiu do kolejnej wersji dystrybucji
315Group: Base
316Requires: yum >= 3.0
317Obsoletes: yum-upgrade-helper
318
319%description -n yum-plugin-upgrade-helper
320This plugin allows yum to erase specific packages on install/update
321based on an additional metadata file in repositories. It is used to
322simplify distribution upgrade hangups.
323
324%description -n yum-plugin-upgrade-helper -l pl.UTF-8
325Ta wtyczka pozwala yumowi usunąć określone pakiety przy instalacji lub
326uaktualnianiu w oparciu o dodatkowe pliki metadanych w repozytoriach.
327Służy do uproszczenia uaktualnień wersji dystrybucji.
328
329%package -n yum-plugin-aliases
330Summary: Yum plugin to enable aliases filters
331Summary(pl.UTF-8): Wtyczka yuma włączająca filtry aliasów
332Group: Base
333# Requires args_hook
334Requires: yum >= 3.2.23
335Obsoletes: yum-aliases
336
337%description -n yum-plugin-aliases
338This plugin adds the command alias, and parses the aliases config.
339file to enable aliases.
340
341%description -n yum-plugin-aliases -l pl.UTF-8
342Ta wtyczka dodaje polecenie alias i analizuje konfigurację aliasów w
343celu włączenia aliasów.
344
345%package -n yum-plugin-list-data
346Summary: Yum plugin to list aggregate package data
347Summary(pl.UTF-8): Wtyczka yuma wypisująca zagregowane dane pakietów
348Group: Base
349Requires: yum >= 3.0.5
350Obsoletes: yum-list-data
351
352%description -n yum-plugin-list-data
353This plugin adds the commands list- vendors, groups, packagers,
354licenses, arches, committers, buildhosts, baseurls, package-sizes,
355archive-sizes and installed-sizes.
356
357%description -n yum-plugin-list-data -l pl.UTF-8
358Ta wtyczka dodaje polecenia list- vendors, groups, packagers,
359licenses, arches, committers, buildhosts, baseurls, package-sizes,
360archive-sizes i installed-sizes.
361
362%package -n yum-plugin-filter-data
363Summary: Yum plugin to list filter based on package data
364Summary(pl.UTF-8): Wtyczka yuma dodająca filtry oparte na danych pakietu
365Group: Base
366Requires: yum >= 3.2.17
367Obsoletes: yum-filter-data
368
369%description -n yum-plugin-filter-data
370This plugin adds the options --filter- vendors, groups, packagers,
371licenses, arches, committers, buildhosts, baseurls, package-sizes,
372archive-sizes and installed-sizes. Note that each package must match
373at least one pattern/range in each category, if any were specified.
374
375%description -n yum-plugin-filter-data -l pl.UTF-8
376Ta wtyczka dodaje opcje --filter- vendors, groups, packagers,
377licenses, arches, committers, buildhosts, baseurls, package-sizes,
378archive-sizes i installed-sizes. Każdy pakiet musi pasować do
379przynajmniej jednego wzorca/zakresu w każdej wybranej kategorii.
380
381%package -n yum-plugin-tmprepo
382Summary: Yum plugin to add temporary repositories
383Summary(pl.UTF-8): Wtyczka yuma dodająca repozytoria tymczasowe
384Group: Base
385Requires: createrepo
386Requires: yum >= 3.2.11
387Obsoletes: yum-tmprepo
388
389%description -n yum-plugin-tmprepo
390This plugin adds the option --tmprepo which takes a URL to a .repo
391file downloads it and enables it for a single run. This plugin tries
392to ensure that temporary repositories are safe to use, by default, by
393not allowing gpg checking to be disabled.
394
395%description -n yum-plugin-tmprepo -l pl.UTF-8
396Ta wtyczka dodaje opcję --tmprepo przyjmującą URL do pliku .repo i
397włączająca go dla jednego uruchomienia. Wtyczka próbuje zapewnić
398bezpieczne użycie repozytoriów tymczasowych domyślnie nie pozwalając
399na wyłączenie sprawdzania gpg.
400
401%package -n yum-plugin-verify
402Summary: Yum plugin to add verify command, and options
403Summary(pl.UTF-8): Wtyczka yuma dodająca polecenie i opcje weryfikacji
404Group: Base
405Requires: yum >= 3.2.12
406Obsoletes: yum-verify
407
408%description -n yum-plugin-verify
409This plugin adds the commands verify, verify-all and verify-rpm. There
410are also a couple of options. This command works like rpm -V, to
411verify your installation.
412
413%description -n yum-plugin-verify -l pl.UTF-8
414Ta wtyczka dodaje polecenia verify, verify-all i verify-rpm, a także
415kilka opcji. Działa podobnie jak rpm -V, weryfikując instalację.
416
417%package -n yum-plugin-keys
418Summary: Yum plugin to deal with signing keys
419Group: Base
420Requires: yum >= 3.2.19
421
422%description -n yum-plugin-keys
423This plugin adds the commands keys, keys-info, keys-data and
424keys-remove. They allow you to query and remove signing keys.
425
426%package -n yum-plugin-remove-with-leaves
427Summary: Yum plugin to remove dependencies which are no longer used because of a removal
428Group: Base
429Requires: yum >= 3.2.19
430
431%description -n yum-plugin-remove-with-leaves
432This plugin removes any unused dependencies that were brought in by an
433install but would not normally be removed. It helps to keep a system
434clean of unused libraries and packages.
435
436%package -n yum-plugin-post-transaction-actions
437Summary: Yum plugin to run arbitrary commands when certain pkgs are acted on
438Group: Base
439Requires: yum >= 3.2.19
440
441%description -n yum-plugin-post-transaction-actions
442This plugin allows the user to run arbitrary actions immediately
443following a transaction when specified packages are changed.
444
445%package -n yum-NetworkManager-dispatcher
446Summary: NetworkManager script which tells yum to check it's cache on network change
447Group: Base
448Requires: yum >= 3.2.17
449
450%description -n yum-NetworkManager-dispatcher
451This NetworkManager "dispatch script" forces yum to check its cache
452if/when a new network connection happens in NetworkManager. Note that
453currently there is no checking of previous data, so if your WiFi keeps
454going up and down (or you suspend/resume a lot) yum will recheck its
455cached data a lot.
456
457%package -n yum-plugin-rpm-warm-cache
458Summary: Yum plugin to access the rpmdb files early to warm up access to the db
459Group: Base
460Requires: yum >= 3.2.19
461
462%description -n yum-plugin-rpm-warm-cache
463This plugin reads the rpmdb files into the system cache before
464accessing the rpmdb directly. In some cases this should speed up
465access to rpmdb information
466
467# Works by searching for *-debuginfo ... so it shouldn't trigger on
468itself.
469%package -n yum-plugin-auto-update-debug-info
470Summary: Yum plugin to enable automatic updates to installed debuginfo packages
471Group: Base
472Requires: yum >= 3.2.19
473
474%description -n yum-plugin-auto-update-debug-info
475This plugin looks to see if any debuginfo packages are installed, and
476if there are it enables all debuginfo repositories that are "children"
477of enabled repositories.
478
479%package -n yum-plugin-show-leaves
480Summary: Yum plugin which shows newly installed leaf packages
481Group: Base
482Requires: yum >= 3.2.23
483
484%description -n yum-plugin-show-leaves
485Yum plugin which shows newly installed leaf packages and packages that
486became leaves after a transaction
487
488%package -n yum-plugin-local
489Summary: Yum plugin to automatically manage a local repo. of downloaded packages
490Group: Base
491# Who the hell knows what version:)
492Requires: createrepo
493Requires: yum >= 3.2.22
494
495%description -n yum-plugin-local
496When this plugin is installed it will automatically copy all
497downloaded packages to a repository on the local filesystem, and
498(re)build that repository. This means that anything you've downloaded
499will always exist, even if the original repo. removes it (and can
500thus. be reinstalled/downgraded/etc.).
501
502%package -n yum-plugin-fs-snapshot
503Summary: Yum plugin to automatically snapshot your filesystems during updates
504Group: Base
505Requires: yum >= 3.2.22
506
507%description -n yum-plugin-fs-snapshot
508When this plugin is installed it will automatically snapshot any
509filesystem that is touched by the packages in a yum update or yum
510remove.
511
512%package -n yum-plugin-ps
513Summary: Yum plugin to look at processes, with respect to packages
514Group: Base
515Requires: yum >= 3.2.27
516
517%description -n yum-plugin-ps
518When this plugin is installed it adds the yum command "ps", which
519allows you to see which running processes are accociated with which
520packages (and if they need rebooting, or have updates, etc.)
521
522%package -n yum-plugin-puppetverify
523Summary: Yum plugin to add puppet checksums to verify data
524Group: Base
525Requires: puppet
526Requires: python-PyYAML >= 3.09
527Requires: yum >= 3.2.12
528
529%description -n yum-plugin-puppetverify
530Supplies checksums for files in packages from puppet's state file.
531
532%package -n bash-completion-%{name}
533Summary: bash-completion for Yum Utils
534Summary(pl.UTF-8): bashowe uzupełnianie nazw dla Yum Utils
535Group: Applications/Shells
536Requires: %{name}
537Requires: bash-completion
538
539%description -n bash-completion-%{name}
540bash-completion for Yum Utils.
541
542%description -n bash-completion-%{name} -l pl.UTF-8
543bashowe uzupełnianie nazw dla Yum Utils.
544
545%prep
546%setup -q
547%patch0 -p1
548
549mv plugins/README README.plugins
550
551%build
552%{__make}
553
554%install
555rm -rf $RPM_BUILD_ROOT
556%{__make} install \
557 PYLIBDIR=%{py_scriptdir} \
558 DESTDIR=$RPM_BUILD_ROOT
559%{__make} -C updateonboot install \
560 DESTDIR=$RPM_BUILD_ROOT
561
562# Plugins to install
563plugins="
564changelog
565fastestmirror
566protectbase
567versionlock
568tsflags
569kernel-module
570downloadonly
571allowdowngrade
572priorities
573refresh-updatesd
574merge-conf
575security
576basearchonly
577upgrade-helper
578aliases
579list-data
580filter-data
581tmprepo
582verify
583
584keys
585remove-with-leaves
586post-transaction-actions
587rpm-warm-cache
588auto-update-debuginfo
589show-leaves
590local
591fs-snapshot
592ps
593%{?with_puppet:puppetverify}
594"
595
596install -d $RPM_BUILD_ROOT{%{_sysconfdir}/yum/{pluginconf.d,post-actions},%{_libexecdir}}
597
598cd plugins
599for plug in $plugins; do
600 cp -p $plug/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/yum/pluginconf.d
601 cp -p $plug/*.py $RPM_BUILD_ROOT%{_libexecdir}
602done
603
604cp -p aliases/aliases $RPM_BUILD_ROOT%{_sysconfdir}/yum/aliases.conf
605cp -p versionlock/versionlock.list $RPM_BUILD_ROOT%{_sysconfdir}/yum/pluginconf.d
606
607# need for for the ghost in files section of yum-plugin-local
608install -d $RPM_BUILD_ROOT%{_sysconfdir}/yum.repos.d
609touch $RPM_BUILD_ROOT%{_sysconfdir}/yum.repos.d/_local.repo
610
611cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_libexecdir}/pld-kernel.py
612cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/yum/pluginconf.d/pld-kernel.conf
613
614%py_postclean
615
616%clean
617rm -rf $RPM_BUILD_ROOT
618
619%post -n yum-updateonboot
620/sbin/chkconfig --add yum-updateonboot
621
622%preun -n yum-updateonboot
623if [ "$1" = 0 ]; then
624 %service yum-updateonboot stop
625 /sbin/chkconfig --del yum-updateonboot
626fi
627
628%files
629%defattr(644,root,root,755)
630%doc ChangeLog README README.plugins TODO
631%doc yum-util-cli-template
632%attr(755,root,root) %{_bindir}/debuginfo-install
633%attr(755,root,root) %{_bindir}/find-repos-of-install
634%attr(755,root,root) %{_bindir}/needs-restarting
635%attr(755,root,root) %{_bindir}/package-cleanup
636%attr(755,root,root) %{_bindir}/repo-graph
637%attr(755,root,root) %{_bindir}/repo-rss
638%attr(755,root,root) %{_bindir}/repoclosure
639%attr(755,root,root) %{_bindir}/repodiff
640%attr(755,root,root) %{_bindir}/repomanage
641%attr(755,root,root) %{_bindir}/repoquery
642%attr(755,root,root) %{_bindir}/reposync
643%attr(755,root,root) %{_bindir}/repotrack
644%attr(755,root,root) %{_bindir}/show-changed-rco
645%attr(755,root,root) %{_bindir}/show-installed
646%attr(755,root,root) %{_bindir}/verifytree
647%attr(755,root,root) %{_bindir}/yum-builddep
648%attr(755,root,root) %{_bindir}/yum-config-manager
649%attr(755,root,root) %{_bindir}/yum-debug-dump
650%attr(755,root,root) %{_bindir}/yum-debug-restore
651%attr(755,root,root) %{_bindir}/yum-groups-manager
652%attr(755,root,root) %{_bindir}/yumdownloader
653%attr(755,root,root) %{_sbindir}/yum-complete-transaction
654%attr(755,root,root) %{_sbindir}/yumdb
655%dir %{_libexecdir}
656%dir %{py_sitescriptdir}/yumutils
657%{py_sitescriptdir}/yumutils/*.py[co]
658%{_mandir}/man1/debuginfo-install.1*
659%{_mandir}/man1/package-cleanup.1.*
660%{_mandir}/man1/repo-rss.1.*
661%{_mandir}/man1/repodiff.1*
662%{_mandir}/man1/repoquery.1.*
663%{_mandir}/man1/reposync.1.*
664%{_mandir}/man1/show-changed-rco.1*
665%{_mandir}/man1/show-installed.1*
666%{_mandir}/man1/yum-aliases.1*
667%{_mandir}/man1/yum-builddep.1.*
668%{_mandir}/man1/yum-debug-dump.1*
669%{_mandir}/man1/yum-groups-manager.1*
670%{_mandir}/man1/yum-utils.1.*
671%{_mandir}/man1/yum-versionlock.1*
672%{_mandir}/man1/yumdownloader.1.*
673%{_mandir}/man5/yum-versionlock.conf.5*
674%{_mandir}/man8/yum-complete-transaction.8.*
675%{_mandir}/man8/yumdb.8*
676
677%files -n yum-updateonboot
678%defattr(644,root,root,755)
679%doc updateonboot/README
680%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/yum-updateonboot
681%attr(754,root,root) /etc/rc.d/init.d/yum-updateonboot
682
683%files -n yum-plugin-changelog
684%defattr(644,root,root,755)
685%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/changelog.conf
686%{_libexecdir}/changelog.*
687%{_mandir}/man1/yum-changelog.1.*
688%{_mandir}/man5/yum-changelog.conf.5.*
689
690%files -n yum-plugin-fastestmirror
691%defattr(644,root,root,755)
692%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/fastestmirror.conf
693%{_libexecdir}/fastestmirror.*
694
695%files -n yum-plugin-protectbase
696%defattr(644,root,root,755)
697%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/protectbase.conf
698%{_libexecdir}/protectbase.*
699
700%files -n yum-plugin-versionlock
701%defattr(644,root,root,755)
702%doc plugins/versionlock/README
703%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/versionlock.conf
704%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/versionlock.list
705%{_libexecdir}/versionlock.*
706
707%files -n yum-plugin-tsflags
708%defattr(644,root,root,755)
709%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/tsflags.conf
710%{_libexecdir}/tsflags.*
711
712# TODO: remove in pld? removed in fedora
713%files -n yum-kernel-module
714%defattr(644,root,root,755)
715%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/kernel-module.conf
716%{_libexecdir}/kernel-module.*
717
718%files -n yum-plugin-downloadonly
719%defattr(644,root,root,755)
720%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/downloadonly.conf
721%{_libexecdir}/downloadonly.*
722
723# TODO: remove like fedora?
724%files -n yum-allowdowngrade
725%defattr(644,root,root,755)
726%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/allowdowngrade.conf
727%{_libexecdir}/allowdowngrade.*
728
729%files -n yum-plugin-pld-kernel
730%defattr(644,root,root,755)
731%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/pld-kernel.conf
732%{_libexecdir}/pld-kernel.*
733
734%files -n yum-plugin-priorities
735%defattr(644,root,root,755)
736%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/priorities.conf
737%{_libexecdir}/priorities.*
738
739%files -n yum-plugin-refresh-updatesd
740%defattr(644,root,root,755)
741%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/refresh-updatesd.conf
742%{_libexecdir}/refresh-updatesd.*
743
744%files -n yum-plugin-merge-conf
745%defattr(644,root,root,755)
746%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/merge-conf.conf
747%{_libexecdir}/merge-conf.*
748
749%files -n yum-plugin-security
750%defattr(644,root,root,755)
751%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/security.conf
752%{_libexecdir}/security.*
753%{_mandir}/man8/yum-security.8.*
754
755%if 0
756# TODO: renamed to protectbase?
757%files -n yum-protect-packages
758%defattr(644,root,root,755)
759%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/protect-packages.conf
760%{_libexecdir}/protect-packages.*
761%endif
762
763# TODO: rename to basearchonly like fedora?
764%files -n yum-basearchonly
765%defattr(644,root,root,755)
766%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/basearchonly.conf
767%{_libexecdir}/basearchonly.*
768
769%files -n yum-plugin-upgrade-helper
770%defattr(644,root,root,755)
771%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/upgrade-helper.conf
772%{_libexecdir}/upgrade-helper.*
773
774%files -n yum-plugin-aliases
775%defattr(644,root,root,755)
776%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/aliases.conf
777%config(noreplace) %{_sysconfdir}/yum/aliases.conf
778%{_libexecdir}/aliases.*
779
780%files -n yum-plugin-list-data
781%defattr(644,root,root,755)
782%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/list-data.conf
783%{_libexecdir}/list-data.*
784%{_mandir}/man1/yum-list-data.1.*
785
786%files -n yum-plugin-filter-data
787%defattr(644,root,root,755)
788%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/filter-data.conf
789%{_libexecdir}/filter-data.*
790%{_mandir}/man1/yum-filter-data.1.*
791
792%files -n yum-plugin-tmprepo
793%defattr(644,root,root,755)
794%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/tmprepo.conf
795%{_libexecdir}/tmprepo.*
796
797%files -n yum-plugin-verify
798%defattr(644,root,root,755)
799%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/verify.conf
800%{_libexecdir}/verify.*
801%{_mandir}/man1/yum-verify.1.*
802
803%files -n yum-plugin-keys
804%defattr(644,root,root,755)
805%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/keys.conf
806%{_libexecdir}/keys.*
807
808%files -n yum-NetworkManager-dispatcher
809%defattr(644,root,root,755)
810%{_sysconfdir}/NetworkManager/dispatcher.d/yum-NetworkManager-dispatcher
811
812%files -n yum-plugin-remove-with-leaves
813%defattr(644,root,root,755)
814%{_libexecdir}/remove-with-leaves.*
815%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/remove-with-leaves.conf
816
817%files -n yum-plugin-post-transaction-actions
818%defattr(644,root,root,755)
819%{_libexecdir}/post-transaction-actions.*
820%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/post-transaction-actions.conf
821%doc plugins/post-transaction-actions/sample.action
822# Default *.action file dropping dir.
823%dir %{_sysconfdir}/yum/post-actions
824
825%files -n yum-plugin-rpm-warm-cache
826%defattr(644,root,root,755)
827%{_libexecdir}/rpm-warm-cache.*
828%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/rpm-warm-cache.conf
829
830%files -n yum-plugin-auto-update-debug-info
831%defattr(644,root,root,755)
832%{_libexecdir}/auto-update-debuginfo.*
833%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/auto-update-debuginfo.conf
834
835%files -n yum-plugin-show-leaves
836%defattr(644,root,root,755)
837%{_libexecdir}/show-leaves.*
838%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/show-leaves.conf
839
840%files -n yum-plugin-local
841%defattr(644,root,root,755)
842%ghost %{_sysconfdir}/yum.repos.d/_local.repo
843%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/local.conf
844%{_libexecdir}/local.*
845
846%files -n yum-plugin-fs-snapshot
847%defattr(644,root,root,755)
848%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/fs-snapshot.conf
849%{_libexecdir}/fs-snapshot.*
850%{_mandir}/man1/yum-fs-snapshot.1.*
851%{_mandir}/man5/yum-fs-snapshot.conf.5.*
852
853%files -n yum-plugin-ps
854%defattr(644,root,root,755)
855%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/ps.conf
856%{_libexecdir}/ps.*
857
858%if %{with puppet}
859%files -n yum-plugin-puppetverify
860%defattr(644,root,root,755)
861%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/puppetverify.conf
862%{_libexecdir}/puppetverify.*
863%endif
864
865%files -n bash-completion-%{name}
866%defattr(644,root,root,755)
867/etc/bash_completion.d/*
This page took 0.067 seconds and 4 git commands to generate.