]> git.pld-linux.org Git - packages/yarn.git/blame - yarn.spec
up to 0.24.5
[packages/yarn.git] / yarn.spec
CommitLineData
dfd165f4 1Summary: Fast, reliable, and secure node dependency management
b3fffc6d 2Name: yarn
dfd165f4 3Version: 0.24.5
b3fffc6d
ER
4Release: 1
5License: BSD
6Group: Development/Tools
7Source0: https://github.com/yarnpkg/yarn/releases/download/v%{version}/%{name}-v%{version}.tar.gz
dfd165f4 8# Source0-md5: c2484941f0ff0dd20079d2b1f5229845
b3fffc6d
ER
9URL: https://yarnpkg.com/
10BuildRequires: rpmbuild(macros) >= 1.634
11BuildRequires: sed >= 4.0
12Requires: nodejs >= 4.0
13BuildArch: noarch
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17Fast, reliable, and secure dependency management. Yarn: Fast,
18reliable, and secure dependency management.
19
20Fast: Yarn caches every package it downloads so it never needs to
21again. It also parallelizes operations to maximize resource
22utilization so install times are faster than ever.
23
24Reliable: Using a detailed, but concise, lockfile format, and a
25deterministic algorithm for installs, Yarn is able to guarantee that
26an install that worked on one system will work exactly the same way on
27any other system.
28
29Secure: Yarn uses checksums to verify the integrity of every installed
30package before its code is executed.
31
32%prep
33%setup -qc
34mv dist/* .
35
1f4e8cb0
ER
36%{__rm} bin/*.cmd
37%{__rm} bin/yarn
38%{__rm} bin/yarnpkg
b3fffc6d
ER
39
40%install
41rm -rf $RPM_BUILD_ROOT
42install -d $RPM_BUILD_ROOT{%{nodejs_libdir}/%{name},%{_bindir}}
43
dfd165f4 44cp -a lib bin package.json $RPM_BUILD_ROOT%{nodejs_libdir}/%{name}
b3fffc6d
ER
45ln -s %{nodejs_libdir}/%{name}/bin/%{name}.js $RPM_BUILD_ROOT%{_bindir}/%{name}
46ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/yarnpkg
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files
52%defattr(644,root,root,755)
dfd165f4 53%doc LICENSE
b3fffc6d
ER
54%attr(755,root,root) %{_bindir}/yarn
55%attr(755,root,root) %{_bindir}/yarnpkg
56%defattr(-,root,root,-)
57%{nodejs_libdir}/%{name}
This page took 0.059798 seconds and 4 git commands to generate.