]> git.pld-linux.org Git - packages/yarn.git/blame - yarn.spec
up to 1.12.1
[packages/yarn.git] / yarn.spec
CommitLineData
dfd165f4 1Summary: Fast, reliable, and secure node dependency management
b3fffc6d 2Name: yarn
bc001d7f 3Version: 1.12.1
6a7b726a 4Release: 1
b3fffc6d
ER
5License: BSD
6Group: Development/Tools
7Source0: https://github.com/yarnpkg/yarn/releases/download/v%{version}/%{name}-v%{version}.tar.gz
bc001d7f 8# Source0-md5: 0f9197f5dceace96d93520e492c043a2
b3fffc6d
ER
9URL: https://yarnpkg.com/
10BuildRequires: rpmbuild(macros) >= 1.634
11BuildRequires: sed >= 4.0
12Requires: nodejs >= 4.0
13BuildArch: noarch
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17Fast, reliable, and secure dependency management. Yarn: Fast,
18reliable, and secure dependency management.
19
20Fast: Yarn caches every package it downloads so it never needs to
21again. It also parallelizes operations to maximize resource
22utilization so install times are faster than ever.
23
24Reliable: Using a detailed, but concise, lockfile format, and a
25deterministic algorithm for installs, Yarn is able to guarantee that
26an install that worked on one system will work exactly the same way on
27any other system.
28
29Secure: Yarn uses checksums to verify the integrity of every installed
30package before its code is executed.
31
32%prep
c8d0b800 33%setup -q -n %{name}-v%{version}
b3fffc6d 34
1f4e8cb0
ER
35%{__rm} bin/*.cmd
36%{__rm} bin/yarn
37%{__rm} bin/yarnpkg
b3fffc6d
ER
38
39%install
40rm -rf $RPM_BUILD_ROOT
41install -d $RPM_BUILD_ROOT{%{nodejs_libdir}/%{name},%{_bindir}}
42
dfd165f4 43cp -a lib bin package.json $RPM_BUILD_ROOT%{nodejs_libdir}/%{name}
b3fffc6d
ER
44ln -s %{nodejs_libdir}/%{name}/bin/%{name}.js $RPM_BUILD_ROOT%{_bindir}/%{name}
45ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/yarnpkg
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(644,root,root,755)
dfd165f4 52%doc LICENSE
b3fffc6d
ER
53%attr(755,root,root) %{_bindir}/yarn
54%attr(755,root,root) %{_bindir}/yarnpkg
55%defattr(-,root,root,-)
56%{nodejs_libdir}/%{name}
This page took 0.128587 seconds and 4 git commands to generate.