]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blobdiff - xorg-xserver-server.spec
- up to 1.19.3
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
index 240d73223c08d9a84785e46c208fb4664a3dbdfa..a9a3668caaba522d4e7e9032c996e72dca9e92f1 100644 (file)
@@ -1,54 +1,63 @@
-# TODO: consider XSELINUX
+# TODO
+# - consider XSELINUX by default
+# - Xvfb initscript runs Xvfb as root! add user there!
 #
 # Conditional build:
 %bcond_with    dbus            # D-BUS support for configuration (if no udev)
 %bcond_with    hal             # HAL support for configuration (if no udev)
 %bcond_without udev            # UDEV support for configuration
 %bcond_without dri2            # DRI2 extension
-%bcond_without dmx             # DMX support
+%bcond_without dri3            # DRI3 extension
 %bcond_without record          # RECORD extension
 %bcond_with    xcsecurity      # XC-SECURITY extension (deprecated)
 %bcond_with    xf86bigfont     # XF86BigFont extension
 %bcond_with    xselinux        # SELinux extension
+%bcond_without dmx             # DMX DDX (Xdmx server)
+%bcond_without wayland         # Wayland DDX (Xwayland server)
+%bcond_without glamor          # glamor dix module
+%bcond_without systemtap       # systemtap/dtrace probes
+%bcond_without libunwind       # use libunwind for backtracing
 #
 # ABI versions, see hw/xfree86/common/xf86Module.h
 %define        xorg_xserver_server_ansic_abi           0.4
-%define        xorg_xserver_server_extension_abi       7.0
+%define        xorg_xserver_server_extension_abi       10.0
 %define        xorg_xserver_server_font_abi            0.6
-%define        xorg_xserver_server_videodrv_abi        13.0
-%define        xorg_xserver_server_xinput_abi          18.0
-#
-%define        pixman_ver      0.28.0
+%define        xorg_xserver_server_videodrv_abi        23.0
+%define        xorg_xserver_server_xinput_abi          24.1
+
+%define        pixman_ver      0.30.0
+
+%ifarch x32
+%undefine      with_libunwind
+%endif
 
 Summary:       X.org server
 Summary(pl.UTF-8):     Serwer X.org
 Name:          xorg-xserver-server
-Version:       1.13.0
-Release:       3
+Version:       1.19.3
+Release:       1
 License:       MIT
 Group:         X11/Servers
 Source0:       http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
-# Source0-md5: bde3d178b756597d2ec2a19ef60d2e1f
+# Source0-md5: 015d2fc4b9f2bfe7a626edb63a62c65e
 Source1:       10-quirks.conf
 Source2:       xserver.pamd
 Source10:      %{name}-Xvfb.init
 Source11:      %{name}-Xvfb.sysconfig
-Patch0:                %{name}-xwrapper.patch
-Patch1:                %{name}-pic-libxf86config.patch
-Patch2:                pixman-cache.patch
-Patch3:                %{name}-less-acpi-brokenness.patch
+Source12:      xvfb-run.sh
+Patch1:                %{name}-xwrapper-pam.patch
+
 Patch4:                %{name}-builtin-SHA1.patch
-Patch5:                %{name}-export-GetMaster.patch
+
 Patch6:                110_nvidia_slowdow_fix.patch
-Patch7:                %{name}-include-defs.patch
-# https://bugs.freedesktop.org/show_bug.cgi?id=54654
-Patch8:                0001-dix-fix-zaphod-screen-scrossing-54654.patch
 URL:           http://xorg.freedesktop.org/
 BuildRequires: Mesa-libGL-devel >= 7.8.1
+%{?with_dri2:BuildRequires:    Mesa-libGL-devel >= 9.2.0}
+%{?with_glamor:BuildRequires:  Mesa-libgbm-devel >= 10.2.0}
 # for glx headers
 BuildRequires: OpenGL-GLX-devel
 %{?with_xselinux:BuildRequires:        audit-libs-devel}
-BuildRequires: autoconf >= 2.57
+BuildRequires: autoconf >= 2.60
 BuildRequires: automake
 BuildRequires: cpp
 BuildRequires: docbook-dtd43-xml
@@ -57,31 +66,46 @@ BuildRequires:      docbook-dtd43-xml
 BuildRequires: dbus-devel >= 1.0
 %endif
 %{?with_hal:BuildRequires:     hal-devel}
-BuildRequires: libdrm-devel >= 2.4.39
+BuildRequires: libdrm-devel >= 2.4.46
+%if %{with glamor} || %{with wayland}
+BuildRequires: libepoxy-devel
+%endif
 %{?with_xselinux:BuildRequires:        libselinux-devel >= 2.0.86}
-BuildRequires: libtool
-BuildRequires: ncurses-devel
+BuildRequires: libtool >= 2:2.2
+%{?with_libunwind:BuildRequires:       libunwind-devel}
+BuildRequires: libxcb-devel >= 1.6
 BuildRequires: pam-devel
 BuildRequires: perl-base
 BuildRequires: pixman-devel >= %{pixman_ver}
 BuildRequires: pkgconfig >= 1:0.19
+%{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
+BuildRequires: systemd-devel >= 209
 BuildRequires: udev-devel >= 1:143
+# wayland-client
+%{?with_wayland:BuildRequires: wayland-devel >= 1.3.0}
+%{?with_wayland:BuildRequires: wayland-protocols >= 1.1}
+BuildRequires: xcb-util-devel
+BuildRequires: xcb-util-image-devel
+BuildRequires: xcb-util-keysyms-devel
+BuildRequires: xcb-util-renderutil-devel
+BuildRequires: xcb-util-wm-devel
 BuildRequires: xmlto >= 0.0.20
 BuildRequires: xorg-app-mkfontscale
 BuildRequires: xorg-font-font-util >= 1.1
-BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libX11-devel >= 1.6
 BuildRequires: xorg-lib-libXau-devel
-BuildRequires: xorg-lib-libXaw-devel
+%{?with_dmx:BuildRequires:     xorg-lib-libXaw-devel}
 BuildRequires: xorg-lib-libXdamage-devel
 BuildRequires: xorg-lib-libXdmcp-devel
 BuildRequires: xorg-lib-libXext-devel >= 1.0.99.4
-BuildRequires: xorg-lib-libXfont-devel >= 1.4.2
+BuildRequires: xorg-lib-libXfixes-devel
+BuildRequires: xorg-lib-libXfont2-devel >= 2.0.0
 BuildRequires: xorg-lib-libXi-devel >= 1.2.99.1
-BuildRequires: xorg-lib-libXmu-devel
-BuildRequires: xorg-lib-libXpm-devel
+%{?with_dmx:BuildRequires:     xorg-lib-libXmu-devel}
+%{?with_dmx:BuildRequires:     xorg-lib-libXpm-devel}
 BuildRequires: xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXres-devel
-BuildRequires: xorg-lib-libXt-devel >= 1.0.0
+%{?with_dmx:BuildRequires:     xorg-lib-libXt-devel >= 1.0.0}
 BuildRequires: xorg-lib-libXtst-devel >= 1.0.99.2
 BuildRequires: xorg-lib-libXv-devel
 BuildRequires: xorg-lib-libXxf86dga-devel
@@ -91,63 +115,68 @@ BuildRequires:     xorg-lib-libXxf86vm-devel
 BuildRequires: xorg-lib-libfontenc-devel
 BuildRequires: xorg-lib-libpciaccess-devel >= 0.12.901
 BuildRequires: xorg-lib-libxkbfile-devel
-BuildRequires: xorg-lib-libxkbui-devel >= 1.0.2
-BuildRequires: xorg-lib-xtrans-devel >= 1.2.2
+BuildRequires: xorg-lib-libxshmfence-devel >= 1.1
+BuildRequires: xorg-lib-xtrans-devel >= 1.3.5
 BuildRequires: xorg-proto-bigreqsproto-devel >= 1.1.0
 BuildRequires: xorg-proto-compositeproto-devel >= 0.4
 BuildRequires: xorg-proto-damageproto-devel >= 1.1
 %{?with_dmx:BuildRequires:     xorg-proto-dmxproto-devel >= 2.2.99.1}
 %{?with_dri2:BuildRequires:    xorg-proto-dri2proto-devel >= 2.8}
+BuildRequires: xorg-proto-dri3proto-devel >= 1.0
 BuildRequires: xorg-proto-fixesproto-devel >= 5.0
 BuildRequires: xorg-proto-fontcacheproto-devel
-BuildRequires: xorg-proto-fontsproto-devel
-BuildRequires: xorg-proto-glproto-devel >= 1.4.16
-BuildRequires: xorg-proto-inputproto-devel >= 2.2
+BuildRequires: xorg-proto-fontsproto-devel >= 2.1.3
+BuildRequires: xorg-proto-glproto-devel >= 1.4.17
+BuildRequires: xorg-proto-inputproto-devel >= 2.3
 BuildRequires: xorg-proto-kbproto-devel >= 1.0.3
+BuildRequires: xorg-proto-presentproto-devel >= 1.0
 BuildRequires: xorg-proto-printproto-devel
-BuildRequires: xorg-proto-randrproto-devel >= 1.4.0
+BuildRequires: xorg-proto-randrproto-devel >= 1.5.0
 %{?with_record:BuildRequires:  xorg-proto-recordproto-devel >= 1.13.99.1}
 BuildRequires: xorg-proto-renderproto-devel >= 0.11
 BuildRequires: xorg-proto-resourceproto-devel >= 1.2.0
 BuildRequires: xorg-proto-scrnsaverproto-devel >= 1.1
 BuildRequires: xorg-proto-videoproto-devel
 BuildRequires: xorg-proto-xcmiscproto-devel >= 1.2.0
-BuildRequires: xorg-proto-xextproto-devel >= 1:7.2.0
+BuildRequires: xorg-proto-xextproto-devel >= 1:7.3.0
 %{?with_xf86bigfont:BuildRequires:     xorg-proto-xf86bigfontproto-devel >= 1.2.0}
 BuildRequires: xorg-proto-xf86dgaproto-devel >= 2.0.99.1
 BuildRequires: xorg-proto-xf86driproto-devel >= 2.1.0
 BuildRequires: xorg-proto-xf86miscproto-devel
 BuildRequires: xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
 BuildRequires: xorg-proto-xineramaproto-devel
-BuildRequires: xorg-proto-xproto-devel >= 7.0.22
+BuildRequires: xorg-proto-xproto-devel >= 7.0.31
 BuildRequires: xorg-sgml-doctools >= 1.8
 BuildRequires: xorg-util-util-macros >= 1.14
 #BR: tslib (for KDRIVE only)
 Requires(triggerpostun):       sed >= 4.0
+%{?with_glamor:Requires:       Mesa-libgbm >= 10.2.0}
+Requires:      libdrm >= 2.4.46
 Requires:      pixman >= %{pixman_ver}
+Requires:      udev-libs >= 1:143
 Requires:      xkeyboard-config
 # for rgb.txt
 Requires:      xorg-app-rgb >= 0.99.3
 Requires:      xorg-app-xkbcomp
+Requires:      xorg-lib-libXfont2 >= 2.0.0
+Requires:      xorg-lib-libpciaccess >= 0.12.901
+Requires:      xorg-lib-libxshmfence >= 1.1
+Suggests:      dbus-x11 >= 1.0
 %{?with_hal:Suggests:  hal}
 Suggests:      udev-acl >= 1:143
 %{?with_udev:Suggests: udev-core >= 1:143}
-Suggests:      xorg-driver-input-evdev
-# xserver requires fixed and cursor fonts
-Requires:      xorg-font-font-alias
-Requires:      xorg-font-font-cursor-misc
-Requires:      xorg-font-font-misc-misc-base >= 1.0.0-0.3
-Suggests:      dbus-x11 >= 1.0
 Suggests:      xkeyboard-config
+Suggests:      xorg-driver-input-libinput
 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
 Suggests:      xorg-driver-video
+Provides:      xorg-driver-video-modesetting
+Provides:      xorg-xserver-libdri = %{version}-%{release}
+Provides:      xorg-xserver-module(dri)
 Provides:      xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
 Provides:      xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
 Provides:      xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
 Provides:      xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
 Provides:      xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
-Provides:      xorg-xserver-module(dri)
-Provides:      xorg-xserver-libdri = %{version}-%{release}
 Obsoletes:     X11-Xserver < 1:7.0.0
 Obsoletes:     X11-driver-i2c < 1:7.0.0
 Obsoletes:     X11-modules < 1:7.0.0
@@ -156,13 +185,12 @@ Obsoletes:        XFree86-Xserver < 1:7.0.0
 Obsoletes:     XFree86-modules < 1:7.0.0
 Obsoletes:     XFree86-setup < 1:7.0.0
 Obsoletes:     Xserver
-Obsoletes:     xorg-xserver-server-xorgcfg
+%{?with_glamor:Obsoletes:      glamor}
 Obsoletes:     xorg-xserver-libdri
+Obsoletes:     xorg-xserver-server-xorgcfg
+Obsoletes:     xorg-driver-video-modesetting
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# avoid self-dependencies on included modules
-%define                _noautoreq      libscanpci.so libxf1bpp.so
-
 %description
 Xorg server is a generally used X server which uses display hardware.
 It requires proper driver for your display hardware.
@@ -175,6 +203,12 @@ graficznej. Do działania wymaga odpowiedniego sterownika.
 Summary:       Xdmx - distributed multi-head X server
 Summary(pl.UTF-8):     Xdmx - rozproszony, wielomonitorowy serwer X
 Group:         X11/Servers
+Requires:      pixman >= %{pixman_ver}
+Requires:      xorg-lib-libX11 >= 1.6
+Requires:      xorg-lib-libXext >= 1.0.99.4
+Requires:      xorg-lib-libXfont2 >= 2.0.0
+Requires:      xorg-lib-libXi >= 1.2.99.1
+Requires:      xorg-lib-libdmx >= 1.0.99.1
 
 %description -n xorg-xserver-Xdmx
 Xdmx - distributed multi-head X server.
@@ -186,6 +220,9 @@ Xdmx - rozproszony, wielomonitorowy serwer X.
 Summary:       Xnest - nested X server
 Summary(pl.UTF-8):     Xnest - zagnieżdżony serwer X
 Group:         X11/Servers
+Requires:      pixman >= %{pixman_ver}
+Requires:      xorg-lib-libXext >= 1.0.99.4
+Requires:      xorg-lib-libXfont2 >= 2.0.0
 Obsoletes:     X11-Xnest < 1:7.0.0
 Obsoletes:     XFree86-Xnest < 1:7.0.0
 Obsoletes:     Xserver-Xnest
@@ -217,10 +254,13 @@ Xnest - це сервер X Window System, який працює у вікні X
 Summary:       Xephyr - nested X server
 Summary(pl.UTF-8):     Xephyr - zagnieżdżony serwer X
 Group:         X11/Servers
+Requires:      Mesa-libGL >= 7.1.0
+Requires:      libxcb >= 1.6
 Requires:      pixman >= %{pixman_ver}
+Requires:      xorg-lib-libXfont2 >= 2.0.0
 
 %description -n xorg-xserver-Xephyr
-Xephyr is a kdrive server that outputs to a window on a pre-existing
+Xephyr is a kdrive server that outputs to a window on a pre-existing
 'host' X display. Think Xnest but with support for modern extensions
 like composite, damage and randr.
 
@@ -240,6 +280,8 @@ wspólczesnych rozszerzeń jak composite, damage i randr.
 Summary:       Xfbdev - Linux framebuffer device X server
 Summary(pl.UTF-8):     Xfbdev - serwer X dla framebuffera
 Group:         X11/Servers
+Requires:      pixman >= %{pixman_ver}
+Requires:      xorg-lib-libXfont2 >= 2.0.0
 
 %description -n xorg-xserver-Xfbdev
 Xfbdev is a Linux framebuffer device X server based on the kdrive X
@@ -252,10 +294,15 @@ Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
 Summary:       Xvfb - virtual framebuffer X server
 Summary(pl.UTF-8):     Xvfb - serwer X z wirtualnym framebufferem
 Group:         X11/Servers
-# requires fixed and cursor fonts
-Requires:      xorg-font-font-alias
-Requires:      xorg-font-font-cursor-misc
-Requires:      xorg-font-font-misc-misc-base >= 1.0.0-0.3
+Requires:      Mesa-libGL >= 7.1.0
+Requires:      mktemp
+Requires:      pixman >= %{pixman_ver}
+Requires:      util-linux
+Requires:      which
+Requires:      xkeyboard-config
+Requires:      xorg-app-xauth
+Requires:      xorg-app-xkbcomp
+Requires:      xorg-lib-libXfont2 >= 2.0.0
 Obsoletes:     X11-Xvfb < 1:7.0.0
 Obsoletes:     XFree86-Xvfb < 1:7.0.0
 
@@ -296,29 +343,52 @@ system service.
 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
 usługę systemową.
 
+%package -n xorg-xserver-Xwayland
+Summary:       Xwayland - X server integrated into a Wayland window system
+Summary(pl.UTF-8):     Xwayland - serwer X integrowalny w Wayland
+Group:         X11/Servers
+Requires:      pixman >= %{pixman_ver}
+Requires:      xorg-lib-libX11 >= 1.6
+Requires:      xorg-lib-libXext >= 1.0.99.4
+Requires:      xorg-lib-libXfont2 >= 2.0.0
+Requires:      xorg-lib-libXi >= 1.2.99.1
+
+%description -n xorg-xserver-Xwayland
+Xwayland - server integrated into a Wayland window system.
+
+%description -n xorg-xserver-Xwayland -l pl.UTF-8
+Xwayland - serwer X integrowalny w Wayland.
+
 %package devel
 Summary:       Header files for X.org server
 Summary(pl.UTF-8):     Pliki nagłówkowe dla serwera X.org
 Group:         X11/Development/Libraries
-Requires:      libdrm-devel >= 2.4.39
+Requires:      Mesa-libGL-devel >= 7.8.0
+Requires:      libdrm-devel >= 2.4.46
 Requires:      pixman-devel >= %{pixman_ver}
+Requires:      xorg-lib-libXfont2-devel >= 2.0.0
 Requires:      xorg-lib-libpciaccess-devel >= 0.12.901
 Requires:      xorg-lib-libxkbfile-devel
 %{?with_dri2:Requires: xorg-proto-dri2proto-devel >= 2.8}
-Requires:      xorg-proto-fontsproto-devel
-Requires:      xorg-proto-inputproto-devel >= 2.2
+%{?with_dri3:Requires: xorg-proto-dri3proto-devel >= 1.0}
+Requires:      xorg-proto-dri3proto-devel >= 1.0
+Requires:      xorg-proto-fontsproto-devel >= 2.1.3
+Requires:      xorg-proto-glproto-devel >= 1.4.17
+Requires:      xorg-proto-inputproto-devel >= 2.3
 Requires:      xorg-proto-kbproto-devel >= 1.0.3
-Requires:      xorg-proto-randrproto-devel >= 1.4.0
+Requires:      xorg-proto-presentproto-devel >= 1.0
+Requires:      xorg-proto-randrproto-devel >= 1.5.0
 Requires:      xorg-proto-renderproto-devel >= 0.11
 Requires:      xorg-proto-resourceproto-devel >= 1.2.0
 Requires:      xorg-proto-scrnsaverproto-devel >= 1.1
 Requires:      xorg-proto-videoproto-devel
-Requires:      xorg-proto-xextproto-devel >= 1:7.2.0
+Requires:      xorg-proto-xextproto-devel >= 1:7.3.0
 Requires:      xorg-proto-xf86driproto-devel >= 2.1.0
 Requires:      xorg-proto-xineramaproto-devel
-Requires:      xorg-proto-xproto-devel >= 7.0.22
+Requires:      xorg-proto-xproto-devel >= 7.0.31
 Obsoletes:     X11-Xserver-devel < 1:7.0.0
 Obsoletes:     XFree86-Xserver-devel < 1:7.0.0
+%{?with_glamor:Obsoletes:      glamor-devel}
 
 %description devel
 Header files for X.org server.
@@ -342,6 +412,8 @@ Summary:    GLX extension library for X.org server
 Summary(pl.UTF-8):     Biblioteka rozszerzenia GLX dla serwera X.org
 Group:         X11/Servers
 Requires:      %{name} = %{version}-%{release}
+Requires:      Mesa-libGL >= 7.1.0
+%{?with_dri2:Requires: Mesa-libGL >= 9.2.0}
 # Mesa version glapi tables in glx/ dir come from
 Provides:      xorg-xserver-libglx(glapi) = 7.1.0
 Provides:      xorg-xserver-module(glx)
@@ -356,22 +428,18 @@ Biblioteka rozszerzenia GLX dla serwera X.org.
 
 %prep
 %setup -q -n xorg-server-%{version}
-%patch0 -p0
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
 
-#unfortunately breaks build
-#patch7 -p1
+%patch4 -p1
 
-%patch8 -p1
+%patch6 -p1
 
 # xserver uses pixman-1 API/ABI so put that explictly here
 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
 
+# support __filemansuffix__ with "x" suffix (per FHS 2.3)
+%{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
+
 %build
 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
@@ -407,36 +475,47 @@ fi
 %{__autoheader}
 %{__automake}
 %configure \
+       --libexecdir=%{_libdir}/xorg \
        --with-os-name="PLD/Linux" \
        --with-os-vendor="PLD/Team" \
-       --without-fop \
+       --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
+       --with-xkb-output=/var/lib/xkb \
+       --disable-linux-acpi \
+       --disable-linux-apm \
+       --enable-aiglx \
        %{?with_dbus:--enable-config-dbus} \
        --enable-config-hal%{!?with_hal:=no} \
        --enable-config-udev%{!?with_udev:=no} \
-       --enable-aiglx \
        --enable-dga \
        %{?with_dmx:--enable-dmx} \
-       --enable-glx-tls \
-       --enable-install-libxf86config \
-       %{?with_record:--enable-record} \
+       --enable-dri2%{!?with_dri2:=no} \
+       --enable-dri3%{!?with_dri3:=no} \
+       %{?with_glamor:--enable-glamor} \
        --enable-kdrive \
+       %{?with_libunwind:--enable-libunwind} \
+       %{?with_record:--enable-record} \
+       --enable-secure-rpc \
        %{?with_xcsecurity:--enable-xcsecurity} \
        --enable-xephyr \
        %{?with_xf86bigfont:--enable-xf86bigfont} \
+       --disable-xfake \
        --enable-xfbdev \
        %{?with_xselinux:--enable-xselinux} \
-       --enable-glx-tls \
-       --disable-xfake \
-       --enable-secure-rpc \
-       --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
-       --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
-       --with-xkb-output=/var/lib/xkb
+       %{?with_wayland:--enable-xwayland} \
+       %{!?with_systemtap:--without-dtrace} \
+       --without-fop \
+       --enable-suid-wrapper \
+       --with-systemd-daemon
 
-%{__make}
+%{__make} -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+%if "%{_libdir}" != "%{_exec_prefix}/lib"
+install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
+%endif
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -444,11 +523,12 @@ install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
+install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
 
 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
 
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
 
@@ -457,6 +537,19 @@ install -d $RPM_BUILD_ROOT/etc/sysconfig
 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
 
+# Xorg.wrap config
+cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
+# allowed values: rootonly console anybody pam
+allowed_users = pam
+
+# set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
+#needs_root_rights = yes
+EOF
+
+# compatibility with old xwrapper
+ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
+
+# prepare source package
 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
@@ -464,6 +557,10 @@ cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 find -name '*.h' | xargs chmod a-x
 
+%if %{with systemtap}
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -497,14 +594,29 @@ fi
 %attr(755,root,root) %{_bindir}/gtf
 %dir %{_libdir}/xorg
 %{_libdir}/xorg/protocol.txt
+%attr(755,root,root) %{_libdir}/xorg/Xorg
+%attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
 %dir %{_libdir}/xorg/modules
+%attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
+%{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
+%attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
 %dir %{_libdir}/xorg/modules/dri
 %dir %{_libdir}/xorg/modules/drivers
+%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
 %dir %{_libdir}/xorg/modules/extensions
 %dir %{_libdir}/xorg/modules/input
-%dir %{_libdir}/xorg/modules/multimedia
-%attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
-%attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
+%if "%{_libdir}" != "%{_exec_prefix}/lib"
+%dir %{_exec_prefix}/lib/xorg
+%dir %{_exec_prefix}/lib/xorg/modules
+%dir %{_exec_prefix}/lib/xorg/modules/dri
+%endif
 %dir /var/lib/xkb
 /var/lib/xkb/README.compiled
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
@@ -512,17 +624,21 @@ fi
 %config(missingok) /etc/security/console.apps/xserver
 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
 %dir /etc/X11/xorg.conf.d
+%config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
 %dir %{_datadir}/X11/xorg.conf.d
 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
-%verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
-%{_mandir}/man1/Xorg.1x*
-%{_mandir}/man1/Xserver.1x*
+%verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
+%{_mandir}/man1/Xorg.1*
+%{_mandir}/man1/Xorg.wrap.1*
+%{_mandir}/man1/Xserver.1*
 %{_mandir}/man1/cvt.1*
-%{_mandir}/man1/gtf.1x*
+%{_mandir}/man1/gtf.1*
 %{_mandir}/man4/exa.4*
 %{_mandir}/man4/fbdevhw.4*
-%{_mandir}/man5/xorg.conf.5x*
-%{_mandir}/man5/xorg.conf.d.5x
+%{_mandir}/man4/modesetting.4*
+%{_mandir}/man5/Xwrapper.config.5*
+%{_mandir}/man5/xorg.conf.5*
+%{_mandir}/man5/xorg.conf.d.5*
 
 %if %{with dmx}
 %files -n xorg-xserver-Xdmx
@@ -539,21 +655,21 @@ fi
 %attr(755,root,root) %{_bindir}/dmxwininfo
 %attr(755,root,root) %{_bindir}/vdltodmx
 %attr(755,root,root) %{_bindir}/xdmxconfig
-%{_mandir}/man1/Xdmx.1x*
-%{_mandir}/man1/dmxtodmx.1x*
-%{_mandir}/man1/vdltodmx.1x*
-%{_mandir}/man1/xdmxconfig.1x*
+%{_mandir}/man1/Xdmx.1*
+%{_mandir}/man1/dmxtodmx.1*
+%{_mandir}/man1/vdltodmx.1*
+%{_mandir}/man1/xdmxconfig.1*
 %endif
 
 %files -n xorg-xserver-Xnest
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/Xnest
-%{_mandir}/man1/Xnest.1x*
+%{_mandir}/man1/Xnest.1*
 
 %files -n xorg-xserver-Xephyr
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/Xephyr
-%{_mandir}/man1/Xephyr.1x*
+%{_mandir}/man1/Xephyr.1*
 
 %files -n xorg-xserver-Xfbdev
 %defattr(644,root,root,755)
@@ -562,19 +678,24 @@ fi
 %files -n xorg-xserver-Xvfb
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/Xvfb
-%{_mandir}/man1/Xvfb.1x*
+%attr(755,root,root) %{_bindir}/xvfb-run
+%{_mandir}/man1/Xvfb.1*
 
 %files -n xorg-xserver-Xvfb-init
 %defattr(644,root,root,755)
 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
 
+%if %{with wayland}
+%files -n xorg-xserver-Xwayland
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/Xwayland
+%endif
+
 %files devel
 %defattr(644,root,root,755)
-%doc doc/{Xinput,Xserver-spec}.html
+%doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
 %{_includedir}/xorg
-%{_libdir}/libxf86config.a
-%{_libdir}/libxf86config.la
 %{_aclocaldir}/xorg-server.m4
 %{_pkgconfigdir}/xorg-server.pc
 
This page took 0.069244 seconds and 4 git commands to generate.