]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blobdiff - xorg-xserver-server.spec
try reenabling parallel build
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
index 70efd807199bf273df1f27fced4398b76593acd4..253dfa849c0c8769d3732996b2f76a2ce4f42a08 100644 (file)
@@ -1,51 +1,59 @@
-# TODO: consider XSELINUX
+# TODO
+# - consider XSELINUX by default
+# - Xvfb initscript runs Xvfb as root! add user there!
 #
 # Conditional build:
 %bcond_with    dbus            # D-BUS support for configuration (if no udev)
 %bcond_with    hal             # HAL support for configuration (if no udev)
 %bcond_without udev            # UDEV support for configuration
-%bcond_without dmx             # DMX support
 %bcond_without dri2            # DRI2 extension
+%bcond_without dri3            # DRI3 extension
 %bcond_without record          # RECORD extension
-%bcond_without systemtap       # systemtap/dtrace probes
 %bcond_with    xcsecurity      # XC-SECURITY extension (deprecated)
 %bcond_with    xf86bigfont     # XF86BigFont extension
 %bcond_with    xselinux        # SELinux extension
+%bcond_without dmx             # DMX DDX (Xdmx server)
+%bcond_without wayland         # Wayland DDX (Xwayland server)
+%bcond_with    eglstream       # XWayland eglstream support
+%bcond_without glamor          # glamor dix module
+%bcond_without systemtap       # systemtap/dtrace probes
+%bcond_without libunwind       # use libunwind for backtracing
 #
 # ABI versions, see hw/xfree86/common/xf86Module.h
 %define        xorg_xserver_server_ansic_abi           0.4
-%define        xorg_xserver_server_extension_abi       7.0
-%define        xorg_xserver_server_font_abi            0.6
-%define        xorg_xserver_server_videodrv_abi        14.1
-%define        xorg_xserver_server_xinput_abi          19.1
-#
+%define        xorg_xserver_server_extension_abi       10.0
+%define        xorg_xserver_server_videodrv_abi        24.1
+%define        xorg_xserver_server_xinput_abi          24.1
+
 %define        pixman_ver      0.30.0
 
+%ifarch x32
+%undefine      with_libunwind
+%endif
+
 Summary:       X.org server
 Summary(pl.UTF-8):     Serwer X.org
 Name:          xorg-xserver-server
-Version:       1.14.4
+Version:       1.20.8
 Release:       2
 License:       MIT
 Group:         X11/Servers
-Source0:       http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
-# Source0-md5: 9d68a30258c67faa3c036a4a85e8bf97
+Source0:       https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
+# Source0-md5: a770aec600116444a953ff632f51f839
 Source1:       10-quirks.conf
 Source2:       xserver.pamd
 Source10:      %{name}-Xvfb.init
 Source11:      %{name}-Xvfb.sysconfig
 Source12:      xvfb-run.sh
+Patch1:                %{name}-xwrapper-pam.patch
 
-Patch0:                %{name}-xwrapper.patch
-Patch1:                %{name}-pic-libxf86config.patch
-Patch2:                %{name}-newloader.patch
-Patch3:                %{name}-less-acpi-brokenness.patch
 Patch4:                %{name}-builtin-SHA1.patch
-Patch5:                %{name}-export-GetMaster.patch
+
 Patch6:                110_nvidia_slowdow_fix.patch
-Patch7:                %{name}-include-defs.patch
-URL:           http://xorg.freedesktop.org/
+URL:           https://xorg.freedesktop.org/
 BuildRequires: Mesa-libGL-devel >= 7.8.1
+%{?with_dri2:BuildRequires:    Mesa-libGL-devel >= 9.2.0}
+%{?with_glamor:BuildRequires:  Mesa-libgbm-devel >= 17.1.0}
 # for glx headers
 BuildRequires: OpenGL-GLX-devel
 %{?with_xselinux:BuildRequires:        audit-libs-devel}
@@ -57,33 +65,48 @@ BuildRequires:      docbook-dtd43-xml
 %if %{with hal} || %{with dbus}
 BuildRequires: dbus-devel >= 1.0
 %endif
+%{?with_eglstream:BuildRequires:       egl-wayland-devel >= 1.0.2}
 %{?with_hal:BuildRequires:     hal-devel}
-BuildRequires: libdrm-devel >= 2.4.39
+BuildRequires: libdrm-devel >= 2.4.89
+%if %{with glamor}
+BuildRequires: libepoxy-devel >= 1.5.4
+%endif
 %{?with_xselinux:BuildRequires:        libselinux-devel >= 2.0.86}
-BuildRequires: libtool
-BuildRequires: ncurses-devel
+BuildRequires: libtool >= 2:2.2
+%{?with_libunwind:BuildRequires:       libunwind-devel}
+BuildRequires: libxcb-devel >= 1.9.3
 BuildRequires: pam-devel
 BuildRequires: perl-base
 BuildRequires: pixman-devel >= %{pixman_ver}
 BuildRequires: pkgconfig >= 1:0.19
 %{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
+BuildRequires: systemd-devel >= 1:209
 BuildRequires: udev-devel >= 1:143
+# wayland-client
+%{?with_wayland:BuildRequires: wayland-devel >= 1.3.0}
+%{?with_wayland:BuildRequires: wayland-protocols >= 1.10}
+BuildRequires: xcb-util-devel
+BuildRequires: xcb-util-image-devel
+BuildRequires: xcb-util-keysyms-devel
+BuildRequires: xcb-util-renderutil-devel
+BuildRequires: xcb-util-wm-devel
 BuildRequires: xmlto >= 0.0.20
 BuildRequires: xorg-app-mkfontscale
 BuildRequires: xorg-font-font-util >= 1.1
-BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libX11-devel >= 1.6
 BuildRequires: xorg-lib-libXau-devel
-BuildRequires: xorg-lib-libXaw-devel
+%{?with_dmx:BuildRequires:     xorg-lib-libXaw-devel}
 BuildRequires: xorg-lib-libXdamage-devel
 BuildRequires: xorg-lib-libXdmcp-devel
 BuildRequires: xorg-lib-libXext-devel >= 1.0.99.4
-BuildRequires: xorg-lib-libXfont-devel >= 1.4.2
+BuildRequires: xorg-lib-libXfixes-devel
+BuildRequires: xorg-lib-libXfont2-devel >= 2.0.0
 BuildRequires: xorg-lib-libXi-devel >= 1.2.99.1
-BuildRequires: xorg-lib-libXmu-devel
-BuildRequires: xorg-lib-libXpm-devel
+%{?with_dmx:BuildRequires:     xorg-lib-libXmu-devel}
+%{?with_dmx:BuildRequires:     xorg-lib-libXpm-devel}
 BuildRequires: xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXres-devel
-BuildRequires: xorg-lib-libXt-devel >= 1.0.0
+%{?with_dmx:BuildRequires:     xorg-lib-libXt-devel >= 1.0.0}
 BuildRequires: xorg-lib-libXtst-devel >= 1.0.99.2
 BuildRequires: xorg-lib-libXv-devel
 BuildRequires: xorg-lib-libXxf86dga-devel
@@ -93,61 +116,66 @@ BuildRequires:     xorg-lib-libXxf86vm-devel
 BuildRequires: xorg-lib-libfontenc-devel
 BuildRequires: xorg-lib-libpciaccess-devel >= 0.12.901
 BuildRequires: xorg-lib-libxkbfile-devel
-BuildRequires: xorg-lib-libxkbui-devel >= 1.0.2
-BuildRequires: xorg-lib-xtrans-devel >= 1.2.2
+BuildRequires: xorg-lib-libxshmfence-devel >= 1.1
+BuildRequires: xorg-lib-xtrans-devel >= 1.3.5
 BuildRequires: xorg-proto-bigreqsproto-devel >= 1.1.0
 BuildRequires: xorg-proto-compositeproto-devel >= 0.4
 BuildRequires: xorg-proto-damageproto-devel >= 1.1
 %{?with_dmx:BuildRequires:     xorg-proto-dmxproto-devel >= 2.2.99.1}
 %{?with_dri2:BuildRequires:    xorg-proto-dri2proto-devel >= 2.8}
+BuildRequires: xorg-proto-dri3proto-devel >= 1.2
 BuildRequires: xorg-proto-fixesproto-devel >= 5.0
 BuildRequires: xorg-proto-fontcacheproto-devel
-BuildRequires: xorg-proto-fontsproto-devel
-BuildRequires: xorg-proto-glproto-devel >= 1.4.16
+BuildRequires: xorg-proto-fontsproto-devel >= 2.1.3
+BuildRequires: xorg-proto-glproto-devel >= 1.4.17
 BuildRequires: xorg-proto-inputproto-devel >= 2.3
 BuildRequires: xorg-proto-kbproto-devel >= 1.0.3
+BuildRequires: xorg-proto-presentproto-devel >= 1.1
 BuildRequires: xorg-proto-printproto-devel
-BuildRequires: xorg-proto-randrproto-devel >= 1.4.0
+BuildRequires: xorg-proto-randrproto-devel >= 1.6.0
 %{?with_record:BuildRequires:  xorg-proto-recordproto-devel >= 1.13.99.1}
 BuildRequires: xorg-proto-renderproto-devel >= 0.11
 BuildRequires: xorg-proto-resourceproto-devel >= 1.2.0
 BuildRequires: xorg-proto-scrnsaverproto-devel >= 1.1
 BuildRequires: xorg-proto-videoproto-devel
 BuildRequires: xorg-proto-xcmiscproto-devel >= 1.2.0
-BuildRequires: xorg-proto-xextproto-devel >= 1:7.2.0
+BuildRequires: xorg-proto-xextproto-devel >= 1:7.3.0
 %{?with_xf86bigfont:BuildRequires:     xorg-proto-xf86bigfontproto-devel >= 1.2.0}
 BuildRequires: xorg-proto-xf86dgaproto-devel >= 2.0.99.1
 BuildRequires: xorg-proto-xf86driproto-devel >= 2.1.0
 BuildRequires: xorg-proto-xf86miscproto-devel
 BuildRequires: xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
 BuildRequires: xorg-proto-xineramaproto-devel
-BuildRequires: xorg-proto-xproto-devel >= 7.0.22
+BuildRequires: xorg-proto-xproto-devel >= 7.0.31
 BuildRequires: xorg-sgml-doctools >= 1.8
 BuildRequires: xorg-util-util-macros >= 1.14
 #BR: tslib (for KDRIVE only)
 Requires(triggerpostun):       sed >= 4.0
+%{?with_glamor:Requires:       Mesa-libgbm >= 17.1.0}
+Requires:      libdrm >= 2.4.89
+%{?with_glamor:Requires:       libepoxy >= 1.5.4}
 Requires:      pixman >= %{pixman_ver}
+Requires:      udev-libs >= 1:143
 Requires:      xkeyboard-config
 # for rgb.txt
 Requires:      xorg-app-rgb >= 0.99.3
 Requires:      xorg-app-xkbcomp
+Requires:      xorg-lib-libXfont2 >= 2.0.0
+Requires:      xorg-lib-libpciaccess >= 0.12.901
+Requires:      xorg-lib-libxshmfence >= 1.1
+Suggests:      dbus-x11 >= 1.0
 %{?with_hal:Suggests:  hal}
 Suggests:      udev-acl >= 1:143
 %{?with_udev:Suggests: udev-core >= 1:143}
-Suggests:      xorg-driver-input-evdev
-# xserver requires fixed and cursor fonts
-Requires:      xorg-font-font-alias
-Requires:      xorg-font-font-cursor-misc
-Requires:      xorg-font-font-misc-misc-base >= 1.0.0-0.3
-Suggests:      dbus-x11 >= 1.0
 Suggests:      xkeyboard-config
+Suggests:      xorg-driver-input-libinput
 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
 Suggests:      xorg-driver-video
+Provides:      xorg-driver-video-modesetting
 Provides:      xorg-xserver-libdri = %{version}-%{release}
 Provides:      xorg-xserver-module(dri)
 Provides:      xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
 Provides:      xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
-Provides:      xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
 Provides:      xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
 Provides:      xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
 Obsoletes:     X11-Xserver < 1:7.0.0
@@ -158,13 +186,12 @@ Obsoletes:        XFree86-Xserver < 1:7.0.0
 Obsoletes:     XFree86-modules < 1:7.0.0
 Obsoletes:     XFree86-setup < 1:7.0.0
 Obsoletes:     Xserver
+%{?with_glamor:Obsoletes:      glamor}
 Obsoletes:     xorg-xserver-libdri
 Obsoletes:     xorg-xserver-server-xorgcfg
+Obsoletes:     xorg-driver-video-modesetting
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# avoid self-dependencies on included modules
-%define                _noautoreq      libscanpci.so libxf1bpp.so
-
 %description
 Xorg server is a generally used X server which uses display hardware.
 It requires proper driver for your display hardware.
@@ -177,6 +204,12 @@ graficznej. Do działania wymaga odpowiedniego sterownika.
 Summary:       Xdmx - distributed multi-head X server
 Summary(pl.UTF-8):     Xdmx - rozproszony, wielomonitorowy serwer X
 Group:         X11/Servers
+Requires:      pixman >= %{pixman_ver}
+Requires:      xorg-lib-libX11 >= 1.6
+Requires:      xorg-lib-libXext >= 1.0.99.4
+Requires:      xorg-lib-libXfont2 >= 2.0.0
+Requires:      xorg-lib-libXi >= 1.2.99.1
+Requires:      xorg-lib-libdmx >= 1.0.99.1
 
 %description -n xorg-xserver-Xdmx
 Xdmx - distributed multi-head X server.
@@ -188,6 +221,9 @@ Xdmx - rozproszony, wielomonitorowy serwer X.
 Summary:       Xnest - nested X server
 Summary(pl.UTF-8):     Xnest - zagnieżdżony serwer X
 Group:         X11/Servers
+Requires:      pixman >= %{pixman_ver}
+Requires:      xorg-lib-libXext >= 1.0.99.4
+Requires:      xorg-lib-libXfont2 >= 2.0.0
 Obsoletes:     X11-Xnest < 1:7.0.0
 Obsoletes:     XFree86-Xnest < 1:7.0.0
 Obsoletes:     Xserver-Xnest
@@ -219,10 +255,14 @@ Xnest - це сервер X Window System, який працює у вікні X
 Summary:       Xephyr - nested X server
 Summary(pl.UTF-8):     Xephyr - zagnieżdżony serwer X
 Group:         X11/Servers
+Requires:      Mesa-libGL >= 7.1.0
+%{?with_glamor:Requires:       libepoxy >= 1.5.4}
+Requires:      libxcb >= 1.9.3
 Requires:      pixman >= %{pixman_ver}
+Requires:      xorg-lib-libXfont2 >= 2.0.0
 
 %description -n xorg-xserver-Xephyr
-Xephyr is a kdrive server that outputs to a window on a pre-existing
+Xephyr is a kdrive server that outputs to a window on a pre-existing
 'host' X display. Think Xnest but with support for modern extensions
 like composite, damage and randr.
 
@@ -238,30 +278,19 @@ Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
 wspólczesnych rozszerzeń jak composite, damage i randr.
 
-%package -n xorg-xserver-Xfbdev
-Summary:       Xfbdev - Linux framebuffer device X server
-Summary(pl.UTF-8):     Xfbdev - serwer X dla framebuffera
-Group:         X11/Servers
-
-%description -n xorg-xserver-Xfbdev
-Xfbdev is a Linux framebuffer device X server based on the kdrive X
-server.
-
-%description -n xorg-xserver-Xfbdev -l pl.UTF-8
-Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
-
 %package -n xorg-xserver-Xvfb
 Summary:       Xvfb - virtual framebuffer X server
 Summary(pl.UTF-8):     Xvfb - serwer X z wirtualnym framebufferem
 Group:         X11/Servers
+Requires:      Mesa-libGL >= 7.1.0
 Requires:      mktemp
+Requires:      pixman >= %{pixman_ver}
 Requires:      util-linux
 Requires:      which
+Requires:      xkeyboard-config
 Requires:      xorg-app-xauth
-# requires fixed and cursor fonts
-Requires:      xorg-font-font-alias
-Requires:      xorg-font-font-cursor-misc
-Requires:      xorg-font-font-misc-misc-base >= 1.0.0-0.3
+Requires:      xorg-app-xkbcomp
+Requires:      xorg-lib-libXfont2 >= 2.0.0
 Obsoletes:     X11-Xvfb < 1:7.0.0
 Obsoletes:     XFree86-Xvfb < 1:7.0.0
 
@@ -302,29 +331,54 @@ system service.
 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
 usługę systemową.
 
+%package -n xorg-xserver-Xwayland
+Summary:       Xwayland - X server integrated into a Wayland window system
+Summary(pl.UTF-8):     Xwayland - serwer X integrowalny w Wayland
+Group:         X11/Servers
+%{?with_eglstream:Requires:    egl-wayland >= 1.0.2}
+%{?with_glamor:Requires:       libepoxy >= 1.5.4}
+Requires:      pixman >= %{pixman_ver}
+Requires:      xorg-lib-libX11 >= 1.6
+Requires:      xorg-lib-libXext >= 1.0.99.4
+Requires:      xorg-lib-libXfont2 >= 2.0.0
+Requires:      xorg-lib-libXi >= 1.2.99.1
+
+%description -n xorg-xserver-Xwayland
+Xwayland - server integrated into a Wayland window system.
+
+%description -n xorg-xserver-Xwayland -l pl.UTF-8
+Xwayland - serwer X integrowalny w Wayland.
+
 %package devel
 Summary:       Header files for X.org server
 Summary(pl.UTF-8):     Pliki nagłówkowe dla serwera X.org
 Group:         X11/Development/Libraries
-Requires:      libdrm-devel >= 2.4.39
+Requires:      Mesa-libGL-devel >= 7.8.0
+Requires:      libdrm-devel >= 2.4.89
 Requires:      pixman-devel >= %{pixman_ver}
+Requires:      xorg-lib-libXfont2-devel >= 2.0.0
 Requires:      xorg-lib-libpciaccess-devel >= 0.12.901
 Requires:      xorg-lib-libxkbfile-devel
 %{?with_dri2:Requires: xorg-proto-dri2proto-devel >= 2.8}
-Requires:      xorg-proto-fontsproto-devel
+%{?with_dri3:Requires: xorg-proto-dri3proto-devel >= 1.0}
+Requires:      xorg-proto-dri3proto-devel >= 1.0
+Requires:      xorg-proto-fontsproto-devel >= 2.1.3
+Requires:      xorg-proto-glproto-devel >= 1.4.17
 Requires:      xorg-proto-inputproto-devel >= 2.3
 Requires:      xorg-proto-kbproto-devel >= 1.0.3
-Requires:      xorg-proto-randrproto-devel >= 1.4.0
+Requires:      xorg-proto-presentproto-devel >= 1.1
+Requires:      xorg-proto-randrproto-devel >= 1.6.0
 Requires:      xorg-proto-renderproto-devel >= 0.11
 Requires:      xorg-proto-resourceproto-devel >= 1.2.0
 Requires:      xorg-proto-scrnsaverproto-devel >= 1.1
 Requires:      xorg-proto-videoproto-devel
-Requires:      xorg-proto-xextproto-devel >= 1:7.2.0
+Requires:      xorg-proto-xextproto-devel >= 1:7.3.0
 Requires:      xorg-proto-xf86driproto-devel >= 2.1.0
 Requires:      xorg-proto-xineramaproto-devel
-Requires:      xorg-proto-xproto-devel >= 7.0.22
+Requires:      xorg-proto-xproto-devel >= 7.0.31
 Obsoletes:     X11-Xserver-devel < 1:7.0.0
 Obsoletes:     XFree86-Xserver-devel < 1:7.0.0
+%{?with_glamor:Obsoletes:      glamor-devel}
 
 %description devel
 Header files for X.org server.
@@ -348,6 +402,8 @@ Summary:    GLX extension library for X.org server
 Summary(pl.UTF-8):     Biblioteka rozszerzenia GLX dla serwera X.org
 Group:         X11/Servers
 Requires:      %{name} = %{version}-%{release}
+Requires:      Mesa-libGL >= 7.1.0
+%{?with_dri2:Requires: Mesa-libGL >= 9.2.0}
 # Mesa version glapi tables in glx/ dir come from
 Provides:      xorg-xserver-libglx(glapi) = 7.1.0
 Provides:      xorg-xserver-module(glx)
@@ -362,16 +418,11 @@ Biblioteka rozszerzenia GLX dla serwera X.org.
 
 %prep
 %setup -q -n xorg-server-%{version}
-%patch0 -p0
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
+
 %patch4 -p1
-%patch5 -p1
-%patch6 -p1
 
-#unfortunately breaks build
-#patch7 -p1
+%patch6 -p1
 
 # xserver uses pixman-1 API/ABI so put that explictly here
 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
@@ -379,31 +430,28 @@ sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h .
 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
 
+%{__sed} -i -e '1s|#!/usr/bin/python$|#!%{__python}|' config/fdi2iclass.py
+
 %build
 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
-if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
+if [ "$API" != "%{xorg_xserver_server_ansic_abi}" ]; then
        echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
        exit 1
 fi
 
 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
-if [ $API != %{xorg_xserver_server_extension_abi} ]; then
+if [ "$API" != "%{xorg_xserver_server_extension_abi}" ]; then
        echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
        exit 1
 fi
 
-API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
-if [ $API != %{xorg_xserver_server_font_abi} ]; then
-       echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
-       exit 1
-fi
 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
-if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
+if [ "$API" != "%{xorg_xserver_server_videodrv_abi}" ]; then
        echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
        exit 1
 fi
 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
-if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
+if [ "$API" != "%{xorg_xserver_server_xinput_abi}" ]; then
        echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
        exit 1
 fi
@@ -414,30 +462,35 @@ fi
 %{__autoheader}
 %{__automake}
 %configure \
+       --libexecdir=%{_libdir}/xorg \
        --with-os-name="PLD/Linux" \
        --with-os-vendor="PLD/Team" \
        --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
        --with-xkb-output=/var/lib/xkb \
-       %{!?with_systemtap:--without-dtrace} \
-       --without-fop \
-       --enable-aiglx \
+       --disable-linux-acpi \
+       --disable-linux-apm \
        %{?with_dbus:--enable-config-dbus} \
        --enable-config-hal%{!?with_hal:=no} \
        --enable-config-udev%{!?with_udev:=no} \
        --enable-dga \
        %{?with_dmx:--enable-dmx} \
        --enable-dri2%{!?with_dri2:=no} \
-       --enable-glx-tls \
-       --enable-install-libxf86config \
+       --enable-dri3%{!?with_dri3:=no} \
+       %{?with_glamor:--enable-glamor} \
        --enable-kdrive \
+       %{?with_libunwind:--enable-libunwind} \
        %{?with_record:--enable-record} \
        --enable-secure-rpc \
        %{?with_xcsecurity:--enable-xcsecurity} \
        --enable-xephyr \
        %{?with_xf86bigfont:--enable-xf86bigfont} \
-       --disable-xfake \
-       --enable-xfbdev \
-       %{?with_xselinux:--enable-xselinux}
+       %{?with_xselinux:--enable-xselinux} \
+       %{?with_wayland:--enable-xwayland} \
+       %{?with_eglstream:--enable-xwayland-eglstream} \
+       %{!?with_systemtap:--without-dtrace} \
+       --without-fop \
+       --enable-suid-wrapper \
+       --with-systemd-daemon
 
 %{__make}
 
@@ -469,6 +522,19 @@ install -d $RPM_BUILD_ROOT/etc/sysconfig
 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
 
+# Xorg.wrap config
+cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
+# allowed values: rootonly console anybody pam
+allowed_users = pam
+
+# set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
+#needs_root_rights = yes
+EOF
+
+# compatibility with old xwrapper
+ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
+
+# prepare source package
 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
@@ -476,6 +542,10 @@ cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 find -name '*.h' | xargs chmod a-x
 
+%if %{with systemtap}
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -501,7 +571,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc COPYING ChangeLog README
+%doc COPYING ChangeLog README.md
 %attr(755,root,root) %{_bindir}/X
 %attr(755,root,root) %{_bindir}/Xorg
 %attr(4755,root,root) %{_bindir}/Xwrapper
@@ -509,14 +579,24 @@ fi
 %attr(755,root,root) %{_bindir}/gtf
 %dir %{_libdir}/xorg
 %{_libdir}/xorg/protocol.txt
+%attr(755,root,root) %{_libdir}/xorg/Xorg
+%attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
 %dir %{_libdir}/xorg/modules
+%attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
+%{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
+%attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
+%attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
 %dir %{_libdir}/xorg/modules/dri
 %dir %{_libdir}/xorg/modules/drivers
+%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
 %dir %{_libdir}/xorg/modules/extensions
 %dir %{_libdir}/xorg/modules/input
-%dir %{_libdir}/xorg/modules/multimedia
-%attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
-%attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
 %if "%{_libdir}" != "%{_exec_prefix}/lib"
 %dir %{_exec_prefix}/lib/xorg
 %dir %{_exec_prefix}/lib/xorg/modules
@@ -529,15 +609,19 @@ fi
 %config(missingok) /etc/security/console.apps/xserver
 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
 %dir /etc/X11/xorg.conf.d
+%config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
 %dir %{_datadir}/X11/xorg.conf.d
 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
-%verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
+%verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
 %{_mandir}/man1/Xorg.1*
+%{_mandir}/man1/Xorg.wrap.1*
 %{_mandir}/man1/Xserver.1*
 %{_mandir}/man1/cvt.1*
 %{_mandir}/man1/gtf.1*
 %{_mandir}/man4/exa.4*
 %{_mandir}/man4/fbdevhw.4*
+%{_mandir}/man4/modesetting.4*
+%{_mandir}/man5/Xwrapper.config.5*
 %{_mandir}/man5/xorg.conf.5*
 %{_mandir}/man5/xorg.conf.d.5*
 
@@ -572,10 +656,6 @@ fi
 %attr(755,root,root) %{_bindir}/Xephyr
 %{_mandir}/man1/Xephyr.1*
 
-%files -n xorg-xserver-Xfbdev
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/Xfbdev
-
 %files -n xorg-xserver-Xvfb
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/Xvfb
@@ -587,12 +667,16 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
 
+%if %{with wayland}
+%files -n xorg-xserver-Xwayland
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/Xwayland
+%endif
+
 %files devel
 %defattr(644,root,root,755)
 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
 %{_includedir}/xorg
-%{_libdir}/libxf86config.a
-%{_libdir}/libxf86config.la
 %{_aclocaldir}/xorg-server.m4
 %{_pkgconfigdir}/xorg-server.pc
 
This page took 0.066607 seconds and 4 git commands to generate.