]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blame_incremental - xorg-xserver-server.spec
- separated -tools with cvt and gtf; release 4
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
... / ...
CommitLineData
1# TODO
2# - consider XSELINUX by default
3# - Xvfb initscript runs Xvfb as root! add user there!
4#
5# Conditional build:
6%bcond_with dbus # D-BUS support for configuration (if no udev)
7%bcond_with hal # HAL support for configuration (if no udev)
8%bcond_without udev # UDEV support for configuration
9%bcond_without dri2 # DRI2 extension
10%bcond_without dri3 # DRI3 extension
11%bcond_without record # RECORD extension
12%bcond_with xcsecurity # XC-SECURITY extension (deprecated)
13%bcond_with xf86bigfont # XF86BigFont extension
14%bcond_with xselinux # SELinux extension
15%bcond_without dmx # DMX DDX (Xdmx server)
16%bcond_with wayland # Wayland DDX (Xwayland server) [newer version in xorg-xserver-Xwayland.spec]
17%bcond_without xnest # Xnest DDX (Xnest server)
18%bcond_without xvfb # Xvfb DDX (Xvfb server)
19%bcond_without xephyr # kdrive Xephyr server
20%bcond_with eglstream # XWayland eglstream support
21%bcond_without glamor # glamor dix module
22%bcond_without systemtap # systemtap/dtrace probes
23%bcond_without libunwind # use libunwind for backtracing
24#
25# ABI versions, see hw/xfree86/common/xf86Module.h
26%define xorg_xserver_server_ansic_abi 0.4
27%define xorg_xserver_server_extension_abi 10.0
28%define xorg_xserver_server_videodrv_abi 24.1
29%define xorg_xserver_server_xinput_abi 24.1
30
31%define pixman_ver 0.30.0
32
33%ifarch x32
34%undefine with_libunwind
35%endif
36
37Summary: X.org server
38Summary(pl.UTF-8): Serwer X.org
39Name: xorg-xserver-server
40Version: 1.20.11
41Release: 4
42License: MIT
43Group: X11/Servers
44Source0: https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
45# Source0-md5: a22ccd74a5eee721cad6805e489c7144
46Source1: 10-quirks.conf
47Source2: xserver.pamd
48Source10: %{name}-Xvfb.init
49Source11: %{name}-Xvfb.sysconfig
50Source12: xvfb-run.sh
51Patch1: %{name}-xwrapper-pam.patch
52
53Patch4: %{name}-builtin-SHA1.patch
54
55Patch6: 110_nvidia_slowdow_fix.patch
56Patch7: platform_probe_crash.patch
57URL: https://xorg.freedesktop.org/
58BuildRequires: Mesa-dri-devel >= 7.8.1
59%{?with_dri2:BuildRequires: Mesa-dri-devel >= 9.2.0}
60%{?with_glamor:BuildRequires: Mesa-libgbm-devel >= 17.1.0}
61BuildRequires: OpenGL-devel >= 3.0
62# for glx headers
63BuildRequires: OpenGL-GLX-devel >= 1.3
64%{?with_xselinux:BuildRequires: audit-libs-devel}
65BuildRequires: autoconf >= 2.60
66BuildRequires: automake
67BuildRequires: cpp
68BuildRequires: docbook-dtd43-xml
69#BuildRequires: doxygen >= 1.6.1
70%if %{with hal} || %{with dbus}
71BuildRequires: dbus-devel >= 1.0
72%endif
73%{?with_eglstream:BuildRequires: egl-wayland-devel >= 1.0.2}
74%{?with_hal:BuildRequires: hal-devel}
75BuildRequires: libdrm-devel >= 2.4.89
76%if %{with glamor}
77BuildRequires: libepoxy-devel >= 1.5.4
78%endif
79%{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
80BuildRequires: libtirpc-devel
81BuildRequires: libtool >= 2:2.2
82%{?with_libunwind:BuildRequires: libunwind-devel}
83BuildRequires: libxcb-devel >= 1.9.3
84BuildRequires: pam-devel
85BuildRequires: perl-base
86BuildRequires: pixman-devel >= %{pixman_ver}
87BuildRequires: pkgconfig >= 1:0.19
88BuildRequires: pkgconfig(gl) >= 1.2
89%{?with_systemtap:BuildRequires: systemtap-sdt-devel}
90BuildRequires: systemd-devel >= 1:209
91BuildRequires: udev-devel >= 1:143
92# wayland-client
93%{?with_wayland:BuildRequires: wayland-devel >= 1.3.0}
94%{?with_wayland:BuildRequires: wayland-protocols >= 1.10}
95BuildRequires: xcb-util-devel
96BuildRequires: xcb-util-image-devel
97BuildRequires: xcb-util-keysyms-devel
98BuildRequires: xcb-util-renderutil-devel
99BuildRequires: xcb-util-wm-devel
100BuildRequires: xmlto >= 0.0.20
101BuildRequires: xorg-app-mkfontscale
102BuildRequires: xorg-font-font-util >= 1.1
103BuildRequires: xorg-lib-libX11-devel >= 1.6
104BuildRequires: xorg-lib-libXau-devel
105%{?with_dmx:BuildRequires: xorg-lib-libXaw-devel}
106BuildRequires: xorg-lib-libXdamage-devel
107BuildRequires: xorg-lib-libXdmcp-devel
108BuildRequires: xorg-lib-libXext-devel >= 1.0.99.4
109BuildRequires: xorg-lib-libXfixes-devel
110BuildRequires: xorg-lib-libXfont2-devel >= 2.0.0
111BuildRequires: xorg-lib-libXi-devel >= 1.2.99.1
112%{?with_dmx:BuildRequires: xorg-lib-libXmu-devel}
113%{?with_dmx:BuildRequires: xorg-lib-libXpm-devel}
114BuildRequires: xorg-lib-libXrender-devel
115BuildRequires: xorg-lib-libXres-devel
116%{?with_dmx:BuildRequires: xorg-lib-libXt-devel >= 1.0.0}
117BuildRequires: xorg-lib-libXtst-devel >= 1.0.99.2
118BuildRequires: xorg-lib-libXv-devel
119BuildRequires: xorg-lib-libXxf86dga-devel
120BuildRequires: xorg-lib-libXxf86misc-devel
121BuildRequires: xorg-lib-libXxf86vm-devel
122%{?with_dmx:BuildRequires: xorg-lib-libdmx-devel >= 1.0.99.1}
123BuildRequires: xorg-lib-libfontenc-devel
124BuildRequires: xorg-lib-libpciaccess-devel >= 0.12.901
125BuildRequires: xorg-lib-libxkbfile-devel
126BuildRequires: xorg-lib-libxshmfence-devel >= 1.1
127BuildRequires: xorg-lib-xtrans-devel >= 1.3.5
128BuildRequires: xorg-proto-bigreqsproto-devel >= 1.1.0
129BuildRequires: xorg-proto-compositeproto-devel >= 0.4
130BuildRequires: xorg-proto-damageproto-devel >= 1.1
131%{?with_dmx:BuildRequires: xorg-proto-dmxproto-devel >= 2.2.99.1}
132%{?with_dri2:BuildRequires: xorg-proto-dri2proto-devel >= 2.8}
133BuildRequires: xorg-proto-dri3proto-devel >= 1.2
134BuildRequires: xorg-proto-fixesproto-devel >= 5.0
135BuildRequires: xorg-proto-fontcacheproto-devel
136BuildRequires: xorg-proto-fontsproto-devel >= 2.1.3
137BuildRequires: xorg-proto-glproto-devel >= 1.4.17
138BuildRequires: xorg-proto-inputproto-devel >= 2.3
139BuildRequires: xorg-proto-kbproto-devel >= 1.0.3
140BuildRequires: xorg-proto-presentproto-devel >= 1.1
141BuildRequires: xorg-proto-printproto-devel
142BuildRequires: xorg-proto-randrproto-devel >= 1.6.0
143%{?with_record:BuildRequires: xorg-proto-recordproto-devel >= 1.13.99.1}
144BuildRequires: xorg-proto-renderproto-devel >= 0.11
145BuildRequires: xorg-proto-resourceproto-devel >= 1.2.0
146BuildRequires: xorg-proto-scrnsaverproto-devel >= 1.1
147BuildRequires: xorg-proto-videoproto-devel
148BuildRequires: xorg-proto-xcmiscproto-devel >= 1.2.0
149BuildRequires: xorg-proto-xextproto-devel >= 1:7.3.0
150%{?with_xf86bigfont:BuildRequires: xorg-proto-xf86bigfontproto-devel >= 1.2.0}
151BuildRequires: xorg-proto-xf86dgaproto-devel >= 2.0.99.1
152BuildRequires: xorg-proto-xf86driproto-devel >= 2.1.0
153BuildRequires: xorg-proto-xf86miscproto-devel
154BuildRequires: xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
155BuildRequires: xorg-proto-xineramaproto-devel
156BuildRequires: xorg-proto-xproto-devel >= 7.0.31
157BuildRequires: xorg-sgml-doctools >= 1.8
158BuildRequires: xorg-util-util-macros >= 1.14
159%{?with_glamor:Requires: Mesa-libgbm >= 17.1.0}
160Requires: libdrm >= 2.4.89
161%{?with_glamor:Requires: libepoxy >= 1.5.4}
162Requires: pixman >= %{pixman_ver}
163Requires: sed >= 4.0
164Requires: udev-libs >= 1:143
165Requires: xkeyboard-config
166# for rgb.txt
167Requires: xorg-app-rgb >= 0.99.3
168Requires: xorg-app-xkbcomp
169Requires: xorg-lib-libXfont2 >= 2.0.0
170Requires: xorg-lib-libpciaccess >= 0.12.901
171Requires: xorg-lib-libxshmfence >= 1.1
172# for protocol.txt
173Requires: xorg-xserver-common = %{version}-%{release}
174Suggests: %{name}-tools = %{version}-%{release}
175Suggests: dbus-x11 >= 1.0
176%{?with_hal:Suggests: hal}
177Suggests: udev-acl >= 1:143
178%{?with_udev:Suggests: udev-core >= 1:143}
179Suggests: xkeyboard-config
180Suggests: xorg-driver-input-libinput
181# Usual desktop setups need least one video driver to run, see xorg.log which one exactly
182Suggests: xorg-driver-video
183Provides: xorg-driver-video-modesetting
184Provides: xorg-xserver-libdri = %{version}-%{release}
185Provides: xorg-xserver-module(dri)
186Provides: xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
187Provides: xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
188Provides: xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
189Provides: xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
190Obsoletes: X11-Xserver < 1:7.0.0
191Obsoletes: X11-driver-i2c < 1:7.0.0
192Obsoletes: X11-modules < 1:7.0.0
193Obsoletes: X11-setup < 1:7.0.0
194Obsoletes: XFree86-Xserver < 1:7.0.0
195Obsoletes: XFree86-modules < 1:7.0.0
196Obsoletes: XFree86-setup < 1:7.0.0
197Obsoletes: Xserver < 7.0
198%{?with_glamor:Obsoletes: glamor < 0.6.1}
199Obsoletes: xorg-xserver-libdri < 1.12.99
200Obsoletes: xorg-xserver-server-xorgcfg < 1.5.99
201Obsoletes: xorg-driver-video-modesetting < 0.9.1
202BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
203
204%define tirpc_cflags $(pkg-config --cflags libtirpc)
205%define tirpc_libs $(pkg-config --libs libtirpc)
206
207%description
208Xorg server is a generally used X server which uses display hardware.
209It requires proper driver for your display hardware.
210
211%description -l pl.UTF-8
212Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
213graficznej. Do działania wymaga odpowiedniego sterownika.
214
215%package tools
216Summary: Tools to calculate modelines for X.org server
217Summary(pl.UTF-8): Narzędzia do liczenia opisów trybów graficznych (modeline) dla serwera X.org
218Group: X11/Applications
219Conflicts: xorg-xserver-server < 1.20.11-4
220
221%description tools
222Tools to calculate modelines for X.org server (using Coordinated Video
223Timing or Generalized Timing Formula).
224
225%description tools -l pl.UTF-8
226Narzędzia do liczenia opisów trybów graficznych (modeline) dla serwera
227X.org (przy użyciu algorytmów Coordinated Video Timing lub
228Generalizaed Timing Formula).
229
230%package devel
231Summary: Header files for X.org server
232Summary(pl.UTF-8): Pliki nagłówkowe dla serwera X.org
233Group: X11/Development/Libraries
234Requires: Mesa-dri-devel >= 7.8.0
235Requires: libdrm-devel >= 2.4.89
236Requires: pixman-devel >= %{pixman_ver}
237Requires: xorg-lib-libXfont2-devel >= 2.0.0
238Requires: xorg-lib-libpciaccess-devel >= 0.12.901
239Requires: xorg-lib-libxkbfile-devel
240%{?with_dri2:Requires: xorg-proto-dri2proto-devel >= 2.8}
241%{?with_dri3:Requires: xorg-proto-dri3proto-devel >= 1.0}
242Requires: xorg-proto-dri3proto-devel >= 1.0
243Requires: xorg-proto-fontsproto-devel >= 2.1.3
244Requires: xorg-proto-glproto-devel >= 1.4.17
245Requires: xorg-proto-inputproto-devel >= 2.3
246Requires: xorg-proto-kbproto-devel >= 1.0.3
247Requires: xorg-proto-presentproto-devel >= 1.1
248Requires: xorg-proto-randrproto-devel >= 1.6.0
249Requires: xorg-proto-renderproto-devel >= 0.11
250Requires: xorg-proto-resourceproto-devel >= 1.2.0
251Requires: xorg-proto-scrnsaverproto-devel >= 1.1
252Requires: xorg-proto-videoproto-devel
253Requires: xorg-proto-xextproto-devel >= 1:7.3.0
254Requires: xorg-proto-xf86driproto-devel >= 2.1.0
255Requires: xorg-proto-xineramaproto-devel
256Requires: xorg-proto-xproto-devel >= 7.0.31
257Obsoletes: X11-Xserver-devel < 1:7.0.0
258Obsoletes: XFree86-Xserver-devel < 1:7.0.0
259%{?with_glamor:Obsoletes: glamor-devel < 0.6.1}
260
261%description devel
262Header files for X.org server.
263
264%description devel -l pl.UTF-8
265Pliki nagłówkowe dla serwera X.org.
266
267%package source
268Summary: X.org server source code
269Summary(pl.UTF-8): Pliki źródłowe dla serwera X.org
270Group: X11/Development/Libraries
271
272%description source
273X.org server source code.
274
275%description source -l pl.UTF-8
276Pliki źródłowe dla serwera X.org.
277
278%package -n xorg-xserver-libglx
279Summary: GLX extension library for X.org server
280Summary(pl.UTF-8): Biblioteka rozszerzenia GLX dla serwera X.org
281Group: X11/Servers
282Requires: %{name} = %{version}-%{release}
283Requires: OpenGL >= 1.2
284# Mesa version glapi tables in glx/ dir come from
285Provides: xorg-xserver-libglx(glapi) = 7.1.0
286Provides: xorg-xserver-module(glx)
287Obsoletes: X11-OpenGL-core < 1:7.0.0
288Obsoletes: XFree86-OpenGL-core < 1:7.0.0
289
290%description -n xorg-xserver-libglx
291GLX extension library for X.org server.
292
293%description -n xorg-xserver-libglx -l pl.UTF-8
294Biblioteka rozszerzenia GLX dla serwera X.org.
295
296%package -n xorg-xserver-Xdmx
297Summary: Xdmx - distributed multi-head X server
298Summary(pl.UTF-8): Xdmx - rozproszony, wielomonitorowy serwer X
299Group: X11/Servers
300Requires: pixman >= %{pixman_ver}
301Requires: xorg-lib-libX11 >= 1.6
302Requires: xorg-lib-libXext >= 1.0.99.4
303Requires: xorg-lib-libXfont2 >= 2.0.0
304Requires: xorg-lib-libXi >= 1.2.99.1
305Requires: xorg-lib-libdmx >= 1.0.99.1
306
307%description -n xorg-xserver-Xdmx
308Xdmx - distributed multi-head X server.
309
310%description -n xorg-xserver-Xdmx -l pl.UTF-8
311Xdmx - rozproszony, wielomonitorowy serwer X.
312
313%package -n xorg-xserver-Xephyr
314Summary: Xephyr - nested X server
315Summary(pl.UTF-8): Xephyr - zagnieżdżony serwer X
316Group: X11/Servers
317Requires: OpenGL >= 3.0
318%{?with_glamor:Requires: libepoxy >= 1.5.4}
319Requires: libxcb >= 1.9.3
320Requires: pixman >= %{pixman_ver}
321Requires: xorg-lib-libXfont2 >= 2.0.0
322
323%description -n xorg-xserver-Xephyr
324Xephyr is a kdrive server that outputs to a window on a pre-existing
325'host' X display. Think Xnest but with support for modern extensions
326like composite, damage and randr.
327
328Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
329the host X server, Xephyr is a real X server which uses the host X
330server window as "framebuffer" via fast SHM XImages.
331
332It also has support for 'visually' debugging what the server is
333painting.
334
335%description -n xorg-xserver-Xephyr -l pl.UTF-8
336Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
337istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
338wspólczesnych rozszerzeń jak composite, damage i randr.
339
340%package -n xorg-xserver-Xnest
341Summary: Xnest - nested X server
342Summary(pl.UTF-8): Xnest - zagnieżdżony serwer X
343Group: X11/Servers
344Requires: pixman >= %{pixman_ver}
345Requires: xorg-lib-libXext >= 1.0.99.4
346Requires: xorg-lib-libXfont2 >= 2.0.0
347Obsoletes: X11-Xnest < 1:7.0.0
348Obsoletes: XFree86-Xnest < 1:7.0.0
349Obsoletes: Xserver-Xnest < 7.0
350
351%description -n xorg-xserver-Xnest
352Xnest is an X Window System server which runs in an X window. Xnest is
353a 'nested' window server, actually a client of the real X server,
354which manages windows and graphics requests for Xnest, while Xnest
355manages the windows and graphics requests for its own clients.
356
357%description -n xorg-xserver-Xnest -l pl.UTF-8
358Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
359zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
360serwer X dla własnych klientów.
361
362%description -n xorg-xserver-Xnest -l ru.UTF-8
363Xnest - это сервер X Window System, который работает в окне X. На
364самом деле это клиент реального X-сервера, который управляет окнами и
365графическими запросами для Xnest в то время, как Xnest управляет
366окнами и графическими запросами для своих собственных клиентов.
367
368%description -n xorg-xserver-Xnest -l uk.UTF-8
369Xnest - це сервер X Window System, який працює у вікні X. Фактично це
370клієнт реального X-сервера, який керує вікнами та графічними запитами
371для Xnest в той час, як Xnest керує вікнами та графічними запитами для
372своїх власних клієнтів.
373
374%package -n xorg-xserver-Xvfb
375Summary: Xvfb - virtual framebuffer X server
376Summary(pl.UTF-8): Xvfb - serwer X z wirtualnym framebufferem
377Group: X11/Servers
378Requires: OpenGL >= 1.2.1
379Requires: mktemp
380Requires: pixman >= %{pixman_ver}
381Requires: util-linux
382Requires: which
383Requires: xkeyboard-config
384Requires: xorg-app-xauth
385Requires: xorg-app-xkbcomp
386Requires: xorg-lib-libXfont2 >= 2.0.0
387Obsoletes: X11-Xvfb < 1:7.0.0
388Obsoletes: XFree86-Xvfb < 1:7.0.0
389
390%description -n xorg-xserver-Xvfb
391Xvfb (X Virtual Frame Buffer) is an X Window System server that is
392capable of running on machines with no display hardware and no
393physical input devices. Xvfb emulates a dumb framebuffer using virtual
394memory. Xvfb doesn't open any devices, but behaves otherwise as an X
395display. Xvfb is normally used for testing servers. Using Xvfb, the
396mfb or cfb code for any depth can be exercised without using real
397hardware that supports the desired depths. Xvfb has also been used to
398test X clients against unusual depths and screen configurations, to do
399batch processing with Xvfb as a background rendering engine, to do
400load testing, to help with porting an X server to a new platform, and
401to provide an unobtrusive way of running applications which really
402don't need an X server but insist on having one.
403
404%description -n xorg-xserver-Xvfb -l pl.UTF-8
405Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
406na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
407wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
408używany do testowania serwerów X, może też być używany do testowania
409klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
410Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
411serwera X, ale odmawiają uruchomienia bez niego.
412
413%package -n xorg-xserver-Xvfb-init
414Summary: Init scripts for Xvfb
415Summary(pl.UTF-8): Skrypty startowe dla Xvfb
416Group: X11/Servers
417Requires: xorg-xserver-Xvfb = %{version}-%{release}
418
419%description -n xorg-xserver-Xvfb-init
420This package contains init scripts for Xvfb and registers Xvfb as
421system service.
422
423%description -n xorg-xserver-Xvfb-init -l pl.UTF-8
424Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
425usługę systemową.
426
427%package -n xorg-xserver-Xwayland
428Summary: Xwayland - X server integrated into a Wayland window system
429Summary(pl.UTF-8): Xwayland - serwer X integrowalny w Wayland
430Group: X11/Servers
431%{?with_eglstream:Requires: egl-wayland >= 1.0.2}
432%{?with_glamor:Requires: libepoxy >= 1.5.4}
433Requires: pixman >= %{pixman_ver}
434Requires: xorg-lib-libX11 >= 1.6
435Requires: xorg-lib-libXext >= 1.0.99.4
436Requires: xorg-lib-libXfont2 >= 2.0.0
437Requires: xorg-lib-libXi >= 1.2.99.1
438# for protocol.txt
439Requires: xorg-xserver-common = %{version}-%{release}
440
441%description -n xorg-xserver-Xwayland
442Xwayland - server integrated into a Wayland window system.
443
444%description -n xorg-xserver-Xwayland -l pl.UTF-8
445Xwayland - serwer X integrowalny w Wayland.
446
447%package -n xorg-xserver-common
448Summary: Common files for various X servers
449Summary(pl.UTF-8): Pliki wspólne dla serwerów X
450Group: X11/Servers
451Conflicts: xorg-xserver-server < 1.20.11-2
452
453%description -n xorg-xserver-common
454Common files for various X servers.
455
456%description -n xorg-xserver-common -l pl.UTF-8
457Pliki wspólne dla serwerów X.
458
459%prep
460%setup -q -n xorg-server-%{version}
461%patch1 -p1
462
463%patch4 -p1
464
465%patch6 -p1
466%patch7 -p1
467
468# xserver uses pixman-1 API/ABI so put that explictly here
469sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
470
471# support __filemansuffix__ with "x" suffix (per FHS 2.3)
472%{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
473
474%{__sed} -i -e '1s|#!/usr/bin/python$|#!%{__python}|' config/fdi2iclass.py
475
476%build
477API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
478if [ "$API" != "%{xorg_xserver_server_ansic_abi}" ]; then
479 echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
480 exit 1
481fi
482
483API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
484if [ "$API" != "%{xorg_xserver_server_extension_abi}" ]; then
485 echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
486 exit 1
487fi
488
489API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
490if [ "$API" != "%{xorg_xserver_server_videodrv_abi}" ]; then
491 echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
492 exit 1
493fi
494API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
495if [ "$API" != "%{xorg_xserver_server_xinput_abi}" ]; then
496 echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
497 exit 1
498fi
499
500%{__libtoolize}
501%{__aclocal} -I m4
502%{__autoconf}
503%{__autoheader}
504%{__automake}
505%configure \
506 CPPFLAGS="%{rpmcppflags} %{tirpc_cflags}" \
507 LIBS="%{tirpc_libs}" \
508 --libexecdir=%{_libdir}/xorg \
509 --with-os-name="PLD/Linux" \
510 --with-os-vendor="PLD/Team" \
511 --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
512 --with-xkb-output=/var/lib/xkb \
513 --disable-linux-acpi \
514 --disable-linux-apm \
515 %{?with_dbus:--enable-config-dbus} \
516 --enable-config-hal%{!?with_hal:=no} \
517 --enable-config-udev%{!?with_udev:=no} \
518 --enable-dga \
519 %{?with_dmx:--enable-dmx} \
520 --enable-dri2%{!?with_dri2:=no} \
521 --enable-dri3%{!?with_dri3:=no} \
522 %{?with_glamor:--enable-glamor} \
523 --enable-kdrive \
524 %{?with_libunwind:--enable-libunwind} \
525 %{?with_record:--enable-record} \
526 --enable-secure-rpc \
527 --enable-suid-wrapper \
528 %{?with_xcsecurity:--enable-xcsecurity} \
529 --enable-xephyr%{!?with_xephyr:=no} \
530 %{?with_xf86bigfont:--enable-xf86bigfont} \
531 --enable-xnest%{!?with_xnest:=no} \
532 %{?with_xselinux:--enable-xselinux} \
533 %{!?with_xvfb:--disable-xvfb} \
534 --enable-xwayland%{!?with_wayland:=no} \
535 %{?with_eglstream:--enable-xwayland-eglstream} \
536 %{!?with_systemtap:--without-dtrace} \
537 --without-fop \
538 --with-systemd-daemon
539
540%{__make}
541
542%install
543rm -rf $RPM_BUILD_ROOT
544
545%if "%{_libdir}" != "%{_exec_prefix}/lib"
546install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
547%endif
548
549%{__make} install \
550 DESTDIR=$RPM_BUILD_ROOT
551
552install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
553install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
554install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
555install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
556install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
557
558:> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
559:> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
560
561%{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
562
563cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
564
565%if %{with xvfb}
566install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
567install -d $RPM_BUILD_ROOT/etc/sysconfig
568install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
569cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
570%endif
571
572# Xorg.wrap config
573cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
574# allowed values: rootonly console anybody pam
575allowed_users = pam
576
577# set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
578#needs_root_rights = yes
579EOF
580
581# compatibility with old xwrapper
582ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
583
584# prepare source package
585install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
586cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
587cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
588%{__make} distclean
589find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
590find -name '*.h' | xargs chmod a-x
591
592%if %{with systemtap}
593%{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
594%endif
595
596%clean
597rm -rf $RPM_BUILD_ROOT
598
599%triggerpostun -- xorg-xserver-server < 1.5.0
600if [ -f /etc/X11/xorg.conf ]; then
601 sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
602 sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
603%if %{without record}
604 sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
605%endif
606 sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
607fi
608
609%post -n xorg-xserver-Xvfb-init
610/sbin/chkconfig --add Xvfb
611%service Xvfb restart
612
613%preun -n xorg-xserver-Xvfb-init
614if [ "$1" = "0" ]; then
615 %service -q Xvfb stop
616 /sbin/chkconfig --del Xvfb
617fi
618
619%files
620%defattr(644,root,root,755)
621%doc COPYING ChangeLog README.md
622%attr(755,root,root) %{_bindir}/X
623%attr(755,root,root) %{_bindir}/Xorg
624%attr(4755,root,root) %{_bindir}/Xwrapper
625%attr(755,root,root) %{_libdir}/xorg/Xorg
626%attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
627%dir %{_libdir}/xorg/modules
628%attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
629%attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
630%attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
631%{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
632%attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
633%attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
634%attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
635%attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
636%attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
637%attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
638%dir %{_libdir}/xorg/modules/dri
639%dir %{_libdir}/xorg/modules/drivers
640%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
641%dir %{_libdir}/xorg/modules/extensions
642%dir %{_libdir}/xorg/modules/input
643%if "%{_libdir}" != "%{_exec_prefix}/lib"
644%dir %{_exec_prefix}/lib/xorg
645%dir %{_exec_prefix}/lib/xorg/modules
646%dir %{_exec_prefix}/lib/xorg/modules/dri
647%endif
648%dir /var/lib/xkb
649/var/lib/xkb/README.compiled
650%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
651%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
652%config(missingok) /etc/security/console.apps/xserver
653%{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
654%dir /etc/X11/xorg.conf.d
655%config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
656%dir %{_datadir}/X11/xorg.conf.d
657# overwrite these settings with local configs in /etc/X11/xorg.conf.d
658%verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
659%{_mandir}/man1/Xorg.1*
660%{_mandir}/man1/Xorg.wrap.1*
661%{_mandir}/man4/exa.4*
662%{_mandir}/man4/fbdevhw.4*
663%{_mandir}/man4/modesetting.4*
664%{_mandir}/man5/Xwrapper.config.5*
665%{_mandir}/man5/xorg.conf.5*
666%{_mandir}/man5/xorg.conf.d.5*
667
668%files tools
669%defattr(644,root,root,755)
670%attr(755,root,root) %{_bindir}/cvt
671%attr(755,root,root) %{_bindir}/gtf
672%{_mandir}/man1/cvt.1*
673%{_mandir}/man1/gtf.1*
674
675%files devel
676%defattr(644,root,root,755)
677%doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
678%{_includedir}/xorg
679%{_aclocaldir}/xorg-server.m4
680%{_pkgconfigdir}/xorg-server.pc
681
682%files source
683%defattr(644,root,root,755)
684# keep file perms from install time, but have default defattr to keep adapter happy
685%defattr(-,root,root,755)
686%{_usrsrc}/%{name}-%{version}
687
688%files -n xorg-xserver-libglx
689%defattr(644,root,root,755)
690%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
691
692%if %{with dmx}
693%files -n xorg-xserver-Xdmx
694%defattr(644,root,root,755)
695%attr(755,root,root) %{_bindir}/Xdmx
696%attr(755,root,root) %{_bindir}/dmxaddinput
697%attr(755,root,root) %{_bindir}/dmxaddscreen
698%attr(755,root,root) %{_bindir}/dmxinfo
699%attr(755,root,root) %{_bindir}/dmxreconfig
700%attr(755,root,root) %{_bindir}/dmxresize
701%attr(755,root,root) %{_bindir}/dmxrminput
702%attr(755,root,root) %{_bindir}/dmxrmscreen
703%attr(755,root,root) %{_bindir}/dmxtodmx
704%attr(755,root,root) %{_bindir}/dmxwininfo
705%attr(755,root,root) %{_bindir}/vdltodmx
706%attr(755,root,root) %{_bindir}/xdmxconfig
707%{_mandir}/man1/Xdmx.1*
708%{_mandir}/man1/dmxtodmx.1*
709%{_mandir}/man1/vdltodmx.1*
710%{_mandir}/man1/xdmxconfig.1*
711%endif
712
713%if %{with xephyr}
714%files -n xorg-xserver-Xephyr
715%defattr(644,root,root,755)
716%attr(755,root,root) %{_bindir}/Xephyr
717%{_mandir}/man1/Xephyr.1*
718%endif
719
720%if %{with xnest}
721%files -n xorg-xserver-Xnest
722%defattr(644,root,root,755)
723%attr(755,root,root) %{_bindir}/Xnest
724%{_mandir}/man1/Xnest.1*
725%endif
726
727%if %{with xvfb}
728%files -n xorg-xserver-Xvfb
729%defattr(644,root,root,755)
730%attr(755,root,root) %{_bindir}/Xvfb
731%attr(755,root,root) %{_bindir}/xvfb-run
732%{_mandir}/man1/Xvfb.1*
733
734%files -n xorg-xserver-Xvfb-init
735%defattr(644,root,root,755)
736%attr(754,root,root) /etc/rc.d/init.d/Xvfb
737%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
738%endif
739
740%if %{with wayland}
741%files -n xorg-xserver-Xwayland
742%defattr(644,root,root,755)
743%attr(755,root,root) %{_bindir}/Xwayland
744%endif
745
746%files -n xorg-xserver-common
747%defattr(644,root,root,755)
748%dir %{_libdir}/xorg
749%{_libdir}/xorg/protocol.txt
750%{_mandir}/man1/Xserver.1*
This page took 0.039795 seconds and 4 git commands to generate.