]> git.pld-linux.org Git - packages/xbase.git/blobdiff - xbase.spec
- x32 rebuild
[packages/xbase.git] / xbase.spec
index a661c6988b43dcee33bfd0d941326c6223671ba5..eb5ef3f46a504cac94c2c3345e7a0ed355e83a5a 100644 (file)
@@ -1,60 +1,93 @@
-Summary:       Xbase DBMS Library
-Summary(pl):   Xbase - biblioteka dla ró¿nych baz danych
+Summary:       XBase - xbase-compatible C++ class library
+Summary(pl.UTF-8):     XBase - kompatybilna z xbase biblioteka klas C++
 Name:          xbase
-Version:       2.0.0
-Release:       1
-License:       LGPL
+Version:       2.1.1
+Release:       6
+License:       LGPL v2.1+ (library), GPL v2+ (programs)
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/xdb/%{name}-%{version}.tar.gz
-# Source0-md5: 9b29362031716a12491beb9f8cc882f2
+Source0:       http://downloads.sourceforge.net/xdb/%{name}-%{version}.tar.gz
+# Source0-md5: f36852f0ba0c4d9e047e84c3269fde37
+Patch0:                %{name}-fix.patch
+Patch1:                %{name}-gcc4.patch
+Patch2:                %{name}-am.patch
 URL:           http://linux.techass.com/projects/xdb/
+BuildRequires: autoconf >= 2.52
+BuildRequires: automake
 BuildRequires: libstdc++-devel
+BuildRequires: libtool >= 2:1.4d
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-This product provides C and C++ programmers a class and function
-library for manipulating Xbase type datafiles and indices. This
-project was formerly known as Xbase for Linux, but as I have recieved
-input from several people who are compiling this on platforms other
-than Linux, I have renamed it to Xbase DBMS. The main development of
-this library however, remains on the Linux platform utilizing the GCC
-public domain C/C++ compiler.
-
-XBase DBMS currently includes routines to support multi-user access
-for .DBF databases, fields, Dbase III and IV memo fields (variable
-length fields), dates, record and file locking and (.NDX) indices. As
-of release 1.7.4, Xbase is compatible with dBASE III data, index and
-memo fields and also has support for some dBASE IV features.
-
-%description -l pl
-Bibliotek zawieraj±ca zespó³ procedur i funkcji pozwalaj±cych na
-podstawowe operacje na na formacie danych dBASE III i czê¶ciowo
-dBASE IV.
-
-Bazowo projekt powstawa³ pod Linuksa ale obecnie jest u¿ywany na wielu
-platformach.
+XBase is an xbase (i.e. dBase, FoxPro, etc.) compatible C++ class
+library. It's useful for accessing data in legacy dBase 3 and 4
+database files as well as a general light-weight database engine. It
+includes support for DBF (dBase version 3 and 4) data files, NDX and
+NTX indexes, and DBT (dBase version 3 and 4). It supports file and
+record locking under *nix OSes.
+
+%description -l pl.UTF-8
+XBase to kompatybilna z xbase (czyli dBase, FoxPro itp.) biblioteka
+klas C++. Jest przydatna do dostępu do danych w plikach starych baz
+dBase 3 i 4, a także jako lekki silnik baz danych ogólnego
+przeznaczenia. Obsługuje pliki baz DBF (dBase w wersji 3 i 4), indeksy
+NDX i NTX oraz DBT (dBase w wersji 3 i 4). Obsługuje blokowanie
+plików i rekordów pod systemami uniksowymi.
 
 %package devel
-Summary:       Xbase development files
-Summary(pl):   Xbase dla programistów
+Summary:       XBase development files
+Summary(pl.UTF-8):     Pliki dla programistów używających XBase
+License:       LGPL v2.1+
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      libstdc++-devel
 
 %description devel
-Xbase development files.
+This package contains XBase development files.
+
+%description devel -l pl.UTF-8
+Ten pakiet zawiera pliki nagłówkowe potrzebne przy tworzeniu
+aplikacji używających Xbase.
+
+%package static
+Summary:       Static XBase library
+Summary(pl.UTF-8):     Statyczna biblioteka XBase
+License:       LGPL v2.1+
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static XBase library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka XBase.
+
+%package tools
+Summary:       XBase utilities for xbase files
+Summary(pl.UTF-8):     XBase - narzędzia do plików xbase
+License:       GPL v2+
+Group:         Applications/File
+Requires:      %{name} = %{version}-%{release}
+
+%description tools
+XBase utilities for xbase files.
 
-%description devel -l pl
-Zawiera pliki nag³ówkowe potrzebne przy tworzeniu oprogramowania
-aplikacji u¿ywaj±cych Xbase.
+%description tools -l pl.UTF-8
+XBase - narzędzia do plików xbase.
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
-CPPFLAGS="%{rpmcflags} -fno-rtti -fno-implicit-templates"
-export CPPFLAGS
-%configure2_13 \
-       --enable-nls \
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+CXXFLAGS="%{rpmcflags} -fno-implicit-templates"
+%configure \
        --with-exceptions \
        --with-index-ndx \
        --with-index-ntx
@@ -63,24 +96,43 @@ export CPPFLAGS
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} DESTDIR=$RPM_BUILD_ROOT install
-
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog TODO AUTHORS NEWS README
-%attr(755,root,root) %{_bindir}/[^x]*
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%doc AUTHORS ChangeLog NEWS README TODO
+%attr(755,root,root) %{_libdir}/libxbase.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libxbase.so.1
 
 %files devel
 %defattr(644,root,root,755)
-%doc html/{*.html,*.gif,*.jpg}
+%doc html/{*.html,*.jpg}
 %attr(755,root,root) %{_bindir}/xbase-config
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
+%attr(755,root,root) %{_libdir}/libxbase.so
+%{_libdir}/libxbase.la
 %{_includedir}/xbase
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libxbase.a
+
+%files tools
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/checkndx
+%attr(755,root,root) %{_bindir}/copydbf
+%attr(755,root,root) %{_bindir}/dbfutil1
+%attr(755,root,root) %{_bindir}/dbfxtrct
+%attr(755,root,root) %{_bindir}/deletall
+%attr(755,root,root) %{_bindir}/dumphdr
+%attr(755,root,root) %{_bindir}/dumprecs
+%attr(755,root,root) %{_bindir}/packdbf
+%attr(755,root,root) %{_bindir}/reindex
+%attr(755,root,root) %{_bindir}/undelall
+%attr(755,root,root) %{_bindir}/zap
This page took 0.080767 seconds and 4 git commands to generate.