]> git.pld-linux.org Git - packages/xavs.git/blame - xavs.spec
- disable asm on x86_64
[packages/xavs.git] / xavs.spec
CommitLineData
1cb0dba9
JB
1#
2# Conditional build:
3%bcond_without asm # MMX/SSE* x86 assembler optimizations
4
71d7fb7f
JB
5%ifnarch %{ix86}
6# %{x8664} misses GOT code in i386inc.asm
1cb0dba9
JB
7%undefine with_asm
8%endif
8e8aed12
JB
9Summary: Audio Video Standard of China library
10Summary(pl.UTF-8): Biblioteka kodeka AVS (Audio Video Standard of China)
11Name: xavs
12Version: 0
1cb0dba9 13%define svnver 55
2bc3b3a6 14Release: 0.svn%{svnver}.2
8e8aed12
JB
15License: GPL v2+
16Group: Libraries
17# svn co https://xavs.svn.sourceforge.net/svnroot/xavs/trunk xavs
18Source0: %{name}-r%{svnver}.tar.xz
1cb0dba9 19# Source0-md5: c4f73561424d850a5c59ef202d85f0d7
8e8aed12 20Patch0: %{name}-dynamic-xavs.patch
1cb0dba9
JB
21Patch1: %{name}-asm.patch
22URL: http://xavs.sourceforge.net/
8e8aed12
JB
23BuildRequires: tar >= 1:1.22
24# for svnversion
25BuildRequires: subversion
26BuildRequires: xz
1cb0dba9
JB
27%if %{with asm}
28BuildRequires: binutils >= 2:2.17
29BuildRequires: yasm >= 0.6.1
8e8aed12
JB
30%endif
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34AVS is the Audio Video Standard of China. This project aims to
35implement high quality AVS encoder and decoder.
36
37%description -l pl.UTF-8
38AVS (Audio Video Standard of China) to standardowy kodek A/V dla Chin.
39Celem projektu jest zaimplementowanie wysokiej jakości kodera i
40dekodera AVS.
41
42%package devel
43Summary: Header files for AVS library
44Summary(pl.UTF-8): Pliki nagłówkowe biblioteki AVS
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47
48%description devel
49Header files for AVS library.
50
51%description devel -l pl.UTF-8
52Pliki nagłówkowe biblioteki AVS.
53
54%package static
55Summary: Static AVS library
56Summary(pl.UTF-8): Statyczna biblioteka AVS
57Group: Development/Libraries
58Requires: %{name}-devel = %{version}-%{release}
59
60%description static
61Static AVS library.
62
63%description static -l pl.UTF-8
64Statyczna biblioteka AVS.
65
66%prep
67%setup -q -n %{name}
68%patch0 -p1
1cb0dba9 69%patch1 -p1
8e8aed12
JB
70
71%build
72# not autoconf script
73./configure \
74 --prefix=%{_prefix} \
75 --libdir=%{_libdir} \
f329f731 76 %{?with_asm:--enable-asm}%{!?with_asm:--disable-asm} \
8e8aed12
JB
77 --enable-shared \
78 --extra-cflags="%{rpmcflags} %{rpmcppflags} -fno-strict-aliasing" \
79 --extra-ldflags="%{rpmldflags}"
8e8aed12
JB
80
81# linking hack
82ln -sf libxavs.so.1 libxavs.so
83
84%{__make} default libxavs.a \
85 CC="%{__cc}"
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90%{__make} install \
91 DESTDIR=$RPM_BUILD_ROOT
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%post -p /sbin/ldconfig
97%postun -p /sbin/ldconfig
98
99%files
100%defattr(644,root,root,755)
101%attr(755,root,root) %{_bindir}/xavs
102%attr(755,root,root) %{_libdir}/libxavs.so.1
103
104%files devel
105%defattr(644,root,root,755)
106%attr(755,root,root) %{_libdir}/libxavs.so
107%{_includedir}/xavs.h
108%{_pkgconfigdir}/xavs.pc
109
110%files static
111%defattr(644,root,root,755)
112%{_libdir}/libxavs.a
This page took 0.124185 seconds and 4 git commands to generate.