]> git.pld-linux.org Git - packages/widelands.git/blame_incremental - widelands.spec
- BR: lua51-devel, python, python-modules
[packages/widelands.git] / widelands.spec
... / ...
CommitLineData
1#
2# TODO:
3# - create bcond for ggz
4#
5%define buildver 15
6Summary: Game like Settlers II
7Summary(pl.UTF-8): Remake gry Settlers II
8Name: widelands
9Version: 0.build%{buildver}
10Release: 1
11License: GPL v2+
12Group: X11/Applications/Games
13Source0: http://launchpad.net/widelands/build%{buildver}/build%{buildver}/+download/%{name}-build%{buildver}-src.tar.bz2
14# Source0-md5: 5b2e2d0913272f66055e424f91360b1d
15Source1: %{name}.desktop
16Patch0: %{name}-locale.patch
17Patch1: %{name}-gcc-4.5.patch
18URL: http://widelands.sourceforge.net/
19BuildRequires: SDL-devel >= 1.2.11
20BuildRequires: SDL_gfx-devel
21BuildRequires: SDL_image-devel
22BuildRequires: SDL_mixer-devel >= 1.2.7
23BuildRequires: SDL_net-devel
24BuildRequires: SDL_ttf-devel >= 2.0.0
25BuildRequires: boost-devel >= 1.35
26BuildRequires: cmake
27BuildRequires: gettext-devel
28BuildRequires: libjpeg-devel
29BuildRequires: libpng-devel
30BuildRequires: libstdc++-devel
31BuildRequires: libtiff-devel
32BuildRequires: lua51-devel
33BuildRequires: python
34BuildRequires: python-modules
35Requires: SDL_image >= 1.2.10
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39In Widelands, you are the regent of a small tribe. You start out with
40nothing but your headquarters, a kind of castle in which all your
41resources are stored. Every member of your tribe will do his or her
42part to produce more resources - wood, food, iron, gold and more - to
43further this growth. But you are not alone in the world, and you will
44meet other tribes sooner or later. Some of them may be friendly and
45trade with you. However, if you want to rule the world, you will have
46to train soldiers and fight.
47
48%description -l pl.UTF-8
49W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
50grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
51przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
52wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
53żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
54nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
55spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
56nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
57światem, będziesz musiał wyszkolić żołnierzy i walczyć.
58
59%prep
60%setup -q -n %{name}-build%{buildver}-src
61%patch0 -p1
62%patch1 -p1
63
64%build
65install -d build
66cd build
67%cmake \
68 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
69 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
70 -DWL_INSTALL_BINDIR=%{_bindir} \
71 -DWL_INSTALL_DATADIR=%{_datadir}/games/%{name} \
72 -DWL_INSTALL_LOCALEDIR=%{_datadir}/games/%{name}/locale \
73%if "%{_lib}" == "lib64"
74 -DLIB_SUFFIX=64 \
75%endif
76 ..
77
78%{__make}
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
83%{__make} -C build install \
84 DESTDIR=$RPM_BUILD_ROOT
85
86install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
87
88install pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
89cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(644,root,root,755)
96%doc ChangeLog CREDITS
97%attr(755,root,root) %{_bindir}/%{name}
98%dir %{_datadir}/games/%{name}
99%{_datadir}/games/%{name}/VERSION
100%{_datadir}/games/%{name}/campaigns
101%{_datadir}/games/%{name}/fonts
102%{_datadir}/games/%{name}/global
103%{_datadir}/games/%{name}/maps
104%{_datadir}/games/%{name}/music
105%{_datadir}/games/%{name}/pics
106%{_datadir}/games/%{name}/sound
107%{_datadir}/games/%{name}/tribes
108%{_datadir}/games/%{name}/txts
109%{_datadir}/games/%{name}/worlds
110%dir %{_datadir}/games/%{name}/locale
111%lang(ar) %{_datadir}/games/%{name}/locale/ar
112%lang(ca) %{_datadir}/games/%{name}/locale/ca
113%lang(cs) %{_datadir}/games/%{name}/locale/cs
114%lang(da) %{_datadir}/games/%{name}/locale/da
115%lang(de) %{_datadir}/games/%{name}/locale/de
116%lang(en_GB) %{_datadir}/games/%{name}/locale/en_GB
117%lang(eo) %{_datadir}/games/%{name}/locale/eo
118%lang(es) %{_datadir}/games/%{name}/locale/es
119%lang(eu) %{_datadir}/games/%{name}/locale/eu
120%lang(fi) %{_datadir}/games/%{name}/locale/fi
121%lang(fr) %{_datadir}/games/%{name}/locale/fr
122%lang(gl) %{_datadir}/games/%{name}/locale/gl
123%lang(he) %{_datadir}/games/%{name}/locale/he
124%lang(hu) %{_datadir}/games/%{name}/locale/hu
125%lang(ia) %{_datadir}/games/%{name}/locale/ia
126%lang(id) %{_datadir}/games/%{name}/locale/id
127%lang(it) %{_datadir}/games/%{name}/locale/it
128%lang(ja) %{_datadir}/games/%{name}/locale/ja
129%lang(la) %{_datadir}/games/%{name}/locale/la
130%lang(nl) %{_datadir}/games/%{name}/locale/nl
131%lang(nn) %{_datadir}/games/%{name}/locale/nn
132%lang(pl) %{_datadir}/games/%{name}/locale/pl
133%lang(pt_BR) %{_datadir}/games/%{name}/locale/pt_BR
134%lang(ru) %{_datadir}/games/%{name}/locale/ru
135%lang(si) %{_datadir}/games/%{name}/locale/si
136%lang(sk) %{_datadir}/games/%{name}/locale/sk
137%lang(sl) %{_datadir}/games/%{name}/locale/sl
138%lang(sr) %{_datadir}/games/%{name}/locale/sr
139%lang(sv) %{_datadir}/games/%{name}/locale/sv
140%{_desktopdir}/%{name}.desktop
141%{_pixmapsdir}/%{name}.png
This page took 0.068119 seconds and 4 git commands to generate.