]> git.pld-linux.org Git - packages/widelands.git/blame - widelands.spec
- up to build15 (merge from DEVEL)
[packages/widelands.git] / widelands.spec
CommitLineData
7764f64d 1#
2# TODO:
11907a39 3# - create bcond for ggz
7764f64d 4#
509c89d9 5%define buildver 15
325beb53 6Summary: Game like Settlers II
bf6aa356 7Summary(pl.UTF-8): Remake gry Settlers II
325beb53 8Name: widelands
48449069 9Version: 0.build%{buildver}
509c89d9 10Release: 1
11907a39 11License: GPL v2+
325beb53 12Group: X11/Applications/Games
509c89d9 13Source0: http://launchpad.net/widelands/build%{buildver}/build%{buildver}/+download/%{name}-build%{buildver}-src.tar.bz2
14# Source0-md5: 5b2e2d0913272f66055e424f91360b1d
325beb53 15Source1: %{name}.desktop
509c89d9 16Patch0: %{name}-locale.patch
325beb53 17URL: http://widelands.sourceforge.net/
eaf6bd51 18BuildRequires: OpenGL-GLU-devel
19BuildRequires: OpenGL-devel
7764f64d 20BuildRequires: SDL-devel >= 1.2.11
68f512a6 21BuildRequires: SDL_gfx-devel
325beb53 22BuildRequires: SDL_image-devel
00129253 23BuildRequires: SDL_mixer-devel >= 1.2.7
325beb53 24BuildRequires: SDL_net-devel
7764f64d 25BuildRequires: SDL_ttf-devel >= 2.0.0
48449069 26BuildRequires: boost-devel >= 1.35
509c89d9 27BuildRequires: cmake
eaf6bd51 28BuildRequires: gettext-devel
509c89d9 29BuildRequires: libjpeg-devel
929f8735 30BuildRequires: libpng-devel
325beb53 31BuildRequires: libstdc++-devel
509c89d9 32BuildRequires: libtiff-devel
48449069 33Requires: SDL_image >= 1.2.10
325beb53
AG
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37In Widelands, you are the regent of a small tribe. You start out with
38nothing but your headquarters, a kind of castle in which all your
39resources are stored. Every member of your tribe will do his or her
40part to produce more resources - wood, food, iron, gold and more - to
41further this growth. But you are not alone in the world, and you will
42meet other tribes sooner or later. Some of them may be friendly and
43trade with you. However, if you want to rule the world, you will have
44to train soldiers and fight.
45
d71c4d09
JR
46%description -l pl.UTF-8
47W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
48grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
49przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
50wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
51żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
52nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
53spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
54nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
55światem, będziesz musiał wyszkolić żołnierzy i walczyć.
325beb53
AG
56
57%prep
509c89d9 58%setup -q -n %{name}-build%{buildver}-src
59%patch0 -p1
325beb53
AG
60
61%build
509c89d9 62install -d build
63cd build
64%cmake \
65 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
66 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
67 -DWL_INSTALL_BINDIR=%{_bindir} \
68 -DWL_INSTALL_DATADIR=%{_datadir}/games/%{name} \
69 -DWL_INSTALL_LOCALEDIR=%{_datadir}/games/%{name}/locale \
70%if "%{_lib}" == "lib64"
71 -DLIB_SUFFIX=64 \
72%endif
73 ..
74
75%{__make}
325beb53
AG
76
77%install
78rm -rf $RPM_BUILD_ROOT
325beb53 79
509c89d9 80%{__make} -C build install \
81 DESTDIR=$RPM_BUILD_ROOT
bb198b26 82
83install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
325beb53 84
bb198b26 85install pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
86cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
325beb53
AG
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%files
92%defattr(644,root,root,755)
48449069 93%doc ChangeLog CREDITS
bb198b26 94%attr(755,root,root) %{_bindir}/%{name}
48449069 95%dir %{_datadir}/games/%{name}
96%{_datadir}/games/%{name}/VERSION
97%{_datadir}/games/%{name}/campaigns
98%{_datadir}/games/%{name}/fonts
99%{_datadir}/games/%{name}/global
100%{_datadir}/games/%{name}/maps
101%{_datadir}/games/%{name}/music
102%{_datadir}/games/%{name}/pics
103%{_datadir}/games/%{name}/sound
104%{_datadir}/games/%{name}/tribes
105%{_datadir}/games/%{name}/txts
106%{_datadir}/games/%{name}/worlds
107%dir %{_datadir}/games/%{name}/locale
509c89d9 108%lang(ar) %{_datadir}/games/%{name}/locale/ar
109%lang(ca) %{_datadir}/games/%{name}/locale/ca
110%lang(cs) %{_datadir}/games/%{name}/locale/cs
111%lang(da) %{_datadir}/games/%{name}/locale/da
112%lang(de) %{_datadir}/games/%{name}/locale/de
113%lang(en_GB) %{_datadir}/games/%{name}/locale/en_GB
114%lang(eo) %{_datadir}/games/%{name}/locale/eo
115%lang(es) %{_datadir}/games/%{name}/locale/es
116%lang(eu) %{_datadir}/games/%{name}/locale/eu
117%lang(fi) %{_datadir}/games/%{name}/locale/fi
118%lang(fr) %{_datadir}/games/%{name}/locale/fr
119%lang(gl) %{_datadir}/games/%{name}/locale/gl
120%lang(he) %{_datadir}/games/%{name}/locale/he
121%lang(hu) %{_datadir}/games/%{name}/locale/hu
122%lang(ia) %{_datadir}/games/%{name}/locale/ia
123%lang(id) %{_datadir}/games/%{name}/locale/id
124%lang(it) %{_datadir}/games/%{name}/locale/it
125%lang(ja) %{_datadir}/games/%{name}/locale/ja
126%lang(la) %{_datadir}/games/%{name}/locale/la
127%lang(nl) %{_datadir}/games/%{name}/locale/nl
128%lang(nn) %{_datadir}/games/%{name}/locale/nn
129%lang(pl) %{_datadir}/games/%{name}/locale/pl
130%lang(pt_BR) %{_datadir}/games/%{name}/locale/pt_BR
131%lang(ru) %{_datadir}/games/%{name}/locale/ru
132%lang(si) %{_datadir}/games/%{name}/locale/si
133%lang(sk) %{_datadir}/games/%{name}/locale/sk
134%lang(sl) %{_datadir}/games/%{name}/locale/sl
135%lang(sr) %{_datadir}/games/%{name}/locale/sr
136%lang(sv) %{_datadir}/games/%{name}/locale/sv
bb198b26 137%{_desktopdir}/%{name}.desktop
138%{_pixmapsdir}/%{name}.png
This page took 0.114927 seconds and 4 git commands to generate.