]> git.pld-linux.org Git - packages/wget2.git/blobdiff - wget2.spec
- updated to 2.1.0
[packages/wget2.git] / wget2.spec
index b563ee126121de9196ec093ef7c152ed589c2715..d72959dbc96c9e226a64d8c4b508284236e09888 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Conditional build:
 %bcond_without tests   # check target
 %bcond_with    gnutls  # use GnuTLS (wget default) instead of OpenSSL
@@ -12,26 +13,27 @@ Summary(ru.UTF-8):  Утилита для получения файлов по п
 Summary(uk.UTF-8):     Утиліта для отримання файлів по протоколам HTTP та FTP
 Summary(zh_CN.UTF-8):  [通讯]功能强大的下载程序,支持断点续传
 Name:          wget2
-Version:       1.99.2
-Release:       2
+Version:       2.1.0
+Release:       1
 License:       GPL v3+ with OpenSSL exception
 Group:         Networking/Utilities
 Source0:       https://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.lz
-# Source0-md5: a611727632b4d81cb894621ce01a435d
+# Source0-md5: 0ec2d5738a19967e90e26e3f28f83339
 URL:           http://www.gnu.org/software/wget/
 BuildRequires: bzip2-devel
 BuildRequires: doxygen
+BuildRequires: gettext-tools >= 0.21
 # >= 3.6.3 for TLSv1.3
 %{?with_gnutls:BuildRequires:  gnutls-devel >= 3.0.16}
 BuildRequires: gpgme-devel
 BuildRequires: libbrotli-devel
 BuildRequires: libhsts-devel
-BuildRequires: libidn2-devel
+BuildRequires: libidn2-devel >= 0.14.0
 BuildRequires: libmicrohttpd-devel
 BuildRequires: libpsl-devel >= 0.16.0
+BuildRequires: lzlib-devel
 BuildRequires: nghttp2-devel
-# >= 1.1.0 for TLSv1.3
-%{!?with_gnutls:BuildRequires: openssl-devel >= 1.0.1}
+%{!?with_gnutls:BuildRequires: openssl-devel >= 1.1.0}
 %{?with_pandoc:BuildRequires:  pandoc}
 BuildRequires: pcre2-8-devel
 BuildRequires: pkgconfig
@@ -39,10 +41,7 @@ BuildRequires:       tar >= 1:1.22
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
 BuildRequires: zstd-devel
-%{?with_gnutls:Requires:       gnutls-libs >= 3.0.16}
-Requires:      libpsl >= 0.16.0
 Requires:      libwget2 = %{version}-%{release}
-%{!?with_gnutls:Requires:      openssl >= 1.0.1}
 Provides:      webclient
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -117,12 +116,20 @@ Proxy серверів, настроюваність.
 
 %package -n libwget2
 Summary:       Library that provides the basic functions needed by a web client
+Summary(pl.UTF-8):     Biblioteka udostępniająca podstawowe funkcje klienta WWW
 License:       LGPL v3+
 Group:         Libraries
+%{?with_gnutls:Requires:       gnutls-libs >= 3.0.16}
+Requires:      libidn2 >= 0.14.0
+Requires:      libpsl >= 0.16.0
+%{!?with_gnutls:Requires:      openssl >= 1.1.0}
 
 %description -n libwget2
 Library that provides the basic functions needed by a web client.
 
+%description -n libwget2 -l pl.UTF-8
+Biblioteka udostępniająca podstawowe funkcje klienta WWW.
+
 %package -n libwget2-devel
 Summary:       Header files for wget2 library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki wget2
@@ -155,21 +162,20 @@ Statyczna biblioteka wget2.
 %build
 %configure \
        LDCONFIG=true \
-       --with-linux-crypto \
-       %{!?with_gnutls:--with-openssl=yes} \
-       --with-ssl%{!?with_gnutls:=openssl} \
-       --with-libpsl \
-       --with-libhsts \
-       --with-libnghttp2 \
+       --disable-silent-rules \
        --with-bzip2 \
        --with-gpgme \
-       --with-zlib \
-       --with-lzma \
+       --with-libhsts \
        --with-libidn2 \
-       --with-libpcre2 \
        --with-libmicrohttpd \
+       --with-libnghttp2 \
+       --with-libpcre2 \
+       --with-libpsl \
+       --with-linux-crypto \
+       --with-lzma \
        --with-plugin-support \
-       --disable-silent-rules \
+       --with-ssl%{!?with_gnutls:=openssl} \
+       --with-zlib \
        %{nil}
 %{__make}
 
@@ -182,7 +188,9 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm $RPM_BUILD_ROOT%{_bindir}/wget2_noinstall
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/wget2_noinstall
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libwget.la
 
 %if %{without pandoc}
 install -d $RPM_BUILD_ROOT%{_mandir}/man1
@@ -191,12 +199,12 @@ cp -p docs/man/man1/wget2.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 %find_lang %{name}
 
-%post -n libwget2 -p /sbin/ldconfig
-%postun -n libwget2 -p /sbin/ldconfig
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -n libwget2 -p /sbin/ldconfig
+%postun        -n libwget2 -p /sbin/ldconfig
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README.md
@@ -205,17 +213,16 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n libwget2
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libwget.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libwget.so.0
+%attr(755,root,root) %{_libdir}/libwget.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libwget.so.2
 
 %files -n libwget2-devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libwget.so
 %{_includedir}/wget.h
 %{_includedir}/wgetver.h
-%{_mandir}/man3/libwget*.3*
 %{_pkgconfigdir}/libwget.pc
-%{_libdir}/libwget.la
-%attr(755,root,root) %{_libdir}/libwget.so
+%{_mandir}/man3/libwget*.3*
 
 %files -n libwget2-static
 %defattr(644,root,root,755)
This page took 0.05015 seconds and 4 git commands to generate.