]> git.pld-linux.org Git - packages/wget.git/blame_incremental - wget.spec
- release 2 (by relup.sh)
[packages/wget.git] / wget.spec
... / ...
CommitLineData
1# TODO
2# - add --delete-remote patches:
3# - http://wget-bugs.ferrara.linux.it/issue9
4# - or http://osdir.com/ml/web.wget.patches/2005-09/msg00006.html
5# - add http://article.gmane.org/gmane.comp.web.wget.patches/2333
6#
7# Conditional build:
8%bcond_without tests # check target
9%bcond_without metalink # build without metalink support
10%bcond_with gnutls # use GnuTLS (wget default) instead of OpenSSL
11
12Summary: A utility for retrieving files using the HTTP or FTP protocols
13Summary(es.UTF-8): Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
14Summary(fr.UTF-8): Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
15Summary(pl.UTF-8): Wsadowy klient HTTP/FTP
16Summary(pt_BR.UTF-8): Cliente na linha de comando para baixar arquivos WWW/FTP com recursão opcional
17Summary(ru.UTF-8): Утилита для получения файлов по протоколам HTTP и FTP
18Summary(uk.UTF-8): Утиліта для отримання файлів по протоколам HTTP та FTP
19Summary(zh_CN.UTF-8): [通讯]功能强大的下载程序,支持断点续传
20Name: wget
21Version: 1.20.1
22Release: 2
23License: GPL v3+ with OpenSSL exception
24Group: Networking/Utilities
25Source0: http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.lz
26# Source0-md5: 183af2e886e42aa501d3e6f3992b3344
27Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
28# Source1-md5: d8b2b56ec7461606c22edbafaf8a418f
29Patch0: %{name}-info.patch
30Patch1: %{name}-wgetrc_path.patch
31Patch2: %{name}-home_etc.patch
32Patch3: %{name}-ssl-certs.patch
33Patch4: user.xdg.origin.url.patch
34URL: http://www.gnu.org/software/wget/
35BuildRequires: autoconf >= 2.63
36BuildRequires: automake >= 1:1.9
37BuildRequires: gettext-tools >= 0.19.8
38# >= 3.6.3 for TLSv1.3
39%{?with_gnutls:BuildRequires: gnutls-devel >= 3.0.16}
40%{?with_metalink:BuildRequires: gpgme-devel >= 0.4.2}
41BuildRequires: libidn2-devel
42%{?with_metalink:BuildRequires: libmetalink-devel}
43BuildRequires: libpsl-devel >= 0.16.0
44BuildRequires: libuuid-devel
45# >= 1.1.0 for TLSv1.3
46%{!?with_gnutls:BuildRequires: openssl-devel >= 1.0.1}
47BuildRequires: pcre2-8-devel
48BuildRequires: perl-devel
49BuildRequires: pkgconfig
50BuildRequires: tar >= 1:1.22
51BuildRequires: texinfo
52BuildRequires: xz
53BuildRequires: zlib-devel
54%if %{with tests}
55BuildRequires: perl-HTTP-Daemon
56BuildRequires: perl-HTTP-Message
57BuildRequires: perl-IO-Socket-SSL
58BuildRequires: python3-modules >= 1:3.0
59%endif
60Provides: webclient
61%{?with_gnutls:Requires: gnutls-libs >= 3.0.16}
62%{!?with_gnutls:Requires: openssl >= 1.0.1}
63Requires: libpsl >= 0.16.0
64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66%define _noautoreqfiles %{_bindir}/rmold
67
68%description
69GNU Wget is a file retrieval utility which can use either the HTTP or
70FTP protocols. Wget features include the ability to work in the
71background while you're logged out, recursive retrieval of
72directories, file name wildcard matching, remote file timestamp
73storage and comparison, use of Rest with FTP servers and Range with
74HTTP servers to retrieve files over slow or unstable connections,
75support for Proxy servers, and configurability.
76
77%description -l es.UTF-8
78GNU wget es una herramienta de red para bajar archivos usando HTTP y
79FTP. Funciona en modo no interactivo, pudiendo trabajar en background.
80Funciona muy bien, incluso en conexiones lentas o inestables, bajando
81el archivo hasta que sea completamente recibido.
82
83%description -l fr.UTF-8
84GNU Wget est un utilitaire pour récupérer des fichiers qui peut
85utiliser indifféremment les protocoles HTTP ou FTP. Parmi les
86caractéristiques de Wget, citons la capacité à récupérer des fichiers
87en arrière-plan alors que vous n'êtes pas connecté, la récupération
88récursive de répertoires, la capacité de récupérer des fichiers en
89appliquant un filtre sur le nom ou sur la date, la gestion de Rest
90avec les serveurs FTP et de Range avec les serveurs HTTP pour
91récupérer des fichiers avec une connexion lente ou instable, le
92support des serveurs Proxy... Wget est particulièrement configurable.
93
94%description -l ja.UTF-8
95GNU wget は HTTP か FTP プロトコルのどちらかを使用することができる
96ファイルを取得するユーティリティです。wget はログアウトしている
97間にバックグラウンドで働く特徴をもっていること、ディレクトリの再帰的
98取得、ファイルネームのワイルドカードマッチング、ファイルのタイムスタンプの
99保存と比較、遅く不安定な接続で FTP サーバの Rest と HTTP サーバの
100Range の使用、プロキシーサーバのサポートと設定の容易さを含んだ特徴を
101もっています。
102
103%description -l pl.UTF-8
104Wget jest klientem FTP/HTTP przeznaczonym do ściągania zasobów
105wsadowo. Umożliwia ściąganie zasobów z podkatalogami, a także ma opcje
106umożliwiające wykonanie lokalnej kopii zasobów (mirror). W razie
107niemożności dostania się do zasobów lub gdy połączenie z serwerem
108FTP/HTTP zostanie zerwane, może automatycznie ponawiać próby
109kopiowania. Jest także dobrze przystosowany do tego, żeby uruchamiać
110go jako zadanie z crona.
111
112%description -l pt_BR.UTF-8
113O GNU wget é uma ferramenta de rede para baixar arquivos usando HTTP e
114FTP. Ele funciona em modo não interativo, podendo trabalhar em
115background. Funciona muito bem, mesmo em conexões lentas ou instáveis,
116baixando o arquivo até que ele seja completamente recebido.
117
118%description -l ru.UTF-8
119GNU Wget - это утилита командной строки для получения файлов по
120протоколам FTP и HTTP. Среди возможностей Wget - работа в фоновом
121режиме когда вы выходите из системы, рекурсивное извлечение каталогов,
122выбор файлов по шаблону, сравнение времени удаленных и локальных
123файлов, сохранение времени удаленных файлов при загрузке,
124использование REST с FTP серверами и Range с HTTP серверами для
125загрузки файлов по медленным или нестабильным каналам, поддержка Proxy
126серверов, конфигурируемость.
127
128%description -l uk.UTF-8
129GNU Wget - це утиліта командного рядка для отримання файлів по
130протоколам FTP та HTTP. Серед можливостей Wget - робота в фоновому
131режимі коли ви виходите із системи, рекурсивне отримання каталогів,
132вибір файлів по шаблону, порівняння часу віддалених та локальних
133файлів, збереження часу віддалених файлів при завантаженні,
134використання REST з FTP серверами та Range з HTTP серверами для
135завантаження файлів по повільним чи нестабільним каналам, підтримка
136Proxy серверів, настроюваність.
137
138%prep
139%setup -q
140%patch0 -p1
141%patch1 -p1
142%patch2 -p1
143%patch3 -p1
144%patch4 -p1
145
146%{__rm} doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion po/stamp-po
147
148# temp hack for 1.13.4
149test -e build-aux/bzr-version-gen || cat <<EOF > build-aux/bzr-version-gen
150#!/bin/sh
151echo -n %{version}
152EOF
153chmod +x build-aux/bzr-version-gen
154
155%build
156%{__gettextize}
157%{__aclocal} -I m4
158%{__autoheader}
159%{__autoconf}
160%{__automake}
161%configure \
162 --enable-digest \
163 --enable-ipv6 \
164 --enable-iri \
165 --enable-largefile \
166 --enable-nls \
167 --enable-ntlm \
168 --enable-opie \
169 --enable-pcre \
170 --disable-silent-rules \
171 --with-libpsl \
172 %{__with_without metalink} \
173 --with-ssl%{!?with_gnutls:=openssl} \
174 --with-zlib \
175 %{nil}
176%{__make}
177tail -n 6 util/README >rmold.README
178
179# 1.13.4 tarball was buggy and produced empty version.
180grep %{version} src/version.c
181
182%{?with_tests:%{__make} check}
183
184%install
185rm -rf $RPM_BUILD_ROOT
186install -d $RPM_BUILD_ROOT%{_sysconfdir}
187
188%{__make} install \
189 DESTDIR=$RPM_BUILD_ROOT \
190 GETTEXT_PACKAGE=wget
191
192install -p util/rmold.pl $RPM_BUILD_ROOT%{_bindir}/rmold
193cp -a doc/sample.wgetrc $RPM_BUILD_ROOT%{_sysconfdir}/wgetrc
194
195bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
196%{__rm} $RPM_BUILD_ROOT%{_mandir}/README*
197rm -f $RPM_BUILD_ROOT%{_infodir}/dir
198
199%find_lang %{name}
200
201%clean
202rm -rf $RPM_BUILD_ROOT
203
204%post -p /sbin/postshell
205-/usr/sbin/fix-info-dir -c %{_infodir}
206
207%postun -p /sbin/postshell
208-/usr/sbin/fix-info-dir -c %{_infodir}
209
210%files -f %{name}.lang
211%defattr(644,root,root,755)
212%doc AUTHORS ChangeLog NEWS README MAILING-LIST rmold.README
213%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}rc
214%attr(755,root,root) %{_bindir}/rmold
215%attr(755,root,root) %{_bindir}/wget
216%{_mandir}/man1/wget.1*
217%{_mandir}/hu/man1/wget.1*
218%{_mandir}/pl/man1/wget.1*
219%{_infodir}/wget.info*
This page took 0.091406 seconds and 4 git commands to generate.