]> git.pld-linux.org Git - packages/web2ldap.git/blobdiff - web2ldap.spec
- release 2
[packages/web2ldap.git] / web2ldap.spec
index d1d58043346e3a33ab93aba42fd7edd869bb000b..203bd9bdc1613b40f5d274e90c0745f6797155eb 100644 (file)
@@ -1,15 +1,20 @@
 Summary:       WWW gateway to LDAP server
-Summary(pl):   Bramka WWW do serwera LDAP
+Summary(pl.UTF-8):     Bramka WWW do serwera LDAP
 Name:          web2ldap
-Version:       0.15.4
-Release:       1
+Version:       1.1.0rc1
+Release:       2
 License:       distributable (mostly GPL)
 Group:         Applications
 Source0:       http://www.web2ldap.de/download/%{name}-%{version}.tar.gz
-# Source0-md5: 068b7c7cb54439cac233fcc0b4dc9e4f
-# Source0-size:        224672
+# Source0-md5: dd51bfcc7a639f90ca9c29a2bb977f48
+Source1:       %{name}.tmpfiles
 Patch0:                %{name}-config.patch
+Patch1:                %{name}-paths.patch
 URL:           http://www.web2ldap.de/
+BuildRequires: python-modules
+BuildRequires: rpm-pythonprov
+Requires:      python-pyasn1
+Requires:      python-pyasn1_modules
 %pyrequires_eq python-modules
 Requires:      python-ldap
 Requires:      python-pyweblib
@@ -18,32 +23,33 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 This is:
-- a generic LDAPv3 client which does not make any assumptions about the tree
-  structure or LDAP schema.
-- kind of a swiss-army knife for accessing/manipulating LDAP servers without
-  having to configure anything.
+- a generic LDAPv3 client which does not make any assumptions about
+  the tree structure or LDAP schema.
+- kind of a swiss-army knife for accessing/manipulating LDAP servers
+  without having to configure anything.
 - a secure LDAP client with clean login behaviour.
-- a schema browser which displays references/dependencies within an LDAPv3
-  schema.
+- a schema browser which displays references/dependencies within an
+  LDAPv3 schema.
 - continously maintained software.
 
-%description -l pl
+%description -l pl.UTF-8
 To jest:
-- ogólny klient LDAPv3, nie czyni±cy ¿adnych za³o¿eñ dotycz±cych
-  struktury drzewa ani schemacie LDAP
-- narzêdzie do dostêpu i manipulacji na serwerach LDAP bez potrzeby
-  konfigurowania niczego
-- bezpieczny klient LDAP czysto loguj±cy siê
-- przegl±darka schematów wy¶wietlaj±ca odwo³ania i zale¿no¶ci wewn±trz
+- ogólny klient LDAPv3, nie czyniący żadnych założeń dotyczących
+  struktury drzewa ani schematu LDAP
+- narzędzie do dostępu i manipulacji na serwerach LDAP bez potrzeby
+  konfiguracji
+- bezpieczny klient LDAP czysto logujący się
+- przeglądarka schematów wyświetlająca odwołania i zależności wewnątrz
   schematu LDAPv3
 - stale utrzymywane oprogramowanie.
 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
-for dir in pylib sbin fcgi scgi; do
+for dir in pylib sbin fcgi; do
        python -c "import compileall; compileall.compile_dir('$dir')"
        python -O -c "import compileall; compileall.compile_dir('$dir')"
 done
@@ -51,26 +57,29 @@ done
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},%{_datadir}/%{name}/htdocs} \
-               $RPM_BUILD_ROOT/var{/run,/lib,/log}/%{name}
+               $RPM_BUILD_ROOT/var{/run,/lib,/log}/%{name} \
+               $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
 
-cp -R etc/web2ldap $RPM_BUILD_ROOT%{_sysconfdir}
-cp -R fcgi pylib scgi sbin $RPM_BUILD_ROOT%{_datadir}/%{name}
-cp -R htdocs/css $RPM_BUILD_ROOT%{_datadir}/%{name}/htdocs
+cp -a etc/web2ldap $RPM_BUILD_ROOT%{_sysconfdir}
+cp -a fcgi pylib sbin $RPM_BUILD_ROOT%{_datadir}/%{name}
+cp -a htdocs/css $RPM_BUILD_ROOT%{_datadir}/%{name}/htdocs
 find $RPM_BUILD_ROOT%{_datadir}/%{name}/pylib -name "*.py" | xargs rm
-rm $RPM_BUILD_ROOT%{_datadir}/%{name}/sbin/compile*
-rm $RPM_BUILD_ROOT%{_datadir}/%{name}/sbin/*.py
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/sbin/compile*
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/sbin/*.py
 echo '#!/bin/sh' > $RPM_BUILD_ROOT%{_sbindir}/%{name}
 echo 'exec python %{_datadir}/%{name}/sbin/%{name}.pyc $*' \
        >> $RPM_BUILD_ROOT%{_sbindir}/%{name}
 
+install %{SOURCE1} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc htdocs/* etc/httpd
+%doc AUTHORS README htdocs/* etc/httpd
 %attr(755,root,root) %{_sbindir}/*
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
 
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/pylib
@@ -81,8 +90,5 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_datadir}/%{name}/fcgi/web2ldap.py
 %{_datadir}/%{name}/fcgi/*.py[co]
 
-%dir %{_datadir}/%{name}/scgi
-%attr(755,root,root) %{_datadir}/%{name}/scgi/web2ldap.py
-%{_datadir}/%{name}/scgi/*.py[co]
-
+/usr/lib/tmpfiles.d/%{name}.conf
 %dir %attr(775,root,http) /var/*/%{name}
This page took 0.931843 seconds and 4 git commands to generate.