]> git.pld-linux.org Git - packages/wayland.git/blame_incremental - wayland.spec
up to 1.21.0
[packages/wayland.git] / wayland.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # don't build API documentation
4%bcond_without static_libs # don't build static libraries
5
6Summary: Wayland - protocol for a compositor to talk to its clients
7Summary(pl.UTF-8): Wayland - protokół między serwerem składającym a klientami
8Name: wayland
9Version: 1.21.0
10Release: 1
11License: MIT
12Group: Libraries
13#Source0Download: https://gitlab.freedesktop.org/wayland/wayland/-/releases/
14Source0: https://gitlab.freedesktop.org/wayland/wayland/-/releases/%{version}/downloads/%{name}-%{version}.tar.xz
15# Source0-md5: f2653a2293bcd882d756c6a83d278903
16URL: https://wayland.freedesktop.org/
17BuildRequires: expat-devel >= 1.95
18BuildRequires: libffi-devel >= 3
19# for DTD valudation
20BuildRequires: libxml2-devel >= 2.0
21BuildRequires: meson >= 0.52.1
22BuildRequires: ninja
23BuildRequires: pkgconfig
24%if %{with apidocs}
25BuildRequires: docbook-style-xsl-nons
26BuildRequires: doxygen >= 1.6.0
27BuildRequires: graphviz >= 2.26.0
28BuildRequires: libxslt-progs
29BuildRequires: rpm-build >= 4.6
30BuildRequires: rpmbuild(macros) >= 1.752
31BuildRequires: tar >= 1:1.22
32BuildRequires: xmlto
33BuildRequires: xz
34%endif
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Wayland is a project to define a protocol for a compositor to talk to
39its clients as well as a library implementation of the protocol. The
40compositor can be a standalone display server running on Linux kernel
41modesetting and evdev input devices, an X application, or a Wayland
42client itself. The clients can be traditional applications, X servers
43(rootless or fullscreen) or other display servers.
44
45%description -l pl.UTF-8
46Wayland to projekt definiujący protokół między serwerem składającym a
47klientami, a także biblioteki implementujące ten protokół. Serwer
48składający może być samodzielnym serwerem wyświetlającym działającym
49na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
50aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
51aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
52wyświetlające.
53
54%package devel
55Summary: Header files for Wayland libraries
56Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Wayland
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: libffi-devel
60
61%description devel
62Header files for Wayland libraries.
63
64%description devel -l pl.UTF-8
65Pliki nagłówkowe bibliotek Wayland.
66
67%package static
68Summary: Static Wayland libraries
69Summary(pl.UTF-8): Statyczne biblioteki Wayland
70Group: Development/Libraries
71Requires: %{name}-devel = %{version}-%{release}
72
73%description static
74Static Wayland libraries.
75
76%description static -l pl.UTF-8
77Statyczne biblioteki Wayland.
78
79%package egl
80Summary: Wayland EGL library
81Summary(pl.UTF-8): Biblioteka Wayland EGL
82Group: Libraries
83Obsoletes: Mesa-libwayland-egl
84
85%description egl
86Wayland EGL library.
87
88%description egl -l pl.UTF-8
89Biblioteka Wayland EGL.
90
91%package egl-devel
92Summary: Header files for Wayland EGL library
93Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Wayland EGL
94Group: Development/Libraries
95Requires: %{name}-devel = %{version}-%{release}
96Requires: %{name}-egl = %{version}-%{release}
97Obsoletes: Mesa-libwayland-egl-devel
98
99%description egl-devel
100Header files for Wayland EGL library.
101
102%description egl-devel -l pl.UTF-8
103Pliki nagłówkowe biblioteki Wayland EGL.
104
105%package egl-static
106Summary: Static Wayland EGL library
107Summary(pl.UTF-8): Statyczna biblioteka Wayland EGL
108Group: Development/Libraries
109Requires: %{name}-egl-devel = %{version}-%{release}
110
111%description egl-static
112Static Wayland EGL library.
113
114%description egl-static -l pl.UTF-8
115Statyczna biblioteka Wayland EGL.
116
117%package apidocs
118Summary: Wayland API and protocol documentation
119Summary(pl.UTF-8): Dokumentacja API biblioteki oraz protokołu Wayland
120Group: Documentation
121BuildArch: noarch
122
123%description apidocs
124Wayland API and protocol documentation.
125
126%description apidocs -l pl.UTF-8
127Dokumentacja API biblioteki oraz protokołu Wayland.
128
129%prep
130%setup -q
131
132%build
133%meson build \
134 %{!?with_apidocs:-Ddocumentation=false} \
135 %{!?with_static_libs:--default-library=shared}
136
137%ninja_build -C build
138
139%install
140rm -rf $RPM_BUILD_ROOT
141
142%ninja_install -C build
143
144%if %{with apidocs}
145# packaged as %doc in -devel
146%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
147%endif
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%post -p /sbin/ldconfig
153%postun -p /sbin/ldconfig
154
155%files
156%defattr(644,root,root,755)
157%doc COPYING CONTRIBUTING.md README
158%attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
159%attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
160%attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
161%attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
162%attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
163%attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
164
165%files devel
166%defattr(644,root,root,755)
167%attr(755,root,root) %{_bindir}/wayland-scanner
168%attr(755,root,root) %{_libdir}/libwayland-client.so
169%attr(755,root,root) %{_libdir}/libwayland-cursor.so
170%attr(755,root,root) %{_libdir}/libwayland-server.so
171%{_includedir}/wayland-client*.h
172%{_includedir}/wayland-cursor.h
173%{_includedir}/wayland-server*.h
174%{_includedir}/wayland-util.h
175%{_includedir}/wayland-version.h
176%dir %{_datadir}/wayland
177%{_datadir}/wayland/wayland.dtd
178%{_datadir}/wayland/wayland.xml
179%{_datadir}/wayland/wayland-scanner.mk
180%{_pkgconfigdir}/wayland-client.pc
181%{_pkgconfigdir}/wayland-cursor.pc
182%{_pkgconfigdir}/wayland-scanner.pc
183%{_pkgconfigdir}/wayland-server.pc
184%{_aclocaldir}/wayland-scanner.m4
185%if %{with apidocs}
186%{_mandir}/man3/wl_*.3*
187%endif
188# NOTE: temporarily here because they're used but not included in Mesa 18.1.x
189# TODO: move to -egl-devel after transition to Mesa 18.2.x
190%{_includedir}/wayland-egl.h
191%{_includedir}/wayland-egl-core.h
192
193%if %{with static_libs}
194%files static
195%defattr(644,root,root,755)
196%{_libdir}/libwayland-client.a
197%{_libdir}/libwayland-cursor.a
198%{_libdir}/libwayland-server.a
199%endif
200
201%if %{with apidocs}
202%files apidocs
203%defattr(644,root,root,755)
204%doc build/doc/publican/html/* doc/publican/sources/{css,images}
205%endif
206
207%files egl
208%defattr(644,root,root,755)
209%attr(755,root,root) %{_libdir}/libwayland-egl.so.*.*.*
210%attr(755,root,root) %ghost %{_libdir}/libwayland-egl.so.1
211
212%files egl-devel
213%defattr(644,root,root,755)
214%attr(755,root,root) %{_libdir}/libwayland-egl.so
215%{_includedir}/wayland-egl-backend.h
216%{_pkgconfigdir}/wayland-egl.pc
217%{_pkgconfigdir}/wayland-egl-backend.pc
218
219%if %{with static_libs}
220%files egl-static
221%defattr(644,root,root,755)
222%{_libdir}/libwayland-egl.a
223%endif
This page took 0.072513 seconds and 4 git commands to generate.