]> git.pld-linux.org Git - packages/wayland.git/blame - wayland.spec
- updated to 1.0.2
[packages/wayland.git] / wayland.spec
CommitLineData
cea843df
JB
1#
2# Conditional build:
ceb71059 3%bcond_without apidocs # don't build API documentation
cea843df
JB
4%bcond_without static_libs # don't build static libraries
5#
6Summary: Wayland - protocol for a compositor to talk to its clients
7Summary(pl.UTF-8): Wayland - protokół między serwerem składającym a klientami
8Name: wayland
88a517df 9Version: 1.0.2
fabd73a3 10Release: 1
cea843df
JB
11License: MIT
12Group: Libraries
13Source0: http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
88a517df 14# Source0-md5: 06ff1707418a0be28a13518ff05f76db
ceb71059 15Patch0: %{name}-publican.patch
cea843df 16URL: http://wayland.freedesktop.org/
ceb71059
JB
17BuildRequires: autoconf >= 2.64
18BuildRequires: automake >= 1:1.11
19BuildRequires: doxygen
cea843df
JB
20BuildRequires: expat-devel
21BuildRequires: libffi-devel
ceb71059
JB
22BuildRequires: libtool >= 2:2.2
23BuildRequires: libxslt-progs
cea843df
JB
24BuildRequires: pkgconfig
25BuildRequires: pkgconfig(libffi)
ceb71059 26%{?with_apidocs:BuildRequires: publican >= 3}
cea843df
JB
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Wayland is a project to define a protocol for a compositor to talk to
31its clients as well as a library implementation of the protocol. The
32compositor can be a standalone display server running on Linux kernel
33modesetting and evdev input devices, an X application, or a Wayland
34client itself. The clients can be traditional applications, X servers
35(rootless or fullscreen) or other display servers.
36
37%description -l pl.UTF-8
38Wayland to projekt definiujący protokół między serwerem składającym a
39klientami, a także biblioteki implementujące ten protokół. Serwer
40składający może być samodzielnym serwerem wyświetlającym działającym
41na linuksowym kernel modesetting oraz urządzeniach wejściowych evdev,
42aplikacją X lub klientem Wayland. Klientami mogą być tradycyjne
43aplikacje, serwery X (rootless lub pełnoekranowe) lub inne serwery
44wyświetlające.
45
46%package devel
47Summary: Header files for Wayland libraries
48Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Wayland
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: libffi-devel
52
53%description devel
54Header files for Wayland libraries.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe bibliotek Wayland.
58
59%package static
60Summary: Static Wayland libraries
61Summary(pl.UTF-8): Statyczne biblioteki Wayland
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64
65%description static
66Static Wayland libraries.
67
68%description static -l pl.UTF-8
69Statyczne biblioteki Wayland.
70
ceb71059
JB
71%package apidocs
72Summary: Wayland API and protocol documentation
73Summary(pl.UTF-8): Dokumentacja API biblioteki oraz protokołu Wayland
74Group: Documentation
75
76%description apidocs
77Wayland API and protocol documentation.
78
79%description apidocs -l pl.UTF-8
80Dokumentacja API biblioteki oraz protokołu Wayland.
81
cea843df
JB
82%prep
83%setup -q
84
ceb71059
JB
85# this file is required by publican 3.0; publican patch adds it in en-US dir
86test ! -f doc/Wayland/en_US/Revision_History.xml
87
88%patch0 -p1
89
cea843df 90%build
ceb71059
JB
91%{__libtoolize}
92%{__aclocal} -I m4
93%{__autoconf}
94%{__autoheader}
95%{__automake}
cea843df
JB
96%configure \
97 --disable-silent-rules \
98 %{!?with_static_libs:--disable-static}
99%{__make}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103
104%{__make} install \
105 DESTDIR=$RPM_BUILD_ROOT
106
107# obsoleted by pkg-config
108%{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
cc8accbe
JB
109# packaged as %doc in -devel
110%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
cea843df
JB
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
118%files
119%defattr(644,root,root,755)
cc8accbe 120%doc COPYING README TODO
cea843df
JB
121%attr(755,root,root) %{_libdir}/libwayland-client.so.*.*.*
122%attr(755,root,root) %ghost %{_libdir}/libwayland-client.so.0
cc8accbe
JB
123%attr(755,root,root) %{_libdir}/libwayland-cursor.so.*.*.*
124%attr(755,root,root) %ghost %{_libdir}/libwayland-cursor.so.0
cea843df
JB
125%attr(755,root,root) %{_libdir}/libwayland-server.so.*.*.*
126%attr(755,root,root) %ghost %{_libdir}/libwayland-server.so.0
127
128%files devel
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_bindir}/wayland-scanner
131%attr(755,root,root) %{_libdir}/libwayland-client.so
cc8accbe 132%attr(755,root,root) %{_libdir}/libwayland-cursor.so
cea843df
JB
133%attr(755,root,root) %{_libdir}/libwayland-server.so
134%{_includedir}/wayland-*.h
135%{_pkgconfigdir}/wayland-client.pc
cc8accbe 136%{_pkgconfigdir}/wayland-cursor.pc
cea843df
JB
137%{_pkgconfigdir}/wayland-server.pc
138%{_aclocaldir}/wayland-scanner.m4
139%{_aclocaldir}/wayland-scanner.mk
ceb71059
JB
140%{_mandir}/man3/wl_display_connect.3*
141%{_mandir}/man3/wl_display_connect_to_fd*
cea843df
JB
142
143%if %{with static_libs}
144%files static
145%defattr(644,root,root,755)
146%{_libdir}/libwayland-client.a
cc8accbe 147%{_libdir}/libwayland-cursor.a
cea843df
JB
148%{_libdir}/libwayland-server.a
149%endif
ceb71059
JB
150
151%if %{with apidocs}
152%files apidocs
153%defattr(644,root,root,755)
154%doc doc/Wayland/Wayland/en-US/html/*
155%endif
This page took 0.170707 seconds and 4 git commands to generate.