]> git.pld-linux.org Git - packages/waf.git/blobdiff - waf.spec
- up to 1.7.15
[packages/waf.git] / waf.spec
index 130cf268b1839bd8c392242ee0bf69ff5d614fd8..e341b8c5f4c420adc90cb1dac3e766c9f47745c0 100644 (file)
--- a/waf.spec
+++ b/waf.spec
@@ -1,19 +1,24 @@
 Summary:       The Waf build system
 Summary(pl.UTF-8):     System budowania Waf
 Name:          waf
-Version:       1.4.2
-Release:       3
+Version:       1.7.15
+Release:       1
+# note: waf book is on CC-BY-NC-ND (not included in binary package)
 License:       BSD
 Group:         Development/Building
+#Source0Download: http://code.google.com/p/waf/downloads/list
 Source0:       http://waf.googlecode.com/files/%{name}-%{version}.tar.bz2
-# Source0-md5: 0d0c397ee675b2df79f65b375eb8a0f8
+# Source0-md5: a62272a3b4eb05b7e5842b4f9839cb98
+Patch0:                %{name}-path.patch
 URL:           http://code.google.com/p/waf/
-BuildRequires: python
+BuildRequires: python >= 1:2.6
+BuildRequires: python-modules >= 1:2.6
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.234
+Requires:      python(abi) = %{py_ver}
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _libdir %{_prefix}/lib
-
 %description
 Waf is a general-purpose build system which was modelled from Scons.
 Though it comes last in the arena of the build systems, we believe
@@ -28,29 +33,37 @@ Scons, Cmake, Ant itp.).
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
-export TERM=dumb
-./waf-light --make-waf
+# check waf-light
+extras=
+for f in waflib/extras/*.py ; do
+       tool=$(basename "$f" .py)
+       if [ "$tool" != "__init__" ]; then
+               extras="${extras:+$extras,}$tool"
+       fi
+done
+./waf-light --make-waf --strip --tools="$extras"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-echo y | ./waf install \
-       --prefix %{_prefix} \
-       --destdir $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_datadir}/waf/waflib/{Tools,extras}
+
+cp -p waflib/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib
+cp -p waflib/Tools/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/Tools
+cp -p waflib/extras/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/extras
+
+install -D -p waf-light $RPM_BUILD_ROOT%{_bindir}/waf
 
-%py_comp $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}-*
-%py_ocomp $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}-*
+%py_comp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
+%py_ocomp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README TODO
+%doc ChangeLog README TODO
 %attr(755,root,root) %{_bindir}/waf
-%dir %{_libdir}/%{name}-%{version}-*
-%dir %{_libdir}/%{name}-%{version}-*/wafadmin
-%{_libdir}/%{name}-%{version}-*/wafadmin/*.py[co]
-%dir %{_libdir}/%{name}-%{version}-*/wafadmin/Tools
-%{_libdir}/%{name}-%{version}-*/wafadmin/Tools/*.py[co]
+%{_datadir}/waf
This page took 0.033276 seconds and 4 git commands to generate.