]> git.pld-linux.org Git - packages/waf.git/blame - waf.spec
up to 1.9.11
[packages/waf.git] / waf.spec
CommitLineData
a4eae65c 1Summary: The Waf build system
1a3366fc 2Summary(pl.UTF-8): System budowania Waf
a4eae65c 3Name: waf
ffaa1a0d 4Version: 1.9.11
6a539a7a 5Release: 1
c9f31fb5 6# note: waf book is on CC-BY-NC-ND (not included in binary package)
a4eae65c
ER
7License: BSD
8Group: Development/Building
00844803 9Source0: http://waf.io/%{name}-%{version}.tar.bz2
ffaa1a0d 10# Source0-md5: ba28942df5d03a2e411de16865d36a71
9c06b44f 11Patch0: %{name}-path.patch
00844803 12URL: http://waf.io/
c9f31fb5
JB
13BuildRequires: python >= 1:2.6
14BuildRequires: python-modules >= 1:2.6
12557f0e 15BuildRequires: rpm-pythonprov
2110cbf6 16BuildRequires: rpmbuild(macros) >= 1.234
c9f31fb5 17Requires: python(abi) = %{py_ver}
7a16ee04 18BuildArch: noarch
a4eae65c
ER
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
a4eae65c
ER
21%description
22Waf is a general-purpose build system which was modelled from Scons.
23Though it comes last in the arena of the build systems, we believe
24that Waf is a vastly superior alternative to its competitors
25(Autotools, Scons, Cmake, Ant, etc) for building software,
26
f7ccf166
JR
27%description -l pl.UTF-8
28Waf to system budowania ogólnego przeznaczenia opracowany na podstawie
29Scons. Mimo że pojawił się jako ostatni na arenie systemów budowania,
30autorzy wierzą, że przewyższa alternatywne narzędzia (Autotools,
67f52179
JB
31Scons, Cmake, Ant itp.).
32
a4eae65c
ER
33%prep
34%setup -q
9c06b44f 35%patch0 -p1
a4eae65c
ER
36
37%build
c9f31fb5
JB
38# check waf-light
39extras=
40for f in waflib/extras/*.py ; do
41 tool=$(basename "$f" .py)
42 if [ "$tool" != "__init__" ]; then
43 extras="${extras:+$extras,}$tool"
44 fi
45done
46./waf-light --make-waf --strip --tools="$extras"
a4eae65c
ER
47
48%install
49rm -rf $RPM_BUILD_ROOT
c9f31fb5
JB
50install -d $RPM_BUILD_ROOT%{_datadir}/waf/waflib/{Tools,extras}
51
52cp -p waflib/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib
53cp -p waflib/Tools/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/Tools
54cp -p waflib/extras/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/extras
55
56install -D -p waf-light $RPM_BUILD_ROOT%{_bindir}/waf
a4eae65c 57
c9f31fb5
JB
58%py_comp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
59%py_ocomp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
a4eae65c
ER
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
cb78d8a7 66%doc ChangeLog README.md
a4eae65c 67%attr(755,root,root) %{_bindir}/waf
c9f31fb5 68%{_datadir}/waf
This page took 0.139986 seconds and 4 git commands to generate.